]> git.pld-linux.org Git - packages/kodi.git/blame - xbmc.spec
- fix fps rate for MicroDVD subtitles
[packages/kodi.git] / xbmc.spec
CommitLineData
18b90c81
SP
1#
2# TODO:
3a71016a 3# - fix build flags - some files are compiled with -O3 and without rpm*flags
c1b45330 4# - fix linking argument order
63ff963e 5# - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
6# only libXrandr 1.1 - with no gamma support; it causes application crash
7# on XRRSetCrtcGamma function called by SDL_SetVideoMode)
92b96980 8# - add and/or fix users/groups permissions
63ff963e 9# - split to subpackages?
92b96980 10# - check how it works with external python libraries
18b90c81 11#
92b96980 12# Conditional build:
13%bcond_with external_python
9e98e23b 14%bcond_without goom
92b96980 15
18b90c81
SP
16Summary: XBMC
17Name: xbmc
f4f8f308 18Version: 10.1
ce408a01 19Release: 0.2
2e649bc9 20License: GPL v3
18b90c81 21Group: Applications/Multimedia
54721144 22Source0: http://www.softliste.de/xbmc/releases/source/%{name}-%{version}.tar.gz
f4f8f308 23# Source0-md5: 391398126cb86a4f6fbd0b7037997d84
b2f93b43 24Source1: goom_icon.png
25# Source1-md5: 8c0ffe2055f2cfde1189687d12a68aa8
18b90c81 26URL: http://xbmc.org
01f2a87d 27Patch0: %{name}-nobash.patch
63ff963e 28Patch1: %{name}-python27.patch
0aae19c0 29Patch2: %{name}-subtitle_tags.patch
b2f93b43 30Patch3: %{name}-goom_enable.patch
ce408a01 31Patch4: %{name}-fpsrate.patch
18b90c81
SP
32BuildRequires: SDL_image-devel
33BuildRequires: SDL_mixer-devel
c462fd57 34BuildRequires: a52dec-libs-devel
18b90c81
SP
35BuildRequires: alsa-lib-devel
36BuildRequires: autoconf
37BuildRequires: automake
38BuildRequires: avahi-devel
5a2f2b01 39BuildRequires: boost-devel
18b90c81
SP
40BuildRequires: bzip2-devel
41BuildRequires: cmake
42BuildRequires: curl-devel
43BuildRequires: dbus-devel
44BuildRequires: enca-devel
45BuildRequires: faac-devel
5a2f2b01 46BuildRequires: faad2-devel
c462fd57 47BuildRequires: ffmpeg-devel
5a2f2b01 48BuildRequires: flac-devel
18b90c81
SP
49BuildRequires: fontconfig-devel
50BuildRequires: freetype-devel
51BuildRequires: fribidi-devel
52BuildRequires: gawk
63ff963e 53BuildRequires: gettext-autopoint
5a2f2b01 54BuildRequires: gettext-devel
18b90c81
SP
55BuildRequires: glew-devel
56BuildRequires: gperf
5a2f2b01 57BuildRequires: gtk+-devel
58BuildRequires: hal-devel
59BuildRequires: jasper-devel
60BuildRequires: libao-devel
18b90c81 61BuildRequires: libcdio-devel
c462fd57 62BuildRequires: libdts-devel
18b90c81
SP
63BuildRequires: libjpeg-devel
64BuildRequires: libmad-devel
63ff963e 65BuildRequires: libmicrohttpd-devel
18b90c81 66BuildRequires: libmms-devel
63ff963e 67BuildRequires: libmodplug-devel
c462fd57 68BuildRequires: libmpeg2-devel
18b90c81 69BuildRequires: libogg-devel
5a2f2b01 70BuildRequires: libpng-devel
18b90c81
SP
71BuildRequires: libsamplerate-devel
72BuildRequires: libsmbclient-devel
5a2f2b01 73BuildRequires: libtiff-devel
74BuildRequires: libtool
75BuildRequires: libvdpau-devel
18b90c81 76BuildRequires: libvorbis-devel
5a2f2b01 77BuildRequires: lzo-devel
78BuildRequires: mysql-devel
c1b45330 79%ifarch %{ix86}
26cae375 80BuildRequires: nasm
c1b45330 81%endif
18b90c81 82BuildRequires: openssl-devel
63ff963e 83BuildRequires: pcre-cxx-devel
5a2f2b01 84BuildRequires: pkgconfig
18b90c81 85BuildRequires: pulseaudio-devel
c462fd57 86BuildRequires: python-devel
3a71016a 87BuildRequires: rpm-pythonprov
6f41c837 88BuildRequires: rpmbuild(macros) >= 1.566
c462fd57 89# used internally
90BuildRequires: sed >= 4.0
18b90c81 91BuildRequires: sqlite3-devel
5a2f2b01 92BuildRequires: unzip
c462fd57 93BuildRequires: wavpack-devel
5a2f2b01 94BuildRequires: xmms-devel
95BuildRequires: xorg-lib-libXinerama-devel
18b90c81 96BuildRequires: xorg-lib-libXrandr-devel
5a2f2b01 97BuildRequires: xorg-lib-libXtst-devel
18b90c81
SP
98BuildRequires: zip
99BuildRequires: zlib-devel
63ff963e 100Requires: /usr/bin/glxinfo
f4f8f308 101Requires: SDL >= 1.2.14-5
a58652d4
SP
102Requires: lsb-release
103Requires: xorg-app-xdpyinfo
18b90c81
SP
104BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106%description
107
108%prep
c1b45330 109%setup -q
01f2a87d 110%patch0 -p1
bfde9a19 111%undos xbmc/lib/libPython/xbmcmodule/xbmcaddonmodule.cpp
51b524ca 112%patch1 -p1
0aae19c0 113%patch2 -p1
b2f93b43 114%patch3 -p1
ce408a01 115%patch4 -p1
18b90c81
SP
116
117%build
118./bootstrap
65712ad3 119%configure \
51b524ca
KK
120 --disable-debug \
121 --enable-external-libraries \
9e98e23b 122 --%{?with_external_python:en}%{!?with_external_python:dis}able-external-python \
123 --%{?with_goom:en}%{!?with_goom:dis}able-goom
18b90c81
SP
124%{__make}
125
126%install
127rm -rf $RPM_BUILD_ROOT
128
129%{__make} install \
92b96980 130 DESTDIR=$RPM_BUILD_ROOT
b2f93b43 131 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/xbmc/addons/visualization.goom/icon.png
18b90c81
SP
132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%files
137%defattr(644,root,root,755)
47308569 138#doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
18b90c81 139
47308569 140#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
18b90c81
SP
141%attr(755,root,root) %{_bindir}/*
142%{_datadir}/%{name}
92b96980 143%attr(755,root,root) %{_libdir}/%{name}
144%{_docdir}/%{name}
c1b45330 145%{_desktopdir}/%{name}.desktop
92b96980 146%{_iconsdir}/hicolor/256x256/apps/%{name}.png
147%{_iconsdir}/hicolor/48x48/apps/%{name}.png
3a71016a 148%{_datadir}/xsessions/XBMC.desktop
This page took 0.054549 seconds and 4 git commands to generate.