]> git.pld-linux.org Git - packages/weston.git/blame - weston.spec
- rebuild with expat 2.1.0
[packages/weston.git] / weston.spec
CommitLineData
3adcb0b8
JB
1#
2# Conditional build:
0cb34c60 3%bcond_without drm # DRM compositor
3adcb0b8 4%bcond_with openwfd # OpenWF compositor
0cb34c60
JB
5%bcond_without wayland # wayland (nested) compositor
6%bcond_without x11 # X11 compositor
7%bcond_without wlaunch # weston launch
8%bcond_without xwayland # X server launcher
9%bcond_without sclients # simple clients
6c4f66d1 10%bcond_without clients # non-simple + full GL clients
3adcb0b8
JB
11#
12Summary: Weston - Wayland demos
13Summary(pl.UTF-8): Weston - programy demonstracyjne dla protokołu Wayland
14Name: weston
9c19f94f 15Version: 1.0.0
eed29e52 16Release: 2
3adcb0b8
JB
17License: MIT
18Group: Applications
19Source0: http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
9c19f94f 20# Source0-md5: c33a470d9c23d0f0a04b1b9f1a034da4
3adcb0b8
JB
21URL: http://wayland.freedesktop.org/
22BuildRequires: Mesa-libEGL-devel >= 7.10
23BuildRequires: Mesa-libGLES-devel
0cb34c60 24# for wayland and sclients, but also desktop-shell, which is always enabled
9c19f94f 25BuildRequires: Mesa-libwayland-egl-devel >= 9.0-2
0cb34c60
JB
26BuildRequires: cairo-devel >= 1.10.0
27BuildRequires: libjpeg-devel
3adcb0b8 28BuildRequires: libpng-devel
0cb34c60 29BuildRequires: libwebp-devel
3adcb0b8
JB
30BuildRequires: pixman-devel
31BuildRequires: pkgconfig
32BuildRequires: tar >= 1:1.22
0cb34c60 33# wayland-server always; wayland-client if with_wayland || with_sclients || with_clients; wayland-cursor if with_clients
9c19f94f 34BuildRequires: wayland-devel = 1.0.0
6c4f66d1 35BuildRequires: xorg-lib-libxkbcommon-devel
3adcb0b8 36BuildRequires: xz
0cb34c60
JB
37%if %{with drm}
38BuildRequires: Mesa-libgbm-devel
9c19f94f 39BuildRequires: libdrm-devel >= 2.4.30
0cb34c60 40BuildRequires: mtdev-devel >= 1.1.0
6c4f66d1 41BuildRequires: udev-devel >= 1:136
0cb34c60 42%endif
3adcb0b8 43%if %{with openwfd}
0cb34c60 44BuildRequires: Mesa-libgbm-devel
3adcb0b8
JB
45# what package?
46BuildRequires pkgconfig(openwfd)
47%endif
0cb34c60
JB
48%if %{with x11}
49BuildRequires: libxcb-devel
50BuildRequires: xorg-lib-libX11-devel
51%endif
52%if %{with wlaunch}
53BuildRequires: libdrm-devel
54BuildRequires: pam-devel
55BuildRequires: systemd-devel
56%endif
57%if %{with xwayland}
58BuildRequires: libxcb-devel
6c4f66d1
JB
59BuildRequires: pkgconfig(cairo-xcb)
60BuildRequires: xorg-lib-libXcursor-devel
0cb34c60 61%endif
3adcb0b8 62%if %{with clients}
6c4f66d1 63BuildRequires: cairo-devel >= 1.11.3
3adcb0b8
JB
64BuildRequires: gdk-pixbuf2-devel >= 2.0
65BuildRequires: glib2-devel >= 2.0
6c4f66d1 66BuildRequires: pkgconfig(cairo-egl) >= 1.11.3
3adcb0b8 67BuildRequires: poppler-glib-devel
3adcb0b8 68%endif
9c19f94f 69Requires: Mesa-libwayland-egl >= 9.0-2
3adcb0b8
JB
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72%description
73Weston contains a few demo application for the Wayland project.
74There's a sample compositor that can run on KMS, under X11 or under
75another Wayland compositor and there's a handful of simple clients
76that demonstrate various aspects of Wayland.
77
78%description -l pl.UTF-8
79Weston zawiera kilka aplikacji demonstracyjnych dla projektu Wayland.
80Jest przykładowy serwer składający, który można uruchomić pod KMS, pod
81X11 lub pod innym serwerem składającym Wayland; są także proste
82programy klienckie demonstrujące różne aspekty protokołu Wayland.
83
84%prep
85%setup -q
86
87%build
88%configure \
89 %{!?with_clients:--disable-clients} \
0cb34c60
JB
90 %{!?with_drm:--disable-drm-compositor} \
91 %{!?with_sclients:--disable-simple-clients} \
3adcb0b8
JB
92 --disable-setuid-install \
93 --disable-silent-rules \
0cb34c60
JB
94 %{!?with_static_libs:--disable-static} \
95 %{!?with_wlaunch:--disable-weston-launch} \
96 %{!?with_x11:--disable-x11-compositor} \
97 %{!?with_xwayland:--disable-xwayland}
3adcb0b8
JB
98%{__make}
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
105
106%{__rm} $RPM_BUILD_ROOT%{_libdir}/weston/*.la
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%files
112%defattr(644,root,root,755)
113%doc README
6c4f66d1 114%attr(755,root,root) %{_bindir}/wcap-decode
9c19f94f 115%attr(755,root,root) %{_bindir}/weston-info
3adcb0b8
JB
116# composer
117%attr(755,root,root) %{_bindir}/weston
6c4f66d1
JB
118%if %{with wlaunch}
119%attr(755,root,root) %{_bindir}/weston-launch
120%endif
3adcb0b8
JB
121%if %{with clients}
122%attr(755,root,root) %{_bindir}/weston-terminal
123%attr(755,root,root) %{_libexecdir}/weston-desktop-shell
6c4f66d1
JB
124%attr(755,root,root) %{_libexecdir}/weston-screensaver
125%attr(755,root,root) %{_libexecdir}/weston-screenshooter
3adcb0b8
JB
126%attr(755,root,root) %{_libexecdir}/weston-tablet-shell
127%endif
128%dir %{_libdir}/weston
0cb34c60 129%if %{with drm}
3adcb0b8 130%attr(755,root,root) %{_libdir}/weston/drm-backend.so
0cb34c60 131%endif
3adcb0b8
JB
132%if %{with openwfd}
133%attr(755,root,root) %{_libdir}/weston/openwfd-backend.so
134%endif
0cb34c60 135%if %{with wayland}
3adcb0b8 136%attr(755,root,root) %{_libdir}/weston/wayland-backend.so
0cb34c60
JB
137%endif
138%if %{with x11}
3adcb0b8 139%attr(755,root,root) %{_libdir}/weston/x11-backend.so
0cb34c60 140%endif
6c4f66d1
JB
141%if %{with xwayland}
142%attr(755,root,root) %{_libdir}/weston/xwayland.so
143%endif
3adcb0b8
JB
144%attr(755,root,root) %{_libdir}/weston/desktop-shell.so
145%attr(755,root,root) %{_libdir}/weston/tablet-shell.so
146%{_datadir}/weston
9c19f94f 147%{_mandir}/man1/weston.1*
3adcb0b8
JB
148
149# noinst, too common names - package in %{name}-demos with weston- prefix?
150# "simple clients"
151#%attr(755,root,root) %{_bindir}/simple-egl
152#%attr(755,root,root) %{_bindir}/simple-shm
153#%attr(755,root,root) %{_bindir}/simple-touch
154%if %{with clients}
6c4f66d1 155#%attr(755,root,root) %{_bindir}/clickdot
3adcb0b8 156#%attr(755,root,root) %{_bindir}/dnd
6c4f66d1 157#%attr(755,root,root) %{_bindir}/editor
3adcb0b8
JB
158#%attr(755,root,root) %{_bindir}/eventdemo
159#%attr(755,root,root) %{_bindir}/flower
160#%attr(755,root,root) %{_bindir}/image
6c4f66d1 161#%attr(755,root,root) %{_bindir}/keyboard
3adcb0b8 162#%attr(755,root,root) %{_bindir}/resizor
3adcb0b8
JB
163#%attr(755,root,root) %{_bindir}/smoke
164# "full GL" clients
165#%attr(755,root,root) %{_bindir}/gears
3adcb0b8
JB
166# poppler
167#%attr(755,root,root) %{_bindir}/view
168%endif
This page took 0.080163 seconds and 4 git commands to generate.