]> git.pld-linux.org Git - packages/weston.git/blame - weston.spec
- updated to 1.0.5
[packages/weston.git] / weston.spec
CommitLineData
3adcb0b8
JB
1#
2# Conditional build:
0cb34c60 3%bcond_without drm # DRM compositor
0cb34c60
JB
4%bcond_without wayland # wayland (nested) compositor
5%bcond_without x11 # X11 compositor
6%bcond_without wlaunch # weston launch
7%bcond_without xwayland # X server launcher
8%bcond_without sclients # simple clients
6c4f66d1 9%bcond_without clients # non-simple + full GL clients
3adcb0b8
JB
10#
11Summary: Weston - Wayland demos
12Summary(pl.UTF-8): Weston - programy demonstracyjne dla protokołu Wayland
13Name: weston
8228963f 14Version: 1.0.5
add1cf0d 15Release: 1
3adcb0b8
JB
16License: MIT
17Group: Applications
18Source0: http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
8228963f 19# Source0-md5: 2f70393d577f06f89dc011ab6fec2bfa
3adcb0b8
JB
20URL: http://wayland.freedesktop.org/
21BuildRequires: Mesa-libEGL-devel >= 7.10
22BuildRequires: Mesa-libGLES-devel
0cb34c60 23# for wayland and sclients, but also desktop-shell, which is always enabled
9c19f94f 24BuildRequires: Mesa-libwayland-egl-devel >= 9.0-2
0cb34c60
JB
25BuildRequires: cairo-devel >= 1.10.0
26BuildRequires: libjpeg-devel
3adcb0b8 27BuildRequires: libpng-devel
0cb34c60 28BuildRequires: libwebp-devel
3adcb0b8
JB
29BuildRequires: pixman-devel
30BuildRequires: pkgconfig
31BuildRequires: tar >= 1:1.22
0cb34c60 32# wayland-server always; wayland-client if with_wayland || with_sclients || with_clients; wayland-cursor if with_clients
add1cf0d 33BuildRequires: wayland-devel >= 1.0.0
6c4f66d1 34BuildRequires: xorg-lib-libxkbcommon-devel
3adcb0b8 35BuildRequires: xz
0cb34c60
JB
36%if %{with drm}
37BuildRequires: Mesa-libgbm-devel
9c19f94f 38BuildRequires: libdrm-devel >= 2.4.30
0cb34c60 39BuildRequires: mtdev-devel >= 1.1.0
6c4f66d1 40BuildRequires: udev-devel >= 1:136
0cb34c60 41%endif
0cb34c60
JB
42%if %{with x11}
43BuildRequires: libxcb-devel
44BuildRequires: xorg-lib-libX11-devel
45%endif
46%if %{with wlaunch}
47BuildRequires: libdrm-devel
48BuildRequires: pam-devel
49BuildRequires: systemd-devel
50%endif
51%if %{with xwayland}
52BuildRequires: libxcb-devel
6c4f66d1
JB
53BuildRequires: pkgconfig(cairo-xcb)
54BuildRequires: xorg-lib-libXcursor-devel
0cb34c60 55%endif
3adcb0b8 56%if %{with clients}
6c4f66d1 57BuildRequires: cairo-devel >= 1.11.3
3adcb0b8
JB
58BuildRequires: gdk-pixbuf2-devel >= 2.0
59BuildRequires: glib2-devel >= 2.0
6c4f66d1 60BuildRequires: pkgconfig(cairo-egl) >= 1.11.3
3adcb0b8 61BuildRequires: poppler-glib-devel
3adcb0b8 62%endif
9c19f94f 63Requires: Mesa-libwayland-egl >= 9.0-2
3adcb0b8
JB
64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66%description
67Weston contains a few demo application for the Wayland project.
68There's a sample compositor that can run on KMS, under X11 or under
69another Wayland compositor and there's a handful of simple clients
70that demonstrate various aspects of Wayland.
71
72%description -l pl.UTF-8
73Weston zawiera kilka aplikacji demonstracyjnych dla projektu Wayland.
74Jest przykładowy serwer składający, który można uruchomić pod KMS, pod
75X11 lub pod innym serwerem składającym Wayland; są także proste
76programy klienckie demonstrujące różne aspekty protokołu Wayland.
77
78%prep
79%setup -q
80
81%build
82%configure \
83 %{!?with_clients:--disable-clients} \
0cb34c60
JB
84 %{!?with_drm:--disable-drm-compositor} \
85 %{!?with_sclients:--disable-simple-clients} \
3adcb0b8
JB
86 --disable-setuid-install \
87 --disable-silent-rules \
0cb34c60
JB
88 %{!?with_static_libs:--disable-static} \
89 %{!?with_wlaunch:--disable-weston-launch} \
90 %{!?with_x11:--disable-x11-compositor} \
91 %{!?with_xwayland:--disable-xwayland}
3adcb0b8
JB
92%{__make}
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97%{__make} install \
98 DESTDIR=$RPM_BUILD_ROOT
99
100%{__rm} $RPM_BUILD_ROOT%{_libdir}/weston/*.la
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%files
106%defattr(644,root,root,755)
107%doc README
6c4f66d1 108%attr(755,root,root) %{_bindir}/wcap-decode
9c19f94f 109%attr(755,root,root) %{_bindir}/weston-info
3adcb0b8
JB
110# composer
111%attr(755,root,root) %{_bindir}/weston
6c4f66d1
JB
112%if %{with wlaunch}
113%attr(755,root,root) %{_bindir}/weston-launch
114%endif
3adcb0b8
JB
115%if %{with clients}
116%attr(755,root,root) %{_bindir}/weston-terminal
117%attr(755,root,root) %{_libexecdir}/weston-desktop-shell
6c4f66d1
JB
118%attr(755,root,root) %{_libexecdir}/weston-screensaver
119%attr(755,root,root) %{_libexecdir}/weston-screenshooter
3adcb0b8
JB
120%attr(755,root,root) %{_libexecdir}/weston-tablet-shell
121%endif
122%dir %{_libdir}/weston
0cb34c60 123%if %{with drm}
3adcb0b8 124%attr(755,root,root) %{_libdir}/weston/drm-backend.so
0cb34c60 125%endif
0cb34c60 126%if %{with wayland}
3adcb0b8 127%attr(755,root,root) %{_libdir}/weston/wayland-backend.so
0cb34c60
JB
128%endif
129%if %{with x11}
3adcb0b8 130%attr(755,root,root) %{_libdir}/weston/x11-backend.so
0cb34c60 131%endif
6c4f66d1
JB
132%if %{with xwayland}
133%attr(755,root,root) %{_libdir}/weston/xwayland.so
134%endif
3adcb0b8
JB
135%attr(755,root,root) %{_libdir}/weston/desktop-shell.so
136%attr(755,root,root) %{_libdir}/weston/tablet-shell.so
137%{_datadir}/weston
9c19f94f 138%{_mandir}/man1/weston.1*
8228963f 139%{_mandir}/man5/weston.ini.5*
e9c620bf 140%{_mandir}/man7/weston-drm.7*
3adcb0b8
JB
141
142# noinst, too common names - package in %{name}-demos with weston- prefix?
143# "simple clients"
144#%attr(755,root,root) %{_bindir}/simple-egl
145#%attr(755,root,root) %{_bindir}/simple-shm
146#%attr(755,root,root) %{_bindir}/simple-touch
147%if %{with clients}
6c4f66d1 148#%attr(755,root,root) %{_bindir}/clickdot
3adcb0b8 149#%attr(755,root,root) %{_bindir}/dnd
6c4f66d1 150#%attr(755,root,root) %{_bindir}/editor
3adcb0b8
JB
151#%attr(755,root,root) %{_bindir}/eventdemo
152#%attr(755,root,root) %{_bindir}/flower
153#%attr(755,root,root) %{_bindir}/image
6c4f66d1 154#%attr(755,root,root) %{_bindir}/keyboard
3adcb0b8 155#%attr(755,root,root) %{_bindir}/resizor
3adcb0b8
JB
156#%attr(755,root,root) %{_bindir}/smoke
157# "full GL" clients
158#%attr(755,root,root) %{_bindir}/gears
3adcb0b8
JB
159# poppler
160#%attr(755,root,root) %{_bindir}/view
161%endif
This page took 0.113086 seconds and 4 git commands to generate.