]> git.pld-linux.org Git - packages/webrtc-audio-processing1.git/blame - webrtc-audio-processing1.spec
- webrtc-audio-processing updated to 1.0 (parallel installable with webrtc-audio...
[packages/webrtc-audio-processing1.git] / webrtc-audio-processing1.spec
CommitLineData
ac8de864
ER
1# NOTE:
2# f.d.o source is meant to be a more Linux packaging friendly copy of the
3# AudioProcessing module from the WebRTC[1] project. The ideal case is that we
4# make no changes to the code to make tracking upstream code easy.
5# [1] http://code.google.com/p/webrtc/
902b8ee7
JP
6#
7# Conditional build:
6f2a5c0a
JB
8%bcond_without neon # ARM NEON instructions
9%bcond_with sse2 # SSE2 instructions
902b8ee7
JP
10
11%ifnarch armv7l armv7hl armv7hnl armv8l armv8hl armv8hnl armv8hcnl aarch64
12%undefine with_neon
13%endif
6f2a5c0a
JB
14%ifarch pentium4 %{x8664} x32
15%define with_sse2 1
16%endif
902b8ee7 17
ac8de864 18Summary: WebRTC Audio Processing library
1a9d4a78 19Summary(pl.UTF-8): Biblioteka WebRTC Audio Processing
6f2a5c0a
JB
20Name: webrtc-audio-processing1
21Version: 1.0
6da36386 22Release: 1
ac8de864
ER
23License: BSD
24Group: Libraries
6f2a5c0a
JB
25Source0: https://freedesktop.org/software/pulseaudio/webrtc-audio-processing/webrtc-audio-processing-%{version}.tar.gz
26# Source0-md5: 8ee1b2f3e615c6c2024951c559a9913a
27Patch0: %{name}-abseil.patch
28Patch1: %{name}-nosimd.patch
97029a09 29URL: https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/
6f2a5c0a
JB
30BuildRequires: abseil-cpp-devel >= 20200923
31BuildRequires: libstdc++-devel >= 6:5
32BuildRequires: meson >= 0.54
33BuildRequires: ninja >= 1.5
ac8de864
ER
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37WebRTC is an open source project that enables web browsers with
38Real-Time Communications (RTC) capabilities via simple Javascript
39APIs. The WebRTC components have been optimized to best serve this
40purpose. WebRTC implements the W3C's proposal for video conferencing
41on the web.
42
1a9d4a78
JB
43%description -l pl.UTF-8
44WebRTC to projekt o otwartych źródłach dodający obsługę komunikacji
45w czasie rzeczywistym (RTC - Real-Time Communications) poprzez proste
46API JavaScriptu. Komponenty WebRTC zostały zoptymalizowane, aby jak
47najlepiej sprawdzały się w tym zastosowaniu. WebRTC implementuje
48propozycje W3C do wideokonferencji w sieci.
49
ac8de864 50%package devel
1a9d4a78
JB
51Summary: Header files for WebRTC Audio Processing library
52Summary(pl.UTF-8): Pliki nagłówkowe biblioteki WebRTC Audio Processing
ac8de864
ER
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
6f2a5c0a
JB
55Requires: abseil-cpp-devel >= 20200923
56Requires: libstdc++-devel >= 6:5
ac8de864
ER
57
58%description devel
1a9d4a78
JB
59This package contains the header files needed to develop programs
60which make use of WebRTC Audio Processing library.
61
62%description devel -l pl.UTF-8
63Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
64wykorzystujących bibliotekę WebRTC Audio Processing.
65
66%package static
67Summary: Static WebRTC Audio Processing library
68Summary(pl.UTF-8): Biblioteka statyczna WebRTC Audio Processing
69Group: Development/Libraries
70Requires: %{name}-devel = %{version}-%{release}
71
72%description static
73Static WebRTC Audio Processing library.
74
75%description static -l pl.UTF-8
76Biblioteka statyczna WebRTC Audio Processing.
ac8de864
ER
77
78%prep
6f2a5c0a
JB
79%setup -q -n webrtc-audio-processing-%{version}
80%patch0 -p1
81%patch1 -p1
82
83%ifarch %{ix86}
84%if %{without sse2}
85# add -DPFFFT_SIMD_DISABLE
86%{__sed} -i -e 's/have_arm and not have_neon.*/& or true/' webrtc/third_party/pffft/meson.build
87%endif
88%endif
ac8de864
ER
89
90%build
6f2a5c0a
JB
91%if %{with sse2}
92CFLAGS="%{rpmcflags} -msse2"
93CXXFLAGS="%{rpmcxxflags} -msse2"
94%endif
95%meson build \
96 -Dneon=%{?with_neon:runtime}%{!?with_neon:no}
97
98%ninja_build -C build
ac8de864
ER
99
100%install
101rm -rf $RPM_BUILD_ROOT
ac8de864 102
6f2a5c0a 103%ninja_install -C build
ac8de864
ER
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post -p /sbin/ldconfig
109%postun -p /sbin/ldconfig
110
111%files
112%defattr(644,root,root,755)
7e62f716 113%doc AUTHORS COPYING NEWS README.md webrtc/PATENTS
6f2a5c0a
JB
114%attr(755,root,root) %{_libdir}/libwebrtc-audio-coding-1.so.0
115%attr(755,root,root) %{_libdir}/libwebrtc-audio-processing-1.so.0
ac8de864
ER
116
117%files devel
118%defattr(644,root,root,755)
6f2a5c0a
JB
119%attr(755,root,root) %{_libdir}/libwebrtc-audio-coding-1.so
120%attr(755,root,root) %{_libdir}/libwebrtc-audio-processing-1.so
121%{_includedir}/webrtc-audio-processing-1
122%{_pkgconfigdir}/webrtc-audio-coding-1.pc
123%{_pkgconfigdir}/webrtc-audio-processing-1.pc
1a9d4a78
JB
124
125%files static
126%defattr(644,root,root,755)
6f2a5c0a
JB
127%{_libdir}/libwebrtc-audio-coding-1.a
128%{_libdir}/libwebrtc-audio-processing-1.a
This page took 0.092756 seconds and 4 git commands to generate.