]> git.pld-linux.org Git - packages/waylandpp.git/blame - waylandpp.spec
package protocol files
[packages/waylandpp.git] / waylandpp.spec
CommitLineData
ff84a361
JP
1#
2# Conditional build:
3%bcond_without apidocs # Doxygen based API documentation
4
5Summary: Wayland C++ bindings
6Name: waylandpp
7Version: 0.2.8
8Release: 1
9License: MIT
10Group: Libraries
11Source0: https://github.com/NilsBrause/waylandpp/archive/%{version}/%{name}-%{version}.tar.gz
12# Source0-md5: f930127bb8dee80128c95622e1947f0c
13URL: https://nilsbrause.github.io/waylandpp_docs/
14BuildRequires: cmake >= 3.4
15%{?with_apidocs:BuildRequires: doxygen}
16BuildRequires: libstdc++-devel >= 6:4.8
17BuildRequires: pkgconfig
18BuildRequires: pugixml-devel >= 1.4
19BuildRequires: rpm-build >= 4.6
20BuildRequires: rpmbuild(macros) >= 1.742
21BuildRequires: wayland-devel >= 1.11.0
22BuildRequires: wayland-egl-devel
23Requires: wayland >= 1.11.0
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26# project claims missing symbols are intentional and even tries to
27# remove -Wl,--no-undefined from linker flags
28%define no_install_post_check_so 1
29
30%description
31The goal of this library is to create such a C++ binding for Wayland
32using the most modern C++ technology currently available, providing an
33easy to use C++ API to Wayland.
34
35%package devel
36Summary: Header files for Waylandpp libraries
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: pugixml >= 1.4
40Requires: wayland-devel >= 1.11.0
41Requires: wayland-egl-devel
42
43%description devel
44Header files for Waylandpp libraries.
45
46%package apidocs
47Summary: Waylandpp API documentation
48Group: Documentation
49BuildArch: noarch
50
51%description apidocs
52Waylandpp API documentation.
53
54%prep
55%setup -q
56
57%build
58%cmake -B build \
59 %{cmake_on_off apidocs BUILD_DOCUMENTATION}
60
61%{__make} -C build
62
63%install
64rm -rf $RPM_BUILD_ROOT
65
66%{__make} -C build install \
67 DESTDIR=$RPM_BUILD_ROOT
68
69%{?with_apidocs:%{__rm} -r $RPM_BUILD_ROOT%{_docdir}}
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%post -p /sbin/ldconfig
75%postun -p /sbin/ldconfig
76
77%files
78%defattr(644,root,root,755)
79%doc LICENSE README.md
80%attr(755,root,root) %{_libdir}/libwayland-client++.so.*.*.*
81%attr(755,root,root) %ghost %{_libdir}/libwayland-client++.so.0
82%attr(755,root,root) %{_libdir}/libwayland-client-extra++.so.*.*.*
83%attr(755,root,root) %ghost %{_libdir}/libwayland-client-extra++.so.0
84%attr(755,root,root) %{_libdir}/libwayland-cursor++.so.*.*.*
85%attr(755,root,root) %ghost %{_libdir}/libwayland-cursor++.so.0
86%attr(755,root,root) %{_libdir}/libwayland-egl++.so.*.*.*
87%attr(755,root,root) %ghost %{_libdir}/libwayland-egl++.so.0
88
89%files devel
90%defattr(644,root,root,755)
91%attr(755,root,root) %{_bindir}/wayland-scanner++
92%attr(755,root,root) %{_libdir}/libwayland-client++.so
93%attr(755,root,root) %{_libdir}/libwayland-client-extra++.so
94%attr(755,root,root) %{_libdir}/libwayland-cursor++.so
95%attr(755,root,root) %{_libdir}/libwayland-egl++.so
2f2656ab
JP
96%dir %{_datadir}/waylandpp
97%dir %{_datadir}/waylandpp/protocols
98%{_datadir}/waylandpp/protocols/*.xml
ff84a361
JP
99%{_includedir}/wayland-client*.hpp
100%{_includedir}/wayland-cursor.hpp
101%{_includedir}/wayland-egl.hpp
102%{_includedir}/wayland-util.hpp
103%{_includedir}/wayland-version.hpp
104%{_libdir}/cmake/waylandpp
105%{_pkgconfigdir}/wayland-client++.pc
106%{_pkgconfigdir}/wayland-client-extra++.pc
107%{_pkgconfigdir}/wayland-cursor++.pc
108%{_pkgconfigdir}/wayland-egl++.pc
109%{_pkgconfigdir}/wayland-scanner++.pc
110%if %{with apidocs}
111%{_mandir}/man3/wayland_*.3*
112%{_mandir}/man3/wayland-client.hpp.3*
113%endif
114
115%if %{with apidocs}
116%files apidocs
117%defattr(644,root,root,755)
118%doc build/doc/html
119%endif
This page took 0.097041 seconds and 4 git commands to generate.