]> git.pld-linux.org Git - packages/virt-manager.git/blame - virt-manager.spec
- upped to 0.8.4
[packages/virt-manager.git] / virt-manager.spec
CommitLineData
8eb0adf0
SP
1
2Summary: Virtual Machine Manager
3Name: virt-manager
99a357fc 4Version: 0.8.4
a5ada689 5Release: 0.1
8eb0adf0
SP
6License: GPL v2+
7Group: Applications/Emulators
8URL: http://virt-manager.et.redhat.com/
9Source0: http://virt-manager.et.redhat.com/download/sources/virt-manager/%{name}-%{version}.tar.gz
8eb0adf0
SP
10BuildRequires: atk-devel
11BuildRequires: cairo-devel
98deb886 12BuildRequires: gettext-devel
8eb0adf0
SP
13BuildRequires: glib2-devel
14#BuildRequires: gtk2-devel
15BuildRequires: intltool
16BuildRequires: pango-devel
98deb886 17BuildRequires: perl-tools-pod
8eb0adf0
SP
18BuildRequires: python-devel >= 2.14
19BuildRequires: python-pygobject-devel >= 2.14
20BuildRequires: python-pygtk-devel >= 2.14
21BuildRequires: scrollkeeper
22
23# These two are just the oldest version tested
16442c1b 24Requires: python-gnome-gconf >= 1.99.11-7
0f49eac5 25Requires: python-pygtk-gtk >= 1.99.12-6
8eb0adf0 26# Absolutely require this version or newer
b225787c 27Requires: python-libvirt >= 0.4.5
8eb0adf0 28# Definitely does not work with earlier due to python API changes
16442c1b 29Requires: python-dbus >= 0.61
16442c1b 30Requires: python-gnome-vfs >= 2.15.4
8eb0adf0
SP
31# Minimum we've tested with
32# Required for loading the glade UI
33# Required for our graphics which are currently SVG format
34# Required to install Xen & QEMU guests
16442c1b
SP
35Requires: python-gnome-desktop-librsvg >= 2.14
36Requires: python-libxml2 >= 2.6.23
37Requires: python-pygtk-glade >= 2.12
a5ada689 38Requires: python-virtinst >= 0.500.1
8eb0adf0
SP
39# Earlier vte had broken python binding module
40Requires: vte >= 0.12.2
41# For online help
42Requires: scrollkeeper
43# For console widget
16442c1b 44Requires: python-gtk-vnc >= 0.3.4
8eb0adf0
SP
45# For local authentication against PolicyKit
46Requires: PolicyKit-gnome
47
0f49eac5
SP
48Requires: python-urlgrabber
49Requires: python-vte
234e70d3 50Suggests: gnome-keyring >= 0.4.9
51Suggests: python-gnome-desktop-keyring >= 2.15.4
0f49eac5 52
8eb0adf0
SP
53ExclusiveArch: %{ix86} x86_64 ia64
54
55Requires(post): GConf2
56Requires(pre): GConf2
57Requires(preun): GConf2
58
59%description
60Virtual Machine Manager provides a graphical tool for administering
61virtual machines for KVM, Xen, and QEmu. Start, stop, add or remove
62virtual devices, connect to a graphical or serial console, and see
63resource usage statistics for existing VMs on local or remote
64machines. Uses libvirt as the backend management API.
65
66%prep
67%setup -q
8eb0adf0
SP
68
69%build
70%configure
71%{__make}
72
73
74%install
75rm -rf $RPM_BUILD_ROOT
76%{__make} install DESTDIR=$RPM_BUILD_ROOT
77rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/sparkline.a
78rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/sparkline.la
79%find_lang %{name}
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%pre
85if [ "$1" -gt 1 ]; then
86 export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
87 gconftool-2 --makefile-uninstall-rule \
88 %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
89fi
90
91%post
92export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
93gconftool-2 --makefile-install-rule \
94 %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
95
96update-desktop-database %{_desktopdir}
97
98if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q -o %{_datadir}/omf/%{name}; fi
99
100%postun
101update-desktop-database %{_desktopdir}
102
103if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q; fi
104
105%preun
106if [ "$1" -eq 0 ]; then
107 export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
108 gconftool-2 --makefile-uninstall-rule \
109 %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
110fi
111
112%files -f %{name}.lang
113%defattr(644,root,root,755)
114%doc README COPYING COPYING-DOCS AUTHORS ChangeLog NEWS
115%{_sysconfdir}/gconf/schemas/%{name}.schemas
116%attr(755,root,root) %{_bindir}/%{name}
117%{_libexecdir}/%{name}-launch
8eb0adf0 118
b225787c 119%dir %{_datadir}/%{name}
8eb0adf0 120%{_datadir}/%{name}/*.glade
b225787c 121%dir %{_datadir}/%{name}/pixmaps
8eb0adf0
SP
122%{_datadir}/%{name}/pixmaps/*.png
123%{_datadir}/%{name}/pixmaps/*.svg
99a357fc 124%{_datadir}/%{name}/pixmaps/hicolor/16x16/action/*.png
125%{_datadir}/%{name}/pixmaps/hicolor/22x22/action/*.png
126%{_datadir}/%{name}/pixmaps/hicolor/24x24/action/*.png
127%{_datadir}/%{name}/pixmaps/hicolor/32x32/action/*.png
128
129
8eb0adf0
SP
130
131%{_datadir}/%{name}/*.py
132#%{_datadir}/%{name}/*.pyc
133#%{_datadir}/%{name}/*.pyo
134
b225787c 135%dir %{_datadir}/%{name}/virtManager
8eb0adf0
SP
136%{_datadir}/%{name}/virtManager/*.py
137#%{_datadir}/%{name}/virtManager/*.pyc
138#%{_datadir}/%{name}/virtManager/*.pyo
139
b225787c 140%dir %{_datadir}/omf/%{name}
99a357fc 141%{_datadir}/omf/%{name}/*.omf
b225787c 142%dir %{_datadir}/gnome/help
99a357fc 143%{_datadir}/gnome/help/%{name}
8eb0adf0
SP
144
145%{_desktopdir}/%{name}.desktop
146%{_datadir}/dbus-1/services/%{name}.service
147
148%{_mandir}/man1/%{name}.1*
This page took 0.097869 seconds and 4 git commands to generate.