]> git.pld-linux.org Git - packages/vala.git/blame - vala.spec
- updated to 0.18.0
[packages/vala.git] / vala.spec
CommitLineData
7b719041 1%define major_ver 0.18
2100e356 2Summary: GObject-based language compiler
62a0034d 3Summary(pl.UTF-8): Kompilator języka opartego na bibliotece GObject
2100e356 4Name: vala
6f509235 5Version: 0.18.0
7ace0cac 6Release: 1
c258620e 7Epoch: 2
6a5cf96c 8License: LGPL v2+
2100e356 9Group: Applications
6f509235
ŁK
10Source0: http://ftp.gnome.org/pub/GNOME/sources/vala/0.18/%{name}-%{version}.tar.xz
11# Source0-md5: 06a95d6a6466b3583b59fe956cc75486
9278bb59 12URL: http://live.gnome.org/Vala
1d8bfdb9 13BuildRequires: autoconf
7ace0cac 14BuildRequires: automake >= 1:1.11
6a5cf96c 15BuildRequires: bison
2ac0ddb6 16BuildRequires: flex
8dbbe0bb 17BuildRequires: glib2-devel >= 1:2.16.0
1d8bfdb9 18BuildRequires: libtool
7f0c5943 19BuildRequires: libxslt-progs
6a5cf96c 20BuildRequires: pkgconfig
7ace0cac
AF
21BuildRequires: tar >= 1:1.22
22BuildRequires: xz
a147192b 23Conflicts: gdk-pixbuf2 < 2.23.3-1
2100e356 24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Vala is a new programming language that aims to bring modern
28programming language features to GNOME developers without imposing any
29additional runtime requirements and without using a different ABI
30compared to applications and libraries written in C.
31
32valac, the Vala compiler, is a self-hosting compiler that translates
33Vala source code into C source and header files. It uses the GObject
34type system to create classes and interfaces declared in the Vala
35source code. It's also planned to generate GIDL files when
36gobject-introspection is ready.
37
38The syntax of Vala is similar to C#, modified to better fit the
39GObject type system.
40
a030a99c
JR
41%description -l pl.UTF-8
42Vala to nowy język programowania, którego celem jest udostępnienie
43cech nowoczesnych języków programowania programistom GNOME bez
44wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
45używania API innego niż w aplikacjach i bibliotekach napisanych w C.
fc5b0e4f 46
a030a99c
JR
47valac - kompilator języka Vala - to napisany w sobie samym kompilator
48tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
49C. Używa systemu typów GObject do tworzenia klas i interfejsów
50zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
51generowanie plików GIDL, kiedy system gobject-introspection będzie
fc5b0e4f
JB
52gotowy.
53
a030a99c
JR
54Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
55pasować do systemu typów GObject.
fc5b0e4f 56
b0568d57 57%package apidocs
58Summary: vala API documentation
59Summary(pl.UTF-8): Dokumentacja API vala
60Group: Documentation
8634ffb4 61Requires: devhelp
b0568d57 62
63%description apidocs
64vala API documentation.
65
66%description apidocs -l pl.UTF-8
67Dokumentacja API vala.
68
2100e356 69%prep
70%setup -q
71
72%build
1d8bfdb9 73%{__libtoolize}
7ace0cac 74%{__aclocal} -I m4
1d8bfdb9 75%{__autoconf}
76%{__autoheader}
77%{__automake}
78%configure \
9278bb59 79 --disable-silent-rules \
2ca28226 80 --enable-vapigen
2100e356 81%{__make}
82
83%install
84rm -rf $RPM_BUILD_ROOT
85
a3c413c5
PZ
86install -d $RPM_BUILD_ROOT%{_datadir}/vala/vapi
87
2100e356 88%{__make} install \
89 DESTDIR=$RPM_BUILD_ROOT
90
a3c413c5
PZ
91%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
92
2100e356 93%clean
94rm -rf $RPM_BUILD_ROOT
95
6a5cf96c
JB
96%post -p /sbin/ldconfig
97%postun -p /sbin/ldconfig
98
2100e356 99%files
100%defattr(644,root,root,755)
101%attr(755,root,root) %{_bindir}/*
a3c413c5
PZ
102%attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so.*.*.*
103%attr(755,root,root) %ghost %{_libdir}/libvala-%{major_ver}.so.0
104%attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so
092cc603 105%{_includedir}/vala-%{major_ver}
e6241369 106%{_pkgconfigdir}/libvala-%{major_ver}.pc
ce788c9c
MB
107%{_npkgconfigdir}/vapigen-%{major_ver}.pc
108%{_npkgconfigdir}/vapigen.pc
a3c413c5 109%dir %{_datadir}/vala
ce788c9c 110%{_datadir}/vala/Makefile.vapigen
a3c413c5 111%dir %{_datadir}/vala/vapi
092cc603
JK
112%dir %{_datadir}/vala-%{major_ver}
113%dir %{_datadir}/vala-%{major_ver}/vapi
114%{_datadir}/vala-%{major_ver}/vapi/*.vapi
115%{_datadir}/vala-%{major_ver}/vapi/*.deps
6a5cf96c 116%{_mandir}/man1/valac.1*
092cc603
JK
117%{_mandir}/man1/valac-%{major_ver}.1*
118%dir %{_libdir}/vala-%{major_ver}
119%attr(755,root,root) %{_libdir}/vala-%{major_ver}/gen-introspect-%{major_ver}
cbe6d1d3 120%{_mandir}/man1/vala-gen-introspect.1*
092cc603 121%{_mandir}/man1/vala-gen-introspect-%{major_ver}.1*
cbe6d1d3 122%{_mandir}/man1/vapigen.1*
092cc603
JK
123%{_mandir}/man1/vapigen-%{major_ver}.1*
124%{_aclocaldir}/vala.m4
ce788c9c 125%{_aclocaldir}/vapigen.m4
b0568d57 126
127%files apidocs
128%defattr(644,root,root,755)
092cc603 129%{_datadir}/devhelp/books/vala-%{major_ver}
This page took 0.212876 seconds and 4 git commands to generate.