]> git.pld-linux.org Git - packages/vagrant.git/blame - vagrant.spec
really fix embedded path
[packages/vagrant.git] / vagrant.spec
CommitLineData
2f2a2f85
ER
1Summary: Provisioning and deployment of virtual instances
2Name: vagrant
77d9f457 3Version: 1.1.2
be793ac6 4Release: 0.4
2f2a2f85
ER
5License: MIT
6Group: Applications/Emulators
7URL: http://vagrantup.com/
77d9f457
ER
8Source0: http://files.vagrantup.com/packages/67bd4d30f7dbefa7c0abc643599f0244986c38c8/vagrant_i686.rpm?/%{name}-%{version}.i686.rpm
9# Source0-md5: 83093a71588f97a9eb69fa7fe07418b9
10Source1: http://files.vagrantup.com/packages/67bd4d30f7dbefa7c0abc643599f0244986c38c8/vagrant_x86_64.rpm?/%{name}-%{version}.x86_64.rpm
11# Source1-md5: 3efa3ac73988c565e6b3236da6867557
376b9a6d
ER
12BuildRequires: pkgconfig
13BuildRequires: rpm-pythonprov
32f7fb06 14BuildRequires: rpm-utils
376b9a6d 15BuildRequires: ruby
a08aa0c6 16BuildRequires: sed >= 4.0
376b9a6d 17BuildRequires: which
32f7fb06
ER
18ExclusiveArch: %{ix86} %{x8664}
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%define _appdir %{_libdir}/%{name}
22
23%define _enable_debug_packages 0
24%define no_install_post_strip 1
25%define no_install_post_check_so 1
26%define no_install_post_chrpath 1
2f2a2f85
ER
27
28%description
29Vagrant offers scripted provisioning and deployment of virtual
30instances. While VirtualBox is the main target, future versions may
31support other hypervizors as well.
32
33The vision of the project is to create a tool to transparently manage
34all the complex parts of modern development within a virtual
35environment without affecting the everyday workflow of the developer
36too much. A long term goal is moving all development into virtualized
37environments by making it easier to do so than not to. Additionally,
38work is ongoing to have Vagrant run identically on every major
39consumer OS platform (Linux, Mac OS X, and Windows).
40
41%package doc
42Summary: Documentation for %{name}
43Group: Documentation
44Requires: %{name} = %{version}-%{release}
45%if "%{_rpmversion}" >= "5"
46BuildArch: noarch
47%endif
48
49%description doc
50Ruby documentation for %{gem_name}
51
52%prep
32f7fb06
ER
53%setup -qcT
54%ifarch %{ix86}
55SOURCE=%{S:0}
56%endif
57%ifarch %{x8664}
58SOURCE=%{S:1}
59%endif
2f2a2f85 60
32f7fb06
ER
61V=$(rpm -qp --nodigest --nosignature --qf '%{V}' $SOURCE)
62test "$V" = "%{version}"
2f2a2f85 63
32f7fb06 64rpm2cpio $SOURCE | cpio -i -d
2f2a2f85 65
32f7fb06 66mv opt/vagrant/* .
2f2a2f85 67
be793ac6 68grep -rl /tmp/vagrant-temp embedded | xargs sed -i -e 's,/tmp/vagrant-temp,%{_appdir},'
a08aa0c6 69
2f2a2f85
ER
70%install
71rm -rf $RPM_BUILD_ROOT
32f7fb06 72install -d $RPM_BUILD_ROOT{%{_bindir},%{_appdir}}
2f2a2f85 73
32f7fb06
ER
74cp -a bin embedded $RPM_BUILD_ROOT%{_appdir}
75ln -s %{_appdir}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}
2f2a2f85
ER
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%files
81%defattr(644,root,root,755)
82%attr(755,root,root) %{_bindir}/vagrant
2f2a2f85 83
32f7fb06
ER
84%defattr(-,root,root,-)
85%{_appdir}
86
87%if 0
2f2a2f85
ER
88%files doc
89%defattr(644,root,root,755)
90%doc %{gem_docdir}
32f7fb06 91%endif
This page took 0.045204 seconds and 4 git commands to generate.