]> git.pld-linux.org Git - packages/vagrant.git/blame - vagrant.spec
new, version 1.0.6
[packages/vagrant.git] / vagrant.spec
CommitLineData
2f2a2f85
ER
1
2#
3# Missing deps in Fedora:
4#
5# rubygem-log4r >= 1.1.9 < 2.0.0
6# Fix: Build new package, bz905240
7#
8# rubygem-childprocess >=0.3.1 < 0.4.0 (0.3.6 in rawhide)
9# Fix: Grab 0.3.6 package from rawhide
10#
11# rubygem-json >= 1.5.1, < 1.6.0 (1.6.5 in f18, 1.9.1 in rawhide)
12# Fix: Build rubygem-json15, roughly based on current package
13#
14# rubygem-net-ssh >= 2.2.2 < 2.3.0 (2.2.1 in rawhide)
15# Fix: Build 2.2.2 package based on current package
16#
17
18%define gem_name vagrant
19%define rubyabi 1.9.1
20Summary: Provisioning and deployment of virtual instances
21Name: vagrant
22Version: 1.0.6
23Release: 0.1
24License: MIT
25Group: Applications/Emulators
26URL: http://vagrantup.com/
27Source0: http://rubygems.org/downloads/%{gem_name}-%{version}.gem
28# Source0-md5: c84c240a9e62853336bd3f0f2532ad8a
29BuildRequires: git-core
30BuildRequires: ruby(abi) = %{rubyabi}
31#BuildRequires: rubygem(contest) >= 0.1.2
32BuildRequires: rubygem(minitest) >= 2.5.1
33BuildRequires: rubygem(mocha)
34BuildRequires: rubygem(rake)
35BuildRequires: rubygem(rspec-core) >= 2.8.0
36BuildRequires: rubygem(rspec-expectations) >= 2.8.0
37BuildRequires: rubygem(rspec-mocks) >= 2.8.0
38BuildRequires: rubygems-devel
39Requires: ruby(abi) = %{rubyabi}
40Requires: ruby(rubygems)
41Requires: rubygem(archive-tar-minitar) = 0.5.2
42Requires: rubygem(childprocess) >= 0.3.1
43Requires: rubygem(erubis) >= 2.7.0
44Requires: rubygem(i18n) >= 0.6.0
45Requires: rubygem(log4r) >= 1.1.9
46Requires: rubygem(net-scp) >= 1.0.4
47Requires: rubygem(net-ssh) >= 2.2.2
48Requires: rubygem-json15
49BuildArch: noarch
50
51%description
52Vagrant offers scripted provisioning and deployment of virtual
53instances. While VirtualBox is the main target, future versions may
54support other hypervizors as well.
55
56The vision of the project is to create a tool to transparently manage
57all the complex parts of modern development within a virtual
58environment without affecting the everyday workflow of the developer
59too much. A long term goal is moving all development into virtualized
60environments by making it easier to do so than not to. Additionally,
61work is ongoing to have Vagrant run identically on every major
62consumer OS platform (Linux, Mac OS X, and Windows).
63
64%package doc
65Summary: Documentation for %{name}
66Group: Documentation
67Requires: %{name} = %{version}-%{release}
68%if "%{_rpmversion}" >= "5"
69BuildArch: noarch
70%endif
71
72%description doc
73Ruby documentation for %{gem_name}
74
75%prep
76gem unpack %{SOURCE0}
77%setup -q -D -T -n %{gem_name}-%{version}
78
79gem spec %{SOURCE0} -l --ruby > %{gem_name}.gemspec
80
81%build
82mkdir -p ./%{gem_dir}
83
84# Create the gem as gem install only works on a gem file
85gem build %{gem_name}.gemspec
86
87export CONFIGURE_ARGS="--with-cflags='%{rpmcflags}'"
88# gem install compiles any C extensions and installs into a directory
89# We set that to be a local directory so that we can move it into the
90# buildroot in %%install
91gem install -V \
92 --local \
93 --install-dir ./%{gem_dir} \
94 --bindir ./%{_bindir} \
95 --force \
96 --rdoc \
97 %{SOURCE0}
98
99%install
100rm -rf $RPM_BUILD_ROOT
101install -d $RPM_BUILD_ROOT%{gem_dir}
102
103# Remove a few oddments
104rm .%{gem_instdir}/.gitignore
105rm .%{gem_instdir}/.yardopts
106
107# Just copy these out for putting in default fedora doc location later
108cp .%{gem_instdir}/LICENSE .
109cp .%{gem_instdir}/README.md .
110cp .%{gem_instdir}/CHANGELOG.md .
111
112# Programs/scripts
113install -d $RPM_BUILD_ROOT%{_bindir}
114mv -v ./bin/* $RPM_BUILD_ROOT%{_bindir}
115mv -v .%{gem_instdir}/bin/* $RPM_BUILD_ROOT%{_bindir}
116chmod +x .%{gem_instdir}/test/*/scripts/*.sh
117
118# Wrap up the rest
119cp -a ./%{gem_dir}/* $RPM_BUILD_ROOT%{gem_dir}/
120
121%if %{with tests}
122cd .%{gem_instdir}
123
124# Just a hack, rspec misses this .gitignore(!)
125touch $RPM_BUILD_ROOT%{gem_instdir}/.gitignore
126rspec $RPM_BUILD_ROOT%{gem_instdir}/%{gem_name}.gemspec
127rm $RPM_BUILD_ROOT%{gem_instdir}/.gitignore
128%endif
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%files
134%defattr(644,root,root,755)
135%attr(755,root,root) %{_bindir}/vagrant
136%{gem_spec}
137%{gem_cache}
138%{gem_instdir}/lib
139%{gem_instdir}/test
140%{gem_instdir}/keys
141%{gem_instdir}/tasks
142%{gem_instdir}/contrib
143%{gem_instdir}/Gemfile
144%{gem_instdir}/Rakefile
145%{gem_instdir}/%{gem_name}.gemspec
146%config %{gem_instdir}/config
147
148# Put something in the default fedora documentation location
149%doc LICENSE
150%doc README.md
151%doc CHANGELOG.md
152
153# Ruby devs probably panic if these are not in place here as well
154%doc %{gem_instdir}/LICENSE
155%doc %{gem_instdir}/README.md
156%doc %{gem_instdir}/CHANGELOG.md
157
158%doc %{gem_instdir}/templates
159
160%files doc
161%defattr(644,root,root,755)
162%doc %{gem_docdir}
This page took 0.086255 seconds and 4 git commands to generate.