]> git.pld-linux.org Git - packages/ucommon.git/blame - ucommon.spec
- updated to 6.2.3
[packages/ucommon.git] / ucommon.spec
CommitLineData
a2124e8d
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
90c50098 4%bcond_with gnutls # use GnuTLS instead of OpenSSL
98ea40c1 5
a2124e8d
JB
6Summary: GNU uCommon C++ - very light-weight C++ framework
7Summary(pl.UTF-8): GNU uCommon C++ - bardzo lekki szkielet C++
8Name: ucommon
2f9c191a 9Version: 6.2.3
e3ba3103 10Release: 1
a6e2e8b1 11License: LGPL v3+ (libucommon and secure component), GPL v3+ with runtime exception (commoncpp2)
a2124e8d
JB
12Group: Libraries
13Source0: http://ftp.gnu.org/gnu/commoncpp/%{name}-%{version}.tar.gz
2f9c191a 14# Source0-md5: 610bf2d10cf9abefeb4a50a3bdba2023
a2124e8d
JB
15URL: http://www.gnu.org/software/commoncpp/
16%{?with_apidocs:BuildRequires: doxygen}
95322b3a 17%{?with_gnutls:BuildRequires: gnutls-devel >= 3.0.0}
a2124e8d 18BuildRequires: libstdc++-devel >= 5:3.0
492c374d 19%{!?with_gnutls:BuildRequires: openssl-devel >= 0.9.7}
a2124e8d
JB
20BuildRequires: pkgconfig
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24GNU uCommon C++ is meant as a very light-weight C++ library to
25facilitate using C++ design patterns even for very deeply embedded
26applications, such as for systems using uClibc along with POSIX
27threading support. For this reason, uCommon disables language features
28that consume memory or introduce runtime overhead, such as rtti and
29exception handling, and assumes one will mostly be linking
30applications with other pure C based libraries rather than using the
31overhead of the standard C++ library and other class frameworks.
32
33%description -l pl.UTF-8
34GNU uCommon C++ ma być bardzo lekką biblioteką C++ ułatwiającą
35wykorzystywanie wzorców projektowych C++, nawet w bardzo wbudowanych
36zastosowaniach, takich jak systemy wykorzystujące uClibc, wraz z
37obsługą wątków POSIX. Z tego powodu uCommon wyłącza elementy języka
38pochłaniające pamięć lub wprowadzające narzut w czasie działania,
39takie jak rtti czy obsługa wyjątków i zakłada, że aplikacje będą
98ea40c1
ER
40linkowane z innymi bibliotekami opartymi na czystym C zamiast narzutu
41pełnej biblioteki standardowej C++ czy innych szkieletów klas.
a2124e8d
JB
42
43%package devel
44Summary: Header files for uCommon C++ library
45Summary(pl.UTF-8): Pliki nagłówkowe biblioteki uCommon C++
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
95322b3a 48%{?with_gnutls:Requires: gnutls-devel >= 3.0.0}
a2124e8d 49Requires: libstdc++-devel >= 5:3.0
492c374d 50%{!?with_gnutls:Requires: openssl-devel >= 0.9.7}
a2124e8d
JB
51
52%description devel
53Header files for uCommon C++ library.
54
55%description devel -l pl.UTF-8
56Pliki nagłówkowe biblioteki uCommon C++.
57
58%package static
59Summary: Static uCommon C++ library
60Summary(pl.UTF-8): Statyczna biblioteka uCommon C++
61Group: Development/Libraries
62Requires: %{name}-devel = %{version}-%{release}
63
64%description static
65Static uCommon C++ library.
66
67%description static -l pl.UTF-8
68Statyczna biblioteka uCommon C++.
69
70%package apidocs
71Summary: uCommon C++ API documentation
72Summary(pl.UTF-8): Dokumentacja API biblioteki uCommon C++
73Group: Documentation
98ea40c1
ER
74%if "%{_rpmversion}" >= "5"
75BuildArch: noarch
76%endif
a2124e8d
JB
77
78%description apidocs
79API and internal documentation for uCommon C++ library.
80
81%description apidocs -l pl.UTF-8
82Dokumentacja API biblioteki uCommon C++.
83
84%package tools
85Summary: uCommon system and support applications
86Summary(pl.UTF-8): uCommon - aplikacje systemowe i pomocnicze
87Group: Applications/System
88Requires: %{name} = %{version}-%{release}
89
90%description tools
91uCommon system and support applications.
92
93%description tools -l pl.UTF-8
94uCommon - aplikacje systemowe i pomocnicze.
95
96%prep
97%setup -q
98
99%build
a2124e8d 100%configure \
492c374d 101 --with-sslstack=%{?with_gnutls:gnutls}%{!?with_gnutls:openssl}
a2124e8d
JB
102%{__make}
103
104%if %{with apidocs}
105%{__make} doxy
106%endif
107
108%install
109rm -rf $RPM_BUILD_ROOT
110
111%{__make} install \
112 DESTDIR=$RPM_BUILD_ROOT
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post -p /sbin/ldconfig
118%postun -p /sbin/ldconfig
119
120%files
121%defattr(644,root,root,755)
122%doc AUTHORS COPYRIGHT ChangeLog NEWS README README.secure SUPPORT TODO
123%attr(755,root,root) %{_libdir}/libcommoncpp.so.*.*.*
95322b3a 124%attr(755,root,root) %ghost %{_libdir}/libcommoncpp.so.7
a2124e8d 125%attr(755,root,root) %{_libdir}/libucommon.so.*.*.*
95322b3a 126%attr(755,root,root) %ghost %{_libdir}/libucommon.so.7
a2124e8d 127%attr(755,root,root) %{_libdir}/libusecure.so.*.*.*
95322b3a 128%attr(755,root,root) %ghost %{_libdir}/libusecure.so.7
a2124e8d
JB
129
130%files devel
131%defattr(644,root,root,755)
132%attr(755,root,root) %{_bindir}/commoncpp-config
133%attr(755,root,root) %{_bindir}/ucommon-config
134%attr(755,root,root) %{_libdir}/libcommoncpp.so
135%attr(755,root,root) %{_libdir}/libucommon.so
136%attr(755,root,root) %{_libdir}/libusecure.so
137%{_libdir}/libcommoncpp.la
138%{_libdir}/libucommon.la
139%{_libdir}/libusecure.la
140%{_includedir}/commoncpp
141%{_includedir}/ucommon
142%{_pkgconfigdir}/commoncpp.pc
143%{_pkgconfigdir}/ucommon.pc
144%{_mandir}/man1/commoncpp-config.1*
145%{_mandir}/man1/ucommon-config.1*
146
147%files static
148%defattr(644,root,root,755)
149%{_libdir}/libcommoncpp.a
150%{_libdir}/libucommon.a
151%{_libdir}/libusecure.a
152
153%if %{with apidocs}
154%files apidocs
155%defattr(644,root,root,755)
156%doc doc/html/*
157%endif
158
159%files tools
160%defattr(644,root,root,755)
161%attr(755,root,root) %{_bindir}/args
162%attr(755,root,root) %{_bindir}/car
eacd55d3 163%attr(755,root,root) %{_bindir}/keywait
a2124e8d 164%attr(755,root,root) %{_bindir}/mdsum
102622f6 165%attr(755,root,root) %{_bindir}/pdetach
a2124e8d
JB
166%attr(755,root,root) %{_bindir}/scrub-files
167%attr(755,root,root) %{_bindir}/sockaddr
168%attr(755,root,root) %{_bindir}/zerofill
169%{_mandir}/man1/args.1*
170%{_mandir}/man1/car.1*
eacd55d3 171%{_mandir}/man1/keywait.1*
a2124e8d 172%{_mandir}/man1/mdsum.1*
102622f6 173%{_mandir}/man1/pdetach.1*
a2124e8d
JB
174%{_mandir}/man1/scrub-files.1*
175%{_mandir}/man1/sockaddr.1*
176%{_mandir}/man1/zerofill.1*
This page took 0.06797 seconds and 4 git commands to generate.