]> git.pld-linux.org Git - packages/truecrypt.git/blame - truecrypt.spec
- refetch sources
[packages/truecrypt.git] / truecrypt.spec
CommitLineData
669b1609 1#
5043f3cb 2# Conditional build:
d9ce433d 3%bcond_without gui # build without GUI
96f90661
ER
4%if "%{pld_release}" == "ac"
5%bcond_without gcc4 # use gcc4* packages for building
6%else
7%bcond_with gcc4 # use gcc4* packages for building
8%endif
245c8048 9
e83fe546 10%define wx_ver 2.8.12
5043f3cb 11Summary: TrueCrypt - Free Open-Source Disk Encryption Software
36c1559c 12Summary(pl.UTF-8): TrueCrypt - wolnodostępne oprogramowanie do szyfrowania dysków
5043f3cb 13Name: truecrypt
893772cf 14Version: 7.1a
acba4dab 15Release: 1
e3eb5d87 16License: TrueCrypt License Version 3.0
5043f3cb 17Group: Base/Kernel
06c4ba11 18Source0: http://www.truecrypt.org/download/transient/0d3fab254298c015e75a/TrueCrypt%20%{version}%20Source.tar.gz
893772cf 19# Source0-md5: 102d9652681db11c813610882332ae48
e83fe546
AF
20Source1: http://downloads.sourceforge.net/wxwindows/wxWidgets-%{wx_ver}.tar.bz2
21# Source1-md5: 4103e37e277abeb8aee607b990c215c4
156dc433 22Source2: ftp://ftp.rsasecurity.com/pub/pkcs/pkcs-11/v2-20/pkcs11.h
2be033e9 23# Source2-md5: 713ac88786b436a5df02bface7dfce45
69389ceb 24Source3: ftp://ftp.rsasecurity.com/pub/pkcs/pkcs-11/v2-20/pkcs11f.h
2be033e9 25# Source3-md5: 652434a5793eb14aae7b5baa07f6cfc7
69389ceb 26Source4: ftp://ftp.rsasecurity.com/pub/pkcs/pkcs-11/v2-20/pkcs11t.h
2be033e9 27# Source4-md5: aeebc839b98e672982abf566e6a25525
669b1609 28URL: http://www.truecrypt.org/
d9ce433d 29BuildRequires: gcc >= 5:4.0.0
d01e6fc3 30%{?with_gui:BuildRequires: gtk+2-devel}
3946daf2 31BuildRequires: libfuse-devel
d80c1c0a 32BuildRequires: libstdc++-devel
33BuildRequires: pkgconfig
96f90661 34BuildRequires: rpm >= 4.4.9-56
45862313 35BuildRequires: rpmbuild(macros) >= 1.379
d01e6fc3 36%{?with_gui:BuildRequires: xorg-lib-libSM-devel}
a950a9e6 37Requires: device-mapper
3946daf2 38Requires: losetup
de783508 39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5043f3cb 40
96f90661
ER
41%if %{with gcc4}
42# add suffix, but allow ccache, etc in ~/.rpmmacros
43%{expand:%%define __cc %(echo '%__cc' | sed -e 's,-gcc,-gcc4,')}
44%{expand:%%define __cxx %(echo '%__cxx' | sed -e 's,-g++,-g++4,')}
45%{expand:%%define __cpp %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
46%endif
47
5043f3cb
MW
48%description
49Main Features:
6cb97a31
MW
50- Creates a virtual encrypted disk within a file and mounts it as a
51 real disk.
52- Encrypts an entire hard disk partition or a storage device such as
53 USB flash drive.
54- Encryption is automatic, real-time (on-the-fly) and transparent.
55- Provides two levels of plausible deniability, in case an adversary
56 forces you to reveal the password:
467217e3 57 1) Hidden volume (steganography).
669b1609 58 2) No TrueCrypt volume can be identified (volumes cannot be
6cb97a31
MW
59 distinguished from random data).
60- Encryption algorithms: AES-256, Blowfish (448-bit key), CAST5,
61 Serpent, Triple DES, and Twofish. Mode of operation: LRW (CBC
62 supported as legacy).
5043f3cb 63
e8ff4e04
JR
64%description -l pl.UTF-8
65Główne cechy:
467217e3
JB
66- Tworzenie wirtualnego szyfrowanego dysku w pliku i montowanie go
67 jako prawdziwego dysku.
e8ff4e04 68- Szyfrowanie całej partycji twardego dysku lub urządzenia takiego jak
467217e3
JB
69 dysk flash USB.
70- Szyfrowanie automatyczne, w czasie rzeczywistym i przezroczyste.
e8ff4e04
JR
71- Dwa poziomy prawdopodobnych utrudnień, w przypadku, gdy wróg zmusza
72 do wyjawienia hasła:
467217e3 73 1) Ukryty wolumen (steganografia).
e8ff4e04
JR
74 2) Żaden wolumen TrueCrypt nie może być zidentyfikowany (wolumeny
75 nie dadzą się odróżnić od losowych danych).
467217e3 76- Algorytmy szyfrowania: AES-256, Blowfish (klucz 448-bitowy), CAST5,
de783508 77 Serpent, Triple DES oraz Twofish. Tryby działania: LRW (CBC
e8ff4e04 78 obsługiwane dla wstecznej kompatybilności).
5043f3cb 79
5043f3cb 80%prep
96da4e7c 81%setup -q -n %{name}-%{version}-source -a1
69389ceb 82cp %{SOURCE2} %{SOURCE3} %{SOURCE4} .
83
5043f3cb
MW
84
85%build
d9ce433d 86%{__make} wxbuild \
83c98227
ER
87 CC="%{__cc}" \
88 CXX="%{__cxx}" \
89 CFLAGS="%{rpmcflags}" \
90 CXXFLAGS="%{rpmcxxflags}" \
7719e59a 91 WX_ROOT=%{_builddir}/%{name}-%{version}-source/wxWidgets-%{wx_ver} \
d01e6fc3 92 %{!?with_gui:NOGUI=1} \
7719e59a 93 VERBOSE=1
d9ce433d 94%{__make} \
d01e6fc3 95 %{!?with_gui:NOGUI=1} \
156dc433 96 WXSTATIC=1
5043f3cb
MW
97
98%install
99rm -rf $RPM_BUILD_ROOT
d9ce433d 100install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
5043f3cb 101
245c8048 102install Main/truecrypt $RPM_BUILD_ROOT%{_bindir}/truecrypt
007688d8 103mv -f Release/Setup\ Files/TrueCrypt\ User\ Guide.pdf TrueCrypt-User-Guide.pdf
5043f3cb
MW
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
5043f3cb
MW
108%files
109%defattr(644,root,root,755)
007688d8 110%doc License.txt Readme.txt TrueCrypt-User-Guide.pdf
245c8048 111%attr(755,root,root) %{_bindir}/%{name}
112##%%{_mandir}/man1/*
This page took 0.137909 seconds and 4 git commands to generate.