]> git.pld-linux.org Git - packages/tevent.git/blame - tevent.spec
- rebuild with python 3.8
[packages/tevent.git] / tevent.spec
CommitLineData
429b086b
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x binding
4
d79016b6
JB
5Summary: An event system library
6Summary(pl.UTF-8): Biblioteka systemu zdarzeń
7Name: tevent
429b086b 8Version: 0.9.39
59de6c57 9Release: 2
d79016b6
JB
10License: LGPL v3+
11Group: Libraries
fc0c01b9 12Source0: https://www.samba.org/ftp/tevent/%{name}-%{version}.tar.gz
429b086b 13# Source0-md5: b937d5e980fa9704f20b57df688845c0
d79016b6 14URL: http://tevent.samba.org/
429b086b 15%if %{with python2}
d79016b6 16BuildRequires: python-devel >= 1:2.4.2
429b086b
JB
17BuildRequires: python-talloc-devel >= 2:2.1.16
18%endif
19BuildRequires: python3-devel >= 1:3.2
20BuildRequires: python3-talloc-devel >= 2:2.1.16
d79016b6 21BuildRequires: rpm-pythonprov
429b086b
JB
22BuildRequires: rpmbuild(macros) >= 1.507
23BuildRequires: talloc-devel >= 2:2.1.16
d79016b6
JB
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Tevent is an event system based on the talloc memory management
28library. It is the core event system used in Samba.
29
30The low level tevent has support for many event types, including
31timers, signals, and the classic file descriptor events.
32
33Tevent also provide helpers to deal with asynchronous code providing
34the tevent_req (tevent request) functions.
35
36%description -l pl.UTF-8
37Tevent to system zdarzeń oparty na bibliotece zarządzającej pamięcią
38talloc. Jest to główny system zdarzeń używany w Sambie.
39
40Niskopoziomowo tevent obsługuje wiele rodzajów zdarzeń, w tym
41zegary, sygnały i zdarzenia związane z klasycznymi deskryptorami
42plików.
43
44Tevent udostępnia także funkcje pomocnicze tevent_req (żądanie tevent)
45dla kodu asynchronicznego.
46
47%package devel
48Summary: Header files for tevent library
49Summary(pl.UTF-8): Pliki nagłówkowe biblioteki tevent
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
429b086b 52Requires: talloc-devel >= 2:2.1.16
d79016b6
JB
53
54%description devel
55Header files for tevent library.
56
57%description devel -l pl.UTF-8
58Pliki nagłówkowe biblioteki tevent.
59
60%package -n python-tevent
429b086b
JB
61Summary: Python 2 bindings for tevent
62Summary(pl.UTF-8): Interfejs Pythona 2 do tevent
d79016b6
JB
63Group: Libraries/Python
64Requires: %{name} = %{version}-%{release}
429b086b 65Requires: python-talloc >= 2:2.1.16
d79016b6
JB
66
67%description -n python-tevent
429b086b 68Python 2 bindings for tevent.
d79016b6
JB
69
70%description -n python-tevent -l pl.UTF-8
429b086b
JB
71Interfejs Pythona 2 do tevent.
72
73%package -n python3-tevent
74Summary: Python 3 bindings for tevent
75Summary(pl.UTF-8): Interfejs Pythona 3 do tevent
76Group: Libraries/Python
77Requires: %{name} = %{version}-%{release}
78Requires: python3-talloc >= 2:2.1.16
79
80%description -n python3-tevent
81Python 3 bindings for tevent.
82
83%description -n python3-tevent -l pl.UTF-8
84Interfejs Pythona 3 do tevent.
d79016b6
JB
85
86%prep
87%setup -q
88
89%build
429b086b
JB
90export JOBS=1
91
d79016b6
JB
92CC="%{__cc}" \
93CFLAGS="%{rpmcflags}" \
429b086b 94%{__python3} buildtools/bin/waf configure \
d79016b6 95 --prefix=%{_prefix} \
b23e518b 96 --libdir=%{_libdir} \
429b086b
JB
97 --disable-rpath \
98 %{?with_python2:--extra-python=%{__python}}
d79016b6
JB
99
100%{__make} \
101 V=1
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106%{__make} install \
107 DESTDIR=$RPM_BUILD_ROOT
108
429b086b 109%if %{with python2}
70aba668
JB
110%py_comp $RPM_BUILD_ROOT%{py_sitedir}
111%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
112%py_postclean
429b086b
JB
113%endif
114
115%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
116%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
70aba668 117
d79016b6
JB
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
123
124%files
125%defattr(644,root,root,755)
126%attr(755,root,root) %{_libdir}/libtevent.so.*.*.*
127%attr(755,root,root) %ghost %{_libdir}/libtevent.so.0
128
129%files devel
130%defattr(644,root,root,755)
131%attr(755,root,root) %{_libdir}/libtevent.so
132%{_includedir}/tevent.h
133%{_pkgconfigdir}/tevent.pc
134
429b086b 135%if %{with python2}
d79016b6
JB
136%files -n python-tevent
137%defattr(644,root,root,755)
138%attr(755,root,root) %{py_sitedir}/_tevent.so
70aba668 139%{py_sitedir}/tevent.py[co]
429b086b
JB
140%endif
141
142%files -n python3-tevent
143%defattr(644,root,root,755)
144%attr(755,root,root) %{py3_sitedir}/_tevent.cpython-*.so
145%{py3_sitedir}/tevent.py
146%{py3_sitedir}/__pycache__/tevent.cpython-*.py[co]
This page took 0.148296 seconds and 4 git commands to generate.