]> git.pld-linux.org Git - packages/test.git/blame - test.spec
check AT_SECURE value on builders
[packages/test.git] / test.spec
CommitLineData
efd472d0
ER
1# skeleton for rpm testing.
2# create your own test in separate branch, keep master branch clean
bfa51a85
ER
3#
4# git checkout -b test/feature
5# git push origin -u test/feature
efd472d0
ER
6Summary: testing something
7Name: test
9d98269a 8Version: 1
b1247bf1 9Release: 7
9d98269a
KK
10License: GPL
11Group: Applications/System
12URL: http://www.pld-linux.org/
9d98269a
KK
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15%description
efd472d0 16testing something
9d98269a
KK
17
18%prep
19%setup -qcT
f30ddab9
JP
20cat > test.c <<EOF
21#include <stdio.h>
22#include <sys/auxv.h>
23
24int main() {
25 printf("%lu\n", getauxval(AT_SECURE));
26}
27EOF
28%{__cc} test.c -o test
29./test
9d98269a
KK
30
31%install
efd472d0 32rm -rf $RPM_BUILD_ROOT
bfa51a85 33install -d $RPM_BUILD_ROOT
9d98269a
KK
34
35%clean
bfa51a85 36rm -rf $RPM_BUILD_ROOT
9d98269a
KK
37
38%files
39%defattr(644,root,root,755)
This page took 0.061645 seconds and 4 git commands to generate.