]> git.pld-linux.org Git - packages/tesseract.git/blame - tesseract.spec
- updated to 3.05.01
[packages/tesseract.git] / tesseract.spec
CommitLineData
2fecdb4d
PG
1# TODO:
2# - warnings at compile stage about pointer size on amd64 - needs check
9694f838
JB
3#
4# Conditional build:
b011b0dc 5%bcond_without openmp # OpenMP support
9694f838
JB
6%bcond_with opencl # OpenCL support
7#
a7d2de0d 8Summary: Tesseract Open Source OCR Engine
877b8a7e 9Summary(pl.UTF-8): Tesseract - silnik OCR o otwartych źródłach
afaac0e1 10Name: tesseract
61d69fb5
JB
11Version: 3.05.01
12Release: 1
187eebd6 13License: Apache v2.0
afaac0e1 14Group: Applications/Graphics
61d69fb5 15#Source0Download: https://github.com/tesseract-ocr/tesseract/releases
9694f838 16Source0: https://github.com/tesseract-ocr/tesseract/archive/%{version}/%{name}-%{version}.tar.gz
61d69fb5 17# Source0-md5: 0ac91d57fd35a47f93a9e47b29b63c75
9694f838
JB
18Patch0: %{name}-opencl.patch
19URL: https://github.com/tesseract-ocr/
20%{?with_opencl:BuildRequires: OpenCL-devel}
61d69fb5 21BuildRequires: autoconf >= 2.59
a7d2de0d 22BuildRequires: automake
caa3afbb 23BuildRequires: cairo-devel
cf0c79c1 24BuildRequires: leptonlib-devel >= 1.74
b011b0dc 25%{?with_openmp:BuildRequires: libgomp-devel}
ba6a7995 26BuildRequires: libicu-devel
9694f838
JB
27BuildRequires: libstdc++-devel >= 6:4.7
28BuildRequires: libtiff-devel
29BuildRequires: libtool >= 2:2
caa3afbb 30BuildRequires: pango-devel
f7537631 31Suggests: tesseract-data >= 3
afaac0e1
ER
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35A commercial quality OCR engine originally developed at HP between
361985 and 1995. In 1995, this engine was among the top 3 evaluated by
37UNLV. It was open-sourced by HP and UNLV in 2005.
38
ac8a5dbe
JR
39%description -l pl.UTF-8
40Silnik OCR o komercyjnej jakości oryginalnie stworzony przez HP w
41latach 1985-1995. W 1995 roku był jednym z 3 najlepszych wg UNLV.
42Źródła zostały uwolnione przez HP i UNLV w 2005 roku.
a1b42a34 43
ba6a7995
TP
44%package training
45Summary: Tesseract training tools
ab3171d0 46Summary(pl.UTF-8): Narzędzia treningowe Tesseracta
ba6a7995
TP
47Group: Applications/Graphics
48Requires: %{name} = %{version}
49
50%description training
51This package contains the Tesseract training tools.
52
53%description training -l pl.UTF-8
ab3171d0 54Ten pakiet zawiera programy do trenowania Tesseracta.
ba6a7995 55
f7537631
JB
56%package devel
57Summary: Header files for Tesseract libraries
58Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Tesseracta
59Group: Development/Libraries
2fecdb4d 60Requires: %{name} = %{version}-%{release}
f7537631
JB
61Requires: leptonlib-devel
62Requires: libstdc++-devel
2fecdb4d 63
f7537631
JB
64%description devel
65This package contains the development header files necessary to
66develop applications using Tesseract API.
2fecdb4d 67
f7537631
JB
68%description devel -l pl.UTF-8
69Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
70wykorzystujących API Tesseracta.
2fecdb4d 71
f7537631
JB
72%package static
73Summary: Static Tesseract libraries
74Summary(pl.UTF-8): Statyczne biblioteki Tesseracta
2fecdb4d 75Group: Development/Libraries
f7537631 76Requires: %{name}-devel = %{version}-%{release}
2fecdb4d 77
f7537631
JB
78%description static
79Static Tesseract libraries.
80
81%description static -l pl.UTF-8
82Statyczne biblioteki Tesseracta.
2fecdb4d 83
afaac0e1 84%prep
6f607027 85%setup -q
9694f838 86%patch0 -p1
afaac0e1
ER
87
88%build
f7537631
JB
89%{__libtoolize}
90%{__aclocal}
91%{__autoconf}
92%{__autoheader}
93%{__automake}
9694f838
JB
94%configure \
95 %{?with_opencl:--enable-opencl} \
b011b0dc 96 %{!?with_openmp:--disable-openmp}
afaac0e1 97%{__make}
caa3afbb 98%{__make} training
afaac0e1
ER
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
105
caa3afbb
TP
106%{__make} training-install \
107 DESTDIR=$RPM_BUILD_ROOT
108
6f607027
TP
109%{__rm} $RPM_BUILD_ROOT%{_libdir}/libtesseract.la
110
afaac0e1
ER
111%clean
112rm -rf $RPM_BUILD_ROOT
113
0527fb34
BS
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
afaac0e1
ER
117%files
118%defattr(644,root,root,755)
cf0c79c1 119%doc AUTHORS COPYING ChangeLog README.md
ba6a7995
TP
120%attr(755,root,root) %{_bindir}/tesseract
121%attr(755,root,root) %{_libdir}/libtesseract.so.*.*.*
8028172e 122%attr(755,root,root) %ghost %{_libdir}/libtesseract.so.3
caa3afbb 123%{_datadir}/tessdata
ba6a7995
TP
124%{_mandir}/man1/tesseract.1*
125
126%files training
127%defattr(644,root,root,755)
128%attr(755,root,root) %{_bindir}/ambiguous_words
d02c75d3 129%attr(755,root,root) %{_bindir}/classifier_tester
ba6a7995
TP
130%attr(755,root,root) %{_bindir}/cntraining
131%attr(755,root,root) %{_bindir}/combine_tessdata
132%attr(755,root,root) %{_bindir}/dawg2wordlist
133%attr(755,root,root) %{_bindir}/mftraining
134%attr(755,root,root) %{_bindir}/set_unicharset_properties
135%attr(755,root,root) %{_bindir}/shapeclustering
136%attr(755,root,root) %{_bindir}/text2image
137%attr(755,root,root) %{_bindir}/unicharset_extractor
138%attr(755,root,root) %{_bindir}/wordlist2dawg
854e1083 139%{_mandir}/man1/ambiguous_words.1*
8028172e
JB
140%{_mandir}/man1/cntraining.1*
141%{_mandir}/man1/combine_tessdata.1*
854e1083 142%{_mandir}/man1/dawg2wordlist.1*
8028172e 143%{_mandir}/man1/mftraining.1*
854e1083 144%{_mandir}/man1/shapeclustering.1*
8028172e
JB
145%{_mandir}/man1/unicharset_extractor.1*
146%{_mandir}/man1/wordlist2dawg.1*
2da6320c 147
2fecdb4d 148%files devel
2da6320c 149%defattr(644,root,root,755)
8028172e 150%attr(755,root,root) %{_libdir}/libtesseract.so
f7537631 151%{_includedir}/%{name}
854e1083 152%{_pkgconfigdir}/tesseract.pc
8028172e
JB
153%{_mandir}/man5/unicharambigs.5*
154%{_mandir}/man5/unicharset.5*
f7537631
JB
155
156%files static
157%defattr(644,root,root,755)
8028172e 158%{_libdir}/libtesseract.a
This page took 0.092778 seconds and 4 git commands to generate.