]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- up to 1.6.3
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
b4d1f957 2# - fix java build with java-gcj-compat and s/java-sun/jdk/
1930bef0 3# - remove net_client_only and add db bcond (then without apache and
4# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 5# - finish ruby
1930bef0 6#
bab73684 7# Conditional build:
65c1d4bd 8%bcond_with net_client_only # build only net client
3fc01170 9%bcond_without neon # use serf instead of neon
65c1d4bd
JB
10%bcond_without python # build without python bindings (broken)
11%bcond_without perl # build without perl bindings
73ab938a 12%bcond_without ruby # build without ruby bindings
65c1d4bd
JB
13%bcond_without apache # build without apache support (webdav, etc)
14%bcond_without javahl # build without javahl support (Java high-level bindings)
15%bcond_without tests # don't perform "make check"
65f2befa 16%bcond_without kwallet # build without kde4 wallet support
7b27380f 17#
bc126282 18%ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
c2f5643d 19%undefine with_javahl
bc126282
AG
20%endif
21#
b56474ff 22%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 23%define apxs /usr/sbin/apxs
1f630180
ER
24%define pdir SVN
25%define pnam _Core
12ae68c1 26#
04129f48 27%if %{with neon}
a510fada 28%define webdavlib neon
04129f48
AG
29%else
30%define webdavlib serf
a510fada
AM
31%endif
32#
67cb9518 33Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
34Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
35Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 36Name: subversion
3ffb3517 37Version: 1.6.3
229b2a85 38Release: 1
6f88d80e 39License: Apache/BSD-like
93b78127 40Group: Development/Version Control
a5c00029 41Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
3ffb3517 42# Source0-md5: 8bf7637ac99368db0890e3f085fa690d
93b78127 43Source1: %{name}-dav_svn.conf
65318afa 44Source2: %{name}-authz_svn.conf
b56474ff
AM
45Source3: %{name}-svnserve.init
46Source4: %{name}-svnserve.sysconfig
a510fada
AM
47# current subversion tarball has correct *.swg files
48# but after regeneration these are broken again, so
49# we still need this script
f313e9a9 50Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 51Patch0: %{name}-home_etc.patch
d46e45ba 52Patch1: %{name}-DESTDIR.patch
00664663 53Patch2: %{name}-ruby-datadir-path.patch
d2bf70bf 54URL: http://subversion.tigris.org/
4945947e
AM
55%if %{with net_client_only}
56%global apache_modules_api 0
57%else
f2a757d6 58%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 59BuildRequires: automake
3817faf5 60BuildRequires: db-devel >= 4.1.25
e8d9186f 61BuildRequires: rpmbuild(macros) >= 1.268
0905b458 62%if %{with perl}
522a69b4 63BuildRequires: perl-devel >= 1:5.8.0
64BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 65BuildRequires: swig-perl >= 1.3.24
536b3fd3 66%endif
6ac3574b
AM
67%if %{with python}
68BuildRequires: python-ctypesgen
69BuildRequires: python-devel >= 2.2
70BuildRequires: swig-python >= 1.3.24
71%endif
72%if %{with ruby}
73BuildRequires: ruby-devel
74BuildRequires: swig-ruby >= 1.3.24
75%endif
b4d1f957 76%{?with_javahl:BuildRequires: java-sun}
6ac3574b 77BuildRequires: cyrus-sasl-devel
0905b458 78%endif
16429189 79BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 80BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 81BuildRequires: autoconf >= 2.59
79d8c53c 82BuildRequires: bison
93b78127 83BuildRequires: expat-devel
86ea8fde 84BuildRequires: gettext-devel
1429fa1c 85BuildRequires: gnome-keyring-devel
65f2befa 86%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
f4e6a380 87BuildRequires: libtool >= 1.4-9
a562165a 88BuildRequires: sed >= 4.0
c26d84c4 89BuildRequires: sqlite3-devel >= 3.6.11
a562165a
JB
90BuildRequires: texinfo
91BuildRequires: which
92%if %{with neon}
bd3c99a8 93BuildRequires: neon-devel >= 0.26.0
a562165a
JB
94%else
95BuildRequires: serf-devel
e3ad24ea 96%endif
53855fbf 97BuildRequires: python >= 2.2
ed6210a2 98BuildRequires: python-modules >= 2.2
027f8ebe 99Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
100BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
f4070f5f 102%define _libexecdir %{_libdir}/svn
1af5e34d
ER
103%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
104%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
105
106%description
107The goal of the Subversion project is to build a version control
108system that is a compelling replacement for CVS in the open source
109community.
110
111Our goals are:
112- All current CVS features.
113- Directories, renames, and file meta-data are versioned.
114- Symbolic links, etc, are supported
115- Commits are truly atomic.
116- Branching and tagging are cheap (constant time) operations
117- Repeated merges are handled gracefully
118- Support for plug-in client side diff programs
119- Natively client/server
120- Client/server protocol sends diffs in both directions
121- Costs are proportional to change size, not project size
122- Internationalization
123- Progressive multi-lingual support
124
aa59005f 125%description -l pl.UTF-8
93b78127
AM
126Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
127zamiennika dla CVS.
128
129Cele projektu to:
aa59005f 130- Wszystkie aktualne możliwości CVS.
24406120
JB
131- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
132- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
133- Commity są w pełni atomowe.
134- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
135- Dobra obsługa powtarzanego łączenia (merge).
136- Obsługa wtyczek diff po stronie klienta.
93b78127 137- Natywny klient/serwer.
aa59005f 138- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
139- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
140- Internacjonalizacja.
aa59005f 141- Postępujące wsparcie dla wielu języków.
93b78127 142
aa59005f
JR
143%description -l pt_BR.UTF-8
144O objetivo do projeto Subversion é construir um sistema de controle de
145versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 146System) na comunidade opensource, fornecendo grandes melhorias.
147
f4e6a380
AM
148%package libs
149Summary: Subversion libraries and modules
abe3c421 150Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 151Group: Libraries
04129f48 152%{?with_neon:Requires: neon >= 0.26.0}
53855fbf 153Obsoletes: libsubversion0
f4e6a380
AM
154
155%description libs
156Subversion libraries and modules.
157
aa59005f
JR
158%description libs -l pl.UTF-8
159Biblioteka subversion oraz ładowalne moduły.
f4e6a380 160
93b78127
AM
161%package devel
162Summary: Header files and develpment documentation for subversion
abe3c421
ER
163Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
164Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 165Group: Development/Libraries
9cb7e099 166Requires: %{name}-libs = %{version}-%{release}
c5b1d686 167Requires: apr-util-devel >= 1:1.0.0
04129f48 168%{?with_neon:Requires: neon-devel >= 0.26.0}
12cf252c 169Obsoletes: libsubversion0-devel
93b78127
AM
170
171%description devel
172Header files and develpment documentation for subversion.
173
aa59005f
JR
174%description devel -l pl.UTF-8
175Pliki nagłówkowe i dokumetacja do subversion.
93b78127 176
aa59005f
JR
177%description devel -l pt_BR.UTF-8
178Este pacote provê os arquivos necessários para desenvolvedores
92066deb 179interagirem com o Subversion.
180
93b78127
AM
181%package static
182Summary: Static subversion library
abe3c421
ER
183Summary(pl.UTF-8): Biblioteka statyczna subversion
184Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
185Group: Development/Libraries
186Requires: %{name}-devel = %{version}
12cf252c 187Obsoletes: libsubversion0-static-devel
93b78127
AM
188
189%description static
190Static subversion library.
191
aa59005f 192%description static -l pl.UTF-8
93b78127
AM
193Biblioteka statyczna subversion.
194
aa59005f
JR
195%description static -l pt_BR.UTF-8
196Este pacote provê um cliente estático do subversion.
92066deb 197
b56474ff
AM
198%package svnserve
199Summary: Subversion svnserve
abe3c421 200Summary(pl.UTF-8): Subversion svnserve
b56474ff 201Group: Networking/Daemons
3817faf5 202Requires(post,preun): /sbin/chkconfig
93f1d402 203Requires(postun): /usr/sbin/groupdel
204Requires(postun): /usr/sbin/userdel
205Requires(pre): /bin/id
206Requires(pre): /usr/bin/getgid
207Requires(pre): /usr/lib/rpm/user_group.sh
208Requires(pre): /usr/sbin/groupadd
209Requires(pre): /usr/sbin/useradd
210Requires(pre): /usr/sbin/usermod
9cb7e099 211Requires: %{name} = %{version}-%{release}
7b27380f 212Requires: rc-scripts
a1bac09d
213Provides: group(svn)
214Provides: user(svn)
b56474ff
AM
215
216%description svnserve
217Subversion svnserve server.
218
aa59005f 219%description svnserve -l pl.UTF-8
b56474ff
AM
220Serwer subversion svnserve.
221
4bbdbbf8
AM
222%package tools
223Summary: Subversion tools and scripts
abe3c421
ER
224Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
225Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 226Group: Applications
4bbdbbf8 227%pyrequires_eq python
7b27380f 228Requires: %{name} = %{version}-%{release}
4bbdbbf8
AM
229Requires: python-subversion = %{version}
230
231%description tools
232Subversion tools and scripts.
233
aa59005f
JR
234%description tools -l pl.UTF-8
235Narzędzia oraz skrypty dla subversion.
4bbdbbf8 236
fe5bb6bb 237%package -n bash-completion-subversion
238Summary: bash completion for subversion
abe3c421 239Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 240Group: Applications/Shells
e30588c4 241Requires: %{name} = %{version}-%{release}
53855fbf 242Requires: bash-completion
e30588c4 243Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 244
245%description -n bash-completion-subversion
246Bash completion for subversion.
247
aa59005f
JR
248%description -n bash-completion-subversion -l pl.UTF-8
249Dopełnienia basha dla subversion.
fe5bb6bb 250
1cc7453a 251%package -n java-subversion
65c1d4bd
JB
252Summary: Subversion Java bindings
253Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 254Group: Development/Languages/Java
255Requires: %{name}-libs = %{version}-%{release}
256
257%description -n java-subversion
258This is a set of Java classes which provide the functionality of
259subversion-libs, the Subversion libraries. It is useful if you want
260to, for example, write a Java class that manipulates a Subversion
261repository or working copy. See the 'subversion' package for more
262information.
263
65c1d4bd
JB
264%description -n java-subversion -l pl.UTF-8
265Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
266subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
267pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
268roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 269
fa3ff1b2 270%package -n python-subversion
65c1d4bd
JB
271Summary: Subversion Python bindings
272Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
273Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 274Group: Development/Languages/Python
f4e6a380 275%pyrequires_eq python
9cb7e099 276Requires: %{name}-libs = %{version}-%{release}
53855fbf 277Obsoletes: subversion-python
f4e6a380 278
fa3ff1b2 279%description -n python-subversion
65c1d4bd 280Subversion Python bindings.
f4e6a380 281
aa59005f 282%description -n python-subversion -l pl.UTF-8
65c1d4bd 283Dowiązania do Subversion dla Pythona.
f4e6a380 284
aa59005f 285%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 286Módulos Python para acessar os recursos do Subversion.
92066deb 287
137fcafd
AM
288%package -n python-csvn
289Summary: CTypes Subversion Python bindings
290Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
291Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
292Group: Development/Languages/Python
293%pyrequires_eq python
294Requires: %{name}-libs = %{version}-%{release}
295
296%description -n python-csvn
297Subversion CTypes Python bindings.
298
299%description -n python-csvn -l pl.UTF-8
300Dowiązania do Subversion dla Pythona używające CTypes.
301
302%description -n python-csvn -l pt_BR.UTF-8
303Módulos Python para acessar os recursos do Subversion.
304
b56474ff 305%package -n perl-subversion
65c1d4bd
JB
306Summary: Subversion Perl bindings
307Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
308Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 309Group: Development/Languages/Perl
9cb7e099 310Requires: %{name}-libs = %{version}-%{release}
53855fbf 311Obsoletes: subversion-perl
b56474ff
AM
312
313%description -n perl-subversion
65c1d4bd 314Subversion Perl bindings.
b56474ff 315
aa59005f 316%description -n perl-subversion -l pl.UTF-8
65c1d4bd 317Dowiązania do Subversion dla Perla.
b56474ff 318
aa59005f 319%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 320Módulos Perl para acessar os recursos do Subversion.
b56474ff 321
d46e45ba
AM
322%package -n ruby-subversion
323Summary: Subversion Ruby bindings
d2bf70bf 324Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
325Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
326Group: Development/Languages
327Requires: %{name}-libs = %{version}-%{release}
328Obsoletes: subversion-ruby
329
330%description -n ruby-subversion
331Subversion Ruby bindings.
332
333%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 334Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
335
336%description -n ruby-subversion -l pt_BR.UTF-8
337Módulos Ruby para acessar os recursos do Subversion.
338
93b78127
AM
339%package -n apache-mod_dav_svn
340Summary: Apache module: Subversion Server
abe3c421 341Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 342Group: Networking/Daemons
7b27380f 343Requires: %{name} = %{version}-%{release}
53855fbf 344Requires: apache(modules-api) = %apache_modules_api
7887b1ac 345Requires: apache-mod_dav
93b78127
AM
346
347%description -n apache-mod_dav_svn
348Apache module: Subversion Server.
349
aa59005f
JR
350%description -n apache-mod_dav_svn -l pl.UTF-8
351Moduł apache: Serwer Subversion.
93b78127 352
65318afa
AF
353%package -n apache-mod_authz_svn
354Summary: Apache module: Subversion Server - path-based authorization
abe3c421 355Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 356Group: Networking/Daemons
53855fbf 357Requires: apache(modules-api) = %apache_modules_api
9cb7e099 358Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
359
360%description -n apache-mod_authz_svn
361Apache module: Subversion Server - path-based authorization.
362
aa59005f
JR
363%description -n apache-mod_authz_svn -l pl.UTF-8
364Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 365
1429fa1c
AM
366%package -n gnome-keyring-subversion
367Summary: Subversion module for Gnome Keyring
368Summary(pl.UTF-8): Moduł subversion dla zarządcy kluczy Gnome
369Group: X11/Applications
370
371%description -n gnome-keyring-subversion
372Subversion module for Gnome Keyring.
373
374%description -n gnome-keyring-subversion -l pl.UTF-8
375Moduł subversion dla zarządcy kluczy Gnome.
376
377%package -n kde4-kwallet-subversion
378Summary: Subversion module for KDE Wallet
379Summary(pl.UTF-8): Moduł subversion dla Portfela KDE
380Group: X11/Applications
381
382%description -n kde4-kwallet-subversion
383Subversion module for KDE Wallet.
384
385%description -n kde4-kwallet-subversion -l pl.UTF-8
386Moduł subversion dla Portfela KDE.
387
93b78127 388%prep
a5c00029 389%setup -q
e30588c4 390rm -rf apr apr-util neon
ed6210a2 391%patch0 -p0
d4bccc60 392%patch1 -p1
00664663 393%patch2 -p0
a510fada
AM
394
395sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
396
397# serf.m4 macro is broken and ignores --without serf
244bdb04 398%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
027f8ebe 399
93b78127 400%build
93f1d402 401rm subversion/bindings/swig/proxy/*.swg
24406120 402cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 403cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 404chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 405
93b78127 406%configure \
5dfeafd7 407 --with-editor=vi \
12ae68c1 408 --with-zlib=%{_libdir} \
536b3fd3
AM
409%if %{with net_client_only}
410 --without-apache \
411 --without-swig \
412 --without-apxs \
413 --without-berkeley-db \
414%else
fa6fa2cf 415 --disable-runtime-module-search \
86ee97d3 416 --disable-mod-activation \
0905b458 417%if %{with apache}
536b3fd3 418 --with-apxs=%{_sbindir}/apxs \
0905b458 419%else
420 --without-apache \
421 --without-apxs \
536b3fd3 422 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
0905b458 423%endif
73ab938a 424%if !%{with python} && !%{with perl} && !%{with ruby}
0905b458 425 --without-swig \
426%endif
137fcafd 427 %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
1cc7453a 428 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 429%endif
1cc7453a 430 --with-jdk="%{java_home}" \
04129f48 431%if %{with neon}
e3ad24ea 432 --without-serf \
e30588c4 433 --with-neon=%{_prefix} \
78f330c4 434 --disable-neon-version-check \
04129f48
AG
435%else
436 --with-serf=%{_prefix} \
437 --without-neon \
e3ad24ea 438%endif
16429189 439 --with-apr=%{_bindir}/apr-1-config \
1429fa1c 440 --with-apr-util=%{_bindir}/apu-1-config \
65f2befa 441%if %{with kwallet}
1429fa1c 442 --with-kwallet \
65f2befa 443%endif
1429fa1c 444 --with-gnome-keyring
536b3fd3 445
1f630180 446%{__make} -j1
536b3fd3 447
cf353d53 448%if !%{with net_client_only}
b56474ff 449# python
0905b458 450%if %{with python}
137fcafd
AM
451# ctypes bindings
452%{__make} ctypes-python
453# swig bindings
86a4919e 454%{__make} swig-py \
65318afa
AF
455 swig_pydir=%{py_sitedir}/libsvn \
456 swig_pydir_extra=%{py_sitedir}/svn
0905b458 457%endif
b56474ff 458# perl
0905b458 459%if %{with perl}
390bb8f4 460%{__make} -j1 swig-pl-lib
bf539998
AM
461odir=$(pwd)
462cd subversion/bindings/swig/perl/native
463%{__perl} Makefile.PL INSTALLDIRS=vendor
b445847c 464%{__make} -j1
bf539998 465cd $odir
536b3fd3 466%endif
1cc7453a 467%if %{with javahl}
b445847c 468%{__make} -j1 javahl \
1cc7453a 469 javahl_javadir="%{_javadir}"
470%endif
d46e45ba
AM
471# ruby
472%if %{with ruby}
473%{__make} swig-rb
474%endif
12ae68c1
AM
475%endif
476
477%if %{with tests}
478%{__make} check
d46e45ba 479%if %{with python}
137fcafd 480%{__make} check-ctypes-python
d46e45ba
AM
481%{__make} check-swig-py
482%endif
483%if %{with perl}
484%{__make} check-swig-pl
485%endif
486%if %{with ruby}
487%{__make} check-swig-rb
488%endif
0905b458 489%endif
93b78127
AM
490
491%install
492rm -rf $RPM_BUILD_ROOT
1326bb99 493install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 494 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 495 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 496 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 497
1f630180 498%{__make} install -j1 \
1cc7453a 499%if %{with javahl}
500 install-javahl \
501 javahl_javadir="%{_javadir}" \
502%endif
d46e45ba
AM
503%if !%{with net_client_only}
504%if %{with python}
0905b458 505 install-swig-py \
137fcafd 506 install-ctypes-python \
d46e45ba
AM
507%endif
508%if %{with ruby}
509 install-swig-rb install-swig-rb-doc \
510%endif
0905b458 511%endif
f2a757d6 512 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 513 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
514 swig_pydir=%{py_sitedir}/libsvn \
515 swig_pydir_extra=%{py_sitedir}/svn
93b78127 516
cf353d53 517%if !%{with net_client_only} && %{with perl}
bf539998
AM
518%{__make} install-swig-pl-lib \
519 DESTDIR=$RPM_BUILD_ROOT
b445847c 520%{__make} -C subversion/bindings/swig/perl/native install \
bf539998
AM
521 DESTDIR=$RPM_BUILD_ROOT \
522 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
523 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
bf539998
AM
524%endif
525
0905b458 526%if %{with apache}
1af5e34d
ER
527install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
528install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
529install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
530install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 531%endif
93b78127 532
cf353d53 533%if !%{with net_client_only}
1326bb99 534install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 535%if %{with python}
f4e6a380
AM
536%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
537%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
538find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
539install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 540%endif
0905b458 541%endif
f4e6a380 542
1326bb99
JK
543install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
544install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 545
205a3ddc
AM
546%find_lang %{name}
547
dd73606c 548%{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
c39b6844 549rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
550rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
a6ecf312 551
e23909be
JB
552%clean
553rm -rf $RPM_BUILD_ROOT
554
a1bac09d
555%pre svnserve
556%groupadd -g 86 svn
557%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
558
d2bf70bf
JB
559%post libs -p /sbin/ldconfig
560%postun libs -p /sbin/ldconfig
561
562%post devel -p /sbin/postshell
6f99c3bd 563-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 564
d2bf70bf 565%postun devel -p /sbin/postshell
6f99c3bd 566-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 567
d2bf70bf
JB
568%post -n perl-subversion -p /sbin/ldconfig
569%postun -n perl-subversion -p /sbin/ldconfig
570
571%post -n python-subversion -p /sbin/ldconfig
572%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 573
b56474ff 574%post svnserve
e8d9186f
ER
575/sbin/chkconfig --add svnserve
576%service svnserve restart "svnserve daemon"
577
b56474ff
AM
578%preun svnserve
579if [ "$1" = "0" ]; then
e8d9186f
ER
580 %service svnserve stop
581 /sbin/chkconfig --del svnserve
b56474ff
AM
582fi
583
a1bac09d
584%postun svnserve
585if [ "$1" = "0" ]; then
586 %userremove svn
587 %groupremove svn
588fi
589
93b78127 590%post -n apache-mod_dav_svn
e8d9186f 591%service -q httpd restart
93b78127
AM
592
593%preun -n apache-mod_dav_svn
594if [ "$1" = "0" ]; then
e8d9186f 595 %service -q httpd restart
93b78127
AM
596fi
597
93b78127
AM
598%files
599%defattr(644,root,root,755)
983a49f6 600%doc BUGS CHANGES COPYING INSTALL README
d37298dc 601%doc doc/*/*.html
4bbdbbf8
AM
602%doc tools/hook-scripts/*.{pl,py,example}
603%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 604%doc tools/xslt/*
b445847c
JB
605%attr(755,root,root) %{_bindir}/svn
606%attr(755,root,root) %{_bindir}/svnadmin
607%attr(755,root,root) %{_bindir}/svndumpfilter
608%attr(755,root,root) %{_bindir}/svnlook
609%attr(755,root,root) %{_bindir}/svnsync
610%attr(755,root,root) %{_bindir}/svnversion
611%{_mandir}/man1/svn.1*
612%{_mandir}/man1/svnadmin.1*
613%{_mandir}/man1/svndumpfilter.1*
614%{_mandir}/man1/svnlook.1*
615%{_mandir}/man1/svnsync.1*
616%{_mandir}/man1/svnversion.1*
f4e6a380 617
205a3ddc 618%files libs -f %{name}.lang
f4e6a380 619%defattr(644,root,root,755)
b445847c
JB
620%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
621%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
622%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
623%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
624%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
625%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
626%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
627%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
628%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
629%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
630%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
631%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
632%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
633%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
634%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
635%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
636%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
637%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
a510fada
AM
638%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
639%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
b445847c
JB
640%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
641%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
642%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
643%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
644%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
645%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
646%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
647%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
93b78127
AM
648
649%files devel
650%defattr(644,root,root,755)
b445847c
JB
651%attr(755,root,root) %{_libdir}/libsvn_client-1.so
652%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
653%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
654%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
655%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
656%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
657%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
658%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
659%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
a510fada 660%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
b445847c
JB
661%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
662%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
663%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
664%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
665%{_libdir}/libsvn_client-1.la
666%{_libdir}/libsvn_delta-1.la
667%{_libdir}/libsvn_diff-1.la
668%{_libdir}/libsvn_fs-1.la
669%{_libdir}/libsvn_fs_base-1.la
670%{_libdir}/libsvn_fs_fs-1.la
671%{_libdir}/libsvn_fs_util-1.la
672%{_libdir}/libsvn_ra-1.la
673%{_libdir}/libsvn_ra_local-1.la
a510fada 674%{_libdir}/libsvn_ra_%{webdavlib}-1.la
b445847c
JB
675%{_libdir}/libsvn_ra_svn-1.la
676%{_libdir}/libsvn_repos-1.la
677%{_libdir}/libsvn_subr-1.la
678%{_libdir}/libsvn_wc-1.la
679%{_includedir}/%{name}-1
1326bb99 680%{_examplesdir}/%{name}-%{version}
93b78127
AM
681
682%files static
683%defattr(644,root,root,755)
b445847c
JB
684%{_libdir}/libsvn_client-1.a
685%{_libdir}/libsvn_delta-1.a
686%{_libdir}/libsvn_diff-1.a
687%{_libdir}/libsvn_fs-1.a
688%{_libdir}/libsvn_fs_base-1.a
689%{_libdir}/libsvn_fs_fs-1.a
690%{_libdir}/libsvn_fs_util-1.a
691%{_libdir}/libsvn_ra-1.a
692%{_libdir}/libsvn_ra_local-1.a
a510fada 693%{_libdir}/libsvn_ra_%{webdavlib}-1.a
b445847c
JB
694%{_libdir}/libsvn_ra_svn-1.a
695%{_libdir}/libsvn_repos-1.a
696%{_libdir}/libsvn_subr-1.a
697%{_libdir}/libsvn_wc-1.a
93b78127 698
1429fa1c
AM
699%files -n gnome-keyring-subversion
700%defattr(644,root,root,755)
701%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
702%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
703
65f2befa 704%if %{with kwallet}
1429fa1c
AM
705%files -n kde4-kwallet-subversion
706%defattr(644,root,root,755)
707%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
708%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
65f2befa 709%endif
1429fa1c 710
cf353d53 711%if !%{with net_client_only}
b56474ff
AM
712%files svnserve
713%defattr(644,root,root,755)
714%attr(755,root,root) %{_bindir}/svnserve
b445847c
JB
715%{_mandir}/man5/svnserve.conf.5*
716%{_mandir}/man8/svnserve.8*
a1bac09d
717%dir %attr(750,svn,svn) /home/services/subversion
718%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 719%if %{with apache}
b56474ff 720%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 721%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 722%endif
b56474ff 723
4bbdbbf8
AM
724%files tools
725%defattr(644,root,root,755)
1326bb99 726%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 727
728%files -n bash-completion-subversion
101e74de 729%defattr(644,root,root,755)
1326bb99 730/etc/bash_completion.d/%{name}
536b3fd3 731
1cc7453a 732%if %{with javahl}
733%files -n java-subversion
734%defattr(644,root,root,755)
b445847c
JB
735%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
736%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
737%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
1cc7453a 738%{_javadir}/svn-javahl.jar
739%endif
740
0905b458 741%if %{with python}
fa3ff1b2 742%files -n python-subversion
f4e6a380 743%defattr(644,root,root,755)
4bbdbbf8 744%doc tools/backup/*.py tools/examples/*.py
b445847c
JB
745%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
746%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
747%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
65318afa 748%dir %{py_sitedir}/libsvn
65318afa 749%{py_sitedir}/libsvn/*.py[co]
b445847c
JB
750%dir %{py_sitedir}/svn
751%{py_sitedir}/svn/*.py[co]
65318afa 752%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 753%{_examplesdir}/python-%{name}-%{version}
137fcafd
AM
754
755%files -n python-csvn
756%defattr(644,root,root,755)
757%doc subversion/bindings/ctypes-python/{README,TODO}
758%doc subversion/bindings/ctypes-python/examples/*.py
759%dir %{py_sitescriptdir}/csvn
760%{py_sitescriptdir}/csvn/*.py[co]
761%dir %{py_sitescriptdir}/csvn/core
762%{py_sitescriptdir}/csvn/core/*.py[co]
763%dir %{py_sitescriptdir}/csvn/ext
764%{py_sitescriptdir}/csvn/ext/*.py[co]
765%{py_sitescriptdir}/*.egg-info
0905b458 766%endif
f4e6a380 767
0905b458 768%if %{with perl}
b56474ff
AM
769%files -n perl-subversion
770%defattr(644,root,root,755)
b445847c
JB
771%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
772%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
773%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
b56474ff
AM
774%{perl_vendorarch}/SVN
775%dir %{perl_vendorarch}/auto/SVN
776%dir %{perl_vendorarch}/auto/SVN/*
777%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
778%{perl_vendorarch}/auto/SVN/*/*.bs
779%{_mandir}/man3/*.3pm*
0905b458 780%endif
b56474ff 781
d46e45ba
AM
782%if %{with ruby}
783%files -n ruby-subversion
784%defattr(644,root,root,755)
b445847c
JB
785%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
786%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
787%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
1429fa1c
AM
788%dir %{_libdir}/ruby/site_ruby/[0-9].[0-9]
789%dir %{_libdir}/ruby/site_ruby/*/svn
790%{_libdir}/ruby/site_ruby/*/svn/*.rb
791%dir %{_libdir}/ruby/site_ruby/*/*-*
3c31c4d9 792%dir %{_libdir}/ruby/site_ruby/*/*-*/svn
1429fa1c
AM
793%dir %{_libdir}/ruby/site_ruby/*/*-*/svn/ext
794%attr(755,root,root) %{_libdir}/ruby/site_ruby/*/*-*/svn/ext/*.so
ab6adef9 795%{_datadir}/ri/*.*/system/OptionParser
00664663 796%{_datadir}/ri/*.*/system/Svn
797%{_datadir}/ri/*.*/system/Time
798%{_datadir}/ri/*.*/system/Uconv
799%{_datadir}/ri/*.*/system/*.rid
800%{_datadir}/ri/*.*/system/Kernel/*
d46e45ba
AM
801%endif
802
0905b458 803%if %{with apache}
93b78127
AM
804%files -n apache-mod_dav_svn
805%defattr(644,root,root,755)
1af5e34d
ER
806%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
807%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
808
809%files -n apache-mod_authz_svn
810%defattr(644,root,root,755)
811%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
812%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
813%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 814%endif
7b27380f
ER
815
816%endif # net_client_only
This page took 0.170967 seconds and 4 git commands to generate.