]> git.pld-linux.org Git - packages/strigi.git/blame - strigi.spec
- release 4 (by relup.sh)
[packages/strigi.git] / strigi.spec
CommitLineData
1253c3bb 1#
6a7d7a23
ER
2# Conditional build:
3%bcond_without dbus # dbus support
4#
64e6c73a 5%define qtver 4.6.3
9897709b 6
493bcf16 7Summary: Strigi desktop search
abba28fc 8Summary(pl.UTF-8): System wyszukiwania Strigi
1253c3bb 9Name: strigi
cfce5085 10Version: 0.7.8
6a786e71 11Release: 4
4a9fce3d 12License: LGPL v2+
1253c3bb 13Group: X11/Applications
cfce5085
AM
14Source0: http://www.vandenoever.info/software/strigi/%{name}-%{version}.tar.bz2
15# Source0-md5: d69443234f4286d71997db9de543331a
acbb9c35 16Patch1: %{name}-as-needed.patch
1becfb15 17URL: http://strigi.sourceforge.net/
9897709b 18BuildRequires: QtDBus-devel >= %{qtver}
19BuildRequires: QtGui-devel >= %{qtver}
4a9fce3d 20BuildRequires: attr-devel
6a7d7a23 21BuildRequires: bzip2-devel
4a9fce3d
JB
22BuildRequires: clucene-core-devel >= 0.9.21
23BuildRequires: cmake >= 2.8.9
f331c639 24BuildRequires: cppunit-devel
6a7d7a23 25%{?with_dbus:BuildRequires: dbus-devel >= 1.0}
2027d9a2 26BuildRequires: exiv2-devel >= 0.21
6a7d7a23 27BuildRequires: expat-devel
9b415f88 28BuildRequires: fam-devel
44a8c079 29BuildRequires: ffmpeg-devel
4a9fce3d 30BuildRequires: libxml2-devel >= 2
b7b1af67 31BuildRequires: log4cxx-devel
9b415f88 32%{?with_dbus:BuildRequires: pkgconfig}
9897709b 33BuildRequires: qt4-build >= %{qtver}
34BuildRequires: qt4-qmake >= %{qtver}
4a9fce3d 35BuildRequires: rpmbuild(macros) >= 1.605
6a7d7a23 36BuildRequires: zlib-devel
1253c3bb 37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
abba28fc
JB
40Here are the main features of Strigi Desktop Search: very fast
41crawling, very small memory footprint, no hammering of the system,
42pluggable backend (currently clucene and hyperestraier, sqlite3 and
43xapian are in the works), communication between daemon and search
44program over an abstract interface with two implementations: DBus and
b25c5eb4 45a simple Unix socket. Especially the DBus interface makes it very easy
abba28fc
JB
46to write client applications. There are a few sample scripts in the
47code using Perl, Python, GTK+ and Qt. Writing clients is so easy that
48any GNOME or KDE app could implement this. Additionally, there is a
49simple interface for implementing plugins for extracting information.
50We'll try to reuse the kat plugins, although native plugins will have
51a large speed advantage. Strigi also has calculation of sha1 for every
52file crawled which allows for fast finding of duplicate files.
493bcf16 53
abba28fc
JB
54%description -l pl.UTF-8
55Główne cechy systemu wyszukiwania Strigi to: bardzo szybkie
56przeglądanie, bardzo mały narzut pamięciowy, nieprzytykanie systemu,
57backend z obsługą wtyczek (aktualnie clucene i hyperestraier, sqlite3
58i xapian w trakcie rozwoju), komunikacja między demonem a programem
59wyszukującym po abstrakcyjnym interfejsie z dwiema implementacjami:
60DBus i prostym gdzieździe uniksowym. Zwłaszcza interfejs DBus znacznie
61ułatwia pisanie aplikacji klienckich. Istnieje kilka przykładowych
62skryptów napisanych z użyciem Perla, Pythona, GTK+ i Qt. Tworzenie
63klientów jest tak proste, że każda aplikacja GNOME czy KDE może to
64zaimplementować. Ponadto istnieje prosty interfejs do implementowania
65wtyczek do wydobywania informacji. Autorzy będą próbowali
66wykorzystywać wtyczki kata, ale natywne wtyczki będą miały większą
67szybkość. Strigi ma także obliczanie sha1 dla każdego przeglądanego
68pliku, co pozwala na szybkie znajdowanie duplikatów.
1253c3bb 69
70%package devel
493bcf16 71Summary: Header files for strigi
72Summary(pl.UTF-8): Pliki nagłówkowe dla strigi
73Group: Development/Libraries
74Requires: %{name} = %{version}-%{release}
1253c3bb 75
76%description devel
77Header files for strigi.
78
79%description devel -l pl.UTF-8
80Pliki nagłówkowe dla strigi.
81
82%prep
83%setup -q
acbb9c35 84%patch1 -p1
1253c3bb 85
86%build
87install -d build
88cd build
4a9fce3d
JB
89# note: package expects relative CMAKE_INSTALL_LIBDIR
90%cmake .. \
cfce5085 91 -DCMAKE_INSTALL_LIBDIR=%{_lib} \
130bea1a 92 -DFORCE_DEPS=1 \
b7b1af67 93 -DENABLE_FAM=1 \
4a9fce3d
JB
94 -DENABLE_INOTIFY=1 \
95 -DENABLE_LOG4CXX=1
1253c3bb 96
97%{__make}
98
99%install
100rm -rf $RPM_BUILD_ROOT
abba28fc
JB
101
102%{__make} -C build install \
1253c3bb 103 DESTDIR=$RPM_BUILD_ROOT
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post -p /sbin/ldconfig
109%postun -p /sbin/ldconfig
110
111%files
112%defattr(644,root,root,755)
4a9fce3d
JB
113%doc AUTHORS ChangeLog
114%attr(755,root,root) %{_bindir}/deepfind
115%attr(755,root,root) %{_bindir}/deepgrep
116%attr(755,root,root) %{_bindir}/lucene2indexer
117%attr(755,root,root) %{_bindir}/rdfindexer
118%attr(755,root,root) %{_bindir}/strigiclient
119%attr(755,root,root) %{_bindir}/strigicmd
120%attr(755,root,root) %{_bindir}/strigidaemon
121%attr(755,root,root) %{_bindir}/xmlindexer
3b877464 122%attr(755,root,root) %{_libdir}/libsearchclient.so.*.*.*
f29c8e58 123%attr(755,root,root) %ghost %{_libdir}/libsearchclient.so.0
4a9fce3d 124%attr(755,root,root) %{_libdir}/libstreamanalyzer.so.*.*.*
a52c8172 125%attr(755,root,root) %ghost %{_libdir}/libstreamanalyzer.so.0
4a9fce3d 126%attr(755,root,root) %{_libdir}/libstreams.so.*.*.*
a52c8172 127%attr(755,root,root) %ghost %{_libdir}/libstreams.so.0
4a9fce3d 128%attr(755,root,root) %{_libdir}/libstrigihtmlgui.so.*.*.*
f29c8e58 129%attr(755,root,root) %ghost %{_libdir}/libstrigihtmlgui.so.0
4a9fce3d 130%attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so.*.*.*
f29c8e58
JB
131%attr(755,root,root) %ghost %{_libdir}/libstrigiqtdbusclient.so.0
132%dir %{_libdir}/strigi
133%attr(755,root,root) %{_libdir}/strigi/*.so
4a9fce3d
JB
134%{?with_dbus:%{_datadir}/dbus-1/services/org.freedesktop.xesam.searcher.service}
135%{?with_dbus:%{_datadir}/dbus-1/services/vandenoever.strigi.service}
a52c8172
JB
136%dir %{_datadir}/strigi
137%{_datadir}/strigi/fieldproperties
1253c3bb 138
139%files devel
140%defattr(644,root,root,755)
3b877464 141%attr(755,root,root) %{_libdir}/libsearchclient.so
a52c8172
JB
142%attr(755,root,root) %{_libdir}/libstreamanalyzer.so
143%attr(755,root,root) %{_libdir}/libstreams.so
3b877464
RT
144%attr(755,root,root) %{_libdir}/libstrigihtmlgui.so
145%attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so
31d6d646 146%dir %{_libdir}/cmake/Strigi
cfce5085
AM
147%{_libdir}/cmake/Strigi/*.cmake
148%dir %{_libdir}/cmake/LibSearchClient
149%{_libdir}/cmake/LibSearchClient/LibSearchClientConfig.cmake
150%dir %{_libdir}/cmake/LibStreamAnalyzer
151%{_libdir}/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfig.cmake
152%{_libdir}/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfigVersion.cmake
153%dir %{_libdir}/cmake/LibStreams
154%{_libdir}/cmake/LibStreams/LibStreamsConfig.cmake
155%{_libdir}/cmake/LibStreams/LibStreamsConfigVersion.cmake
156%{_libdir}/cmake/LibStreams/LibStreamsTargets-pld.cmake
157%{_libdir}/cmake/LibStreams/LibStreamsTargets.cmake
1253c3bb 158%dir %{_includedir}/strigi
159%{_includedir}/strigi/*.h
3b877464 160%{_includedir}/strigi/qtdbus
a52c8172
JB
161%{_pkgconfigdir}/libstreamanalyzer.pc
162%{_pkgconfigdir}/libstreams.pc
This page took 0.079682 seconds and 4 git commands to generate.