]> git.pld-linux.org Git - packages/stoken.git/blame - stoken.spec
- updated to 0.92
[packages/stoken.git] / stoken.spec
CommitLineData
6d48841e
JB
1#
2# Conditional build:
3%bcond_without gtk # GTK+ 3 based GUI
4%bcond_without java # JNI bindings
5#
c93370dd
JB
6Summary: Software Token for Linux/UNIX
7Summary(pl.UTF-8): Token programowy dla systemów Linux/UNIX
8Name: stoken
3ff208fb 9Version: 0.92
6d48841e 10Release: 1
c93370dd
JB
11License: LGPL v2.1+
12Group: Libraries
13Source0: http://downloads.sourceforge.net/stoken/%{name}-%{version}.tar.gz
3ff208fb 14# Source0-md5: 2b6d30cf0dfd7311794a54376c958cbc
6d48841e 15Patch0: %{name}-sh.patch
c93370dd 16URL: http://stoken.sourceforge.net/
6d48841e
JB
17%{?with_java:BuildRequires: ant}
18BuildRequires: autoconf >= 2.61
19BuildRequires: automake >= 1:1.11
20%{?with_gtk:BuildRequires: gtk+3-devel >= 3.0}
21%{?with_java:BuildRequires: jdk}
3ff208fb 22BuildRequires: libtomcrypt-devel >= 1.18
6d48841e
JB
23BuildRequires: libtool >= 2:2
24BuildRequires: libxml2-devel >= 2
c93370dd
JB
25BuildRequires: pkgconfig >= 1:0.27
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29stoken is a tokencode generator compatible with RSA SecurID 128-bit
30(AES) tokens. It is a hobbyist project, not affiliated with or
31endorsed by RSA Security.
32
33%description -l pl.UTF-8
34stoken to generator kodów tokenów zgodnych z tokenami 128-bitowymi RSA
35SecurID (AES). Jest to projekt hobbistyczny, nie powiązany, ani nie
36gwarantowany przez RSA Security.
37
38%package gui
39Summary: Software Token GUI
40Summary(pl.UTF-8): Graficzny interfejs użytkownika do tokenów programowych
41Group: X11/Applications
42Requires: %{name} = %{version}-%{release}
43
44%description gui
45Software Token GUI.
46
47%description gui -l pl.UTF-8
48Graficzny interfejs użytkownika do tokenów programowych.
49
50%package devel
51Summary: Header files for stoken library
52Summary(pl.UTF-8): Pliki nagłówkowe biblioteki stoken
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
3ff208fb 55Requires: libtomcrypt-devel >= 1.18
c93370dd
JB
56
57%description devel
58Header files for stoken library.
59
60%description devel -l pl.UTF-8
61Pliki nagłówkowe biblioteki stoken.
62
63%package static
64Summary: Static stoken library
65Summary(pl.UTF-8): Statyczna biblioteka stoken
66Group: Development/Libraries
67Requires: %{name}-devel = %{version}-%{release}
68
69%description static
70Static stoken library.
71
72%description static -l pl.UTF-8
73Statyczna biblioteka stoken.
74
6d48841e
JB
75%package -n java-stoken
76Summary: JNI interface for stoken library
77Summary(pl.UTF-8): Interfejs JNI do biblioteki stoken
78License: BSD
79Group: Libraries/Java
80Requires: %{name} = %{version}-%{release}
81
82%description -n java-stoken
83JNI interface for stoken library.
84
85%description -n java-stoken -l pl.UTF-8
86Interfejs JNI do biblioteki stoken.
87
c93370dd
JB
88%prep
89%setup -q
6d48841e 90%patch0 -p1
c93370dd
JB
91
92%build
6d48841e
JB
93%{__libtoolize}
94%{__aclocal} -I m4
95%{__autoconf}
96%{__autoheader}
97%{__automake}
98%configure \
99 --disable-silent-rules \
100 %{!?with_gtk:--without-gtk} \
101 %{?with_java:--with-java}
c93370dd
JB
102
103%{__make}
104
6d48841e
JB
105%if %{with java}
106cd java
107install -d dist
108%ant
109%endif
110
c93370dd
JB
111%install
112rm -rf $RPM_BUILD_ROOT
113
114%{__make} install \
115 DESTDIR=$RPM_BUILD_ROOT
116
117# obsoleted by pkg-config
118%{__rm} $RPM_BUILD_ROOT%{_libdir}/libstoken.la
119
6d48841e
JB
120%if %{with java}
121%{__rm} $RPM_BUILD_ROOT%{_libdir}/libstoken-wrapper.{la,a}
122install -D java/dist/stoken-wrapper.jar $RPM_BUILD_ROOT%{_javadir}/stoken-wrapper.jar
123%endif
124
c93370dd
JB
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post -p /sbin/ldconfig
129%postun -p /sbin/ldconfig
130
6d48841e
JB
131%post -n java-stoken -p /sbin/ldconfig
132%postun -n java-stoken -p /sbin/ldconfig
133
c93370dd
JB
134%files
135%defattr(644,root,root,755)
6d48841e 136%doc CHANGES README.md TODO
c93370dd
JB
137%attr(755,root,root) %{_bindir}/stoken
138%attr(755,root,root) %{_libdir}/libstoken.so.*.*.*
139%attr(755,root,root) %ghost %{_libdir}/libstoken.so.1
140%{_mandir}/man1/stoken.1*
141
6d48841e 142%if %{with gtk}
c93370dd
JB
143%files gui
144%defattr(644,root,root,755)
145%attr(755,root,root) %{_bindir}/stoken-gui
6d48841e 146%{_datadir}/stoken
c93370dd 147%{_desktopdir}/stoken-gui.desktop
6d48841e 148%{_desktopdir}/stoken-gui-small.desktop
c93370dd
JB
149%{_pixmapsdir}/stoken-gui.png
150%{_mandir}/man1/stoken-gui.1*
6d48841e 151%endif
c93370dd
JB
152
153%files devel
154%defattr(644,root,root,755)
155%attr(755,root,root) %{_libdir}/libstoken.so
156%{_includedir}/stoken.h
157%{_pkgconfigdir}/stoken.pc
158
159%files static
160%defattr(644,root,root,755)
161%{_libdir}/libstoken.a
6d48841e
JB
162
163%if %{with java}
164%files -n java-stoken
165%defattr(644,root,root,755)
166%doc java/src/com/example/LibTest.java
167%attr(755,root,root) %{_libdir}/libstoken-wrapper.so.*.*.*
168%attr(755,root,root) %ghost %{_libdir}/libstoken-wrapper.so.0
169%attr(755,root,root) %{_libdir}/libstoken-wrapper.so
170%{_javadir}/stoken-wrapper.jar
171%endif
This page took 0.086731 seconds and 4 git commands to generate.