]> git.pld-linux.org Git - packages/sqlite3.git/blame - sqlite3.spec
- up to 3.6.10
[packages/sqlite3.git] / sqlite3.spec
CommitLineData
c743401f 1# TODO:
f1015391
JR
2# - some tests fail with tcl8.5, it's tcl fault,
3# if someone REALLY cares (s)he can look into it
65cfa56f
ER
4# - alpha build fail:
5# tclsh ./tool/mksqlite3c.tcl
6# tclsh: allocatestack.c:404: allocate_stack: Assertion `size != 0' failed.
7# make: *** [sqlite3.c] Aborted
17b8c9f1 8#
9# Conditional build:
f1015391
JR
10%bcond_with tests # run tests
11%bcond_without tcl # disable tcl extension
12%bcond_without doc # disable documentation building
17b8c9f1 13#
f1015391
JR
14%ifarch alpha sparc %{x8664}
15%undefine with_tests
16%endif
17
18# disabling tcl currently breaks making test target,
19# some hack in Makefile needs to be done
20%if !%{with tcl}
21%undefine with_tests
22%endif
23
65cfa56f 24%define _ulibdir /usr/lib
539069d8 25%define tclver 8.5
f1015391 26
17b8c9f1 27Summary: SQLite library
e882a99f 28Summary(pl.UTF-8): Biblioteka SQLite
22ef5ab8 29Name: sqlite3
dbff3c9b 30Version: 3.6.10
64a2b8e8 31Release: 1
17b8c9f1 32License: LGPL
33Group: Libraries
65cfa56f
ER
34# Source0Download: http://www.sqlite.org/download.html
35Source0: http://www.sqlite.org/sqlite-%{version}.tar.gz
dbff3c9b 36# Source0-md5: a03bdc86df4025b6881d58557e4b5bd3
a3d8a32d 37Patch0: %{name}-sign-function.patch
65cfa56f 38URL: http://www.sqlite.org/
17b8c9f1 39BuildRequires: autoconf
40BuildRequires: automake
41BuildRequires: libtool
42BuildRequires: readline-devel
1a6aae8d 43%{?with_tcl:BuildRequires: tcl-devel}
17b8c9f1 44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47SQLite is a C library that implements an SQL database engine. A large
48subset of SQL92 is supported. A complete database is stored in a
49single disk file. The API is designed for convenience and ease of use.
50Applications that link against SQLite can enjoy the power and
51flexiblity of an SQL database without the administrative hassles of
52supporting a separate database server. Because it omits the
53client-server interaction overhead and writes directly to disk, SQLite
54is also faster than the big database servers for most operations. In
55addition to the C library, the SQLite distribution includes a
56command-line tool for interacting with SQLite databases and SQLite
57bindings for Tcl/Tk.
58
b7c0e1f2
JR
59%description -l pl.UTF-8
60SQLite jest biblioteką języka C, która implementuje silnik baz danych
61SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
62przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
63bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
64danych bez konieczności utrzymywania osobnego serwera baz danych.
65Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
66bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
67bazodanowych przy większości operacji na bazie danych. Dodatkowo
68oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 69bazami danych.
70
71%package devel
72Summary: Header files for SQLite development
e882a99f 73Summary(pl.UTF-8): Pliki nagłówkowe SQLite
17b8c9f1 74Group: Development/Libraries
75Requires: %{name} = %{version}-%{release}
76
77%description devel
78SQLite is a C library that implements an SQL database engine. A large
79subset of SQL92 is supported. A complete database is stored in a
80single disk file. The API is designed for convenience and ease of use.
81Applications that link against SQLite can enjoy the power and
82flexiblity of an SQL database without the administrative hassles of
83supporting a separate database server. Because it omits the
84client-server interaction overhead and writes directly to disk, SQLite
85is also faster than the big database servers for most operations. In
86addition to the C library, the SQLite distribution includes a
87command-line tool for interacting with SQLite databases and SQLite
88bindings for Tcl/Tk.
89
90This package contains the header files needed to develop programs that
91use these SQLite.
92
b7c0e1f2
JR
93%description devel -l pl.UTF-8
94SQLite jest biblioteką języka C, która implementuje silnik baz danych
95SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
96przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
97bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
98danych bez konieczności utrzymywania osobnego serwera baz danych.
99Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
100bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
101bazodanowych przy większości operacji na bazie danych. Dodatkowo
102oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 103bazami danych.
104
b7c0e1f2
JR
105Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
106używających biblioteki SQLite.
17b8c9f1 107
108%package static
109Summary: Static libraries for SQLite development
e882a99f 110Summary(pl.UTF-8): Statyczne biblioteki SQLite
17b8c9f1 111Group: Development/Libraries
112Requires: %{name}-devel = %{version}-%{release}
113
114%description static
115SQLite is a C library that implements an SQL database engine. A large
116subset of SQL92 is supported. A complete database is stored in a
117single disk file. The API is designed for convenience and ease of use.
118Applications that link against SQLite can enjoy the power and
119flexiblity of an SQL database without the administrative hassles of
120supporting a separate database server. Because it omits the
121client-server interaction overhead and writes directly to disk, SQLite
122is also faster than the big database servers for most operations. In
123addition to the C library, the SQLite distribution includes a
124command-line tool for interacting with SQLite databases and SQLite
125bindings for Tcl/Tk.
126
127This package contains the static SQLite libraries.
128
b7c0e1f2
JR
129%description static -l pl.UTF-8
130SQLite jest biblioteką języka C, która implementuje silnik baz danych
131SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
132przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
133bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
134danych bez konieczności utrzymywania osobnego serwera baz danych.
135Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
136bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
137bazodanowych przy większości operacji na bazie danych. Dodatkowo
138oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 139bazami danych.
140
141Pakiet zawiera statyczne biblioteki SQLite.
142
c743401f 143%package -n tcl-%{name}
8e66772b 144Summary: sqlite3 tcl extension
e882a99f 145Summary(pl.UTF-8): Rozszerzenie sqlite3 dla Tcl
8e66772b 146Group: Development/Languages/Tcl
c743401f
AM
147
148%description -n tcl-%{name}
149sqlite3 tcl extension.
150
b7c0e1f2 151%description -n tcl-%{name} -l pl.UTF-8
c743401f
AM
152Rozszerzenie sqlite3 dla Tcl.
153
17b8c9f1 154%prep
c743401f 155%setup -q -n sqlite-%{version}
30682d5a 156%patch0 -p1
1cd2f537 157
faed6cf7
ER
158%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
159
160%ifarch alpha
161# See also LP#276821
162# wrapper script to reset stack to 8192 as if ran from make it's insanely huge!:
163# stack(kbytes) 18014398509481983
164cat <<'EOF' > tclsh.sh
165#!/bin/sh
166ulimit -s 8192
167exec tclsh "$@"
168EOF
169chmod +x tclsh.sh
170%endif
17b8c9f1 171
172%build
173%{__libtoolize}
174cp -f /usr/share/automake/config.sub .
175%{__aclocal}
176%{__autoconf}
f1015391
JR
177CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1"
178export CFLAGS
17b8c9f1 179%configure \
1a6aae8d 180 %{?with_tcl:--with-tcl=%{_ulibdir}} \
181 %{!?with_tcl:--disable-tcl} \
17b8c9f1 182 --enable-threadsafe
faed6cf7
ER
183%{__make} \
184%ifarch alpha
185 TCLSH_CMD=./tclsh.sh
186%endif
1a6aae8d 187
e16bc4b1 188%if %{with doc}
17b8c9f1 189%{__make} doc
1a6aae8d 190%endif
17b8c9f1 191
3e5df83c 192%{?with_tests:LC_ALL=C %{__make} test}
17b8c9f1 193
194%install
195rm -rf $RPM_BUILD_ROOT
196install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
197
198%{__make} install \
faed6cf7
ER
199%ifarch alpha
200 TCLSH_CMD=./tclsh.sh \
201%endif
80deaf18
JR
202 DESTDIR=$RPM_BUILD_ROOT \
203 TCLLIBDIR=%{_libdir}/tcl%{tclver}
17b8c9f1 204
22de4c1c 205%if %{with tcl}
7e92c022 206sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
22de4c1c 207%endif
ec30f86a 208
c743401f 209install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
17b8c9f1 210
211%clean
212rm -rf $RPM_BUILD_ROOT
213
214%post -p /sbin/ldconfig
215%postun -p /sbin/ldconfig
216
217%files
218%defattr(644,root,root,755)
219%doc README
220%attr(755,root,root) %{_bindir}/sqlite3
7e92c022
JB
221%attr(755,root,root) %{_libdir}/libsqlite3.so.*.*.*
222%attr(755,root,root) %ghost %{_libdir}/libsqlite3.so.0
c743401f 223%{_mandir}/man1/sqlite3.1*
17b8c9f1 224
225%files devel
226%defattr(644,root,root,755)
7e92c022
JB
227%attr(755,root,root) %{_libdir}/libsqlite3.so
228%{_libdir}/libsqlite3.la
17b8c9f1 229%{_includedir}/sqlite3.h
ef88c71c 230%{_includedir}/sqlite3ext.h
7e92c022 231%{_pkgconfigdir}/sqlite3.pc
17b8c9f1 232
233%files static
234%defattr(644,root,root,755)
7e92c022 235%{_libdir}/libsqlite3.a
c743401f 236
1a6aae8d 237%if %{with tcl}
c743401f
AM
238%files -n tcl-%{name}
239%defattr(644,root,root,755)
80deaf18 240%dir %{_libdir}/tcl*/sqlite3
7e92c022
JB
241%attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
242%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
1a6aae8d 243%endif
This page took 0.062087 seconds and 4 git commands to generate.