]> git.pld-linux.org Git - packages/sqlite3.git/blame - sqlite3.spec
- install tcl module in proper libdir
[packages/sqlite3.git] / sqlite3.spec
CommitLineData
c743401f
AM
1# TODO:
2# - fix lib64 in tcl module
7c673bd5
JB
3# - date test fail on tcl8.5 because of missing tcl library initialization
4# (and thus unavailable clock command)
17b8c9f1 5#
6# Conditional build:
7%bcond_without tests # don't run tests
1a6aae8d 8%bcond_without tcl # disable tcl extension
e16bc4b1 9%bcond_without doc # disable documentation building
17b8c9f1 10#
11Summary: SQLite library
e882a99f 12Summary(pl.UTF-8): Biblioteka SQLite
22ef5ab8 13Name: sqlite3
7d6abcd6 14Version: 3.5.0
114e3074 15Release: 1
17b8c9f1 16License: LGPL
17Group: Libraries
18# Source0Download: http://sqlite.org/download.html
e56bde73 19Source0: http://sqlite.org/sqlite-%{version}.tar.gz
7d6abcd6 20# Source0-md5: 7ff857e572d85b8fa865c7d36886a67b
a3d8a32d 21Patch0: %{name}-sign-function.patch
1cd2f537 22Patch1: %{name}-pkgconfig.patch
17b8c9f1 23URL: http://sqlite.org/
24BuildRequires: autoconf
25BuildRequires: automake
26BuildRequires: libtool
27BuildRequires: readline-devel
1a6aae8d 28%{?with_tcl:BuildRequires: tcl-devel}
17b8c9f1 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
10c96aa0 31%ifarch alpha sparc %{x8664}
0a0f5bcf
AM
32%undefine with_tests
33%endif
34
c4d7d942
35# disabling tcl currently breaks making test target,
36# some hack in Makefile needs to be done
b197e0ac 37%if !%{with tcl}
c4d7d942
38%undefine with_tests
39%endif
40
c743401f 41%define _ulibdir /usr/lib
80deaf18 42%define tclver %(rpm -q --qf '%{V}' tcl)
c743401f 43
17b8c9f1 44%description
45SQLite is a C library that implements an SQL database engine. A large
46subset of SQL92 is supported. A complete database is stored in a
47single disk file. The API is designed for convenience and ease of use.
48Applications that link against SQLite can enjoy the power and
49flexiblity of an SQL database without the administrative hassles of
50supporting a separate database server. Because it omits the
51client-server interaction overhead and writes directly to disk, SQLite
52is also faster than the big database servers for most operations. In
53addition to the C library, the SQLite distribution includes a
54command-line tool for interacting with SQLite databases and SQLite
55bindings for Tcl/Tk.
56
b7c0e1f2
JR
57%description -l pl.UTF-8
58SQLite jest biblioteką języka C, która implementuje silnik baz danych
59SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
60przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
61bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
62danych bez konieczności utrzymywania osobnego serwera baz danych.
63Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
64bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
65bazodanowych przy większości operacji na bazie danych. Dodatkowo
66oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 67bazami danych.
68
69%package devel
70Summary: Header files for SQLite development
e882a99f 71Summary(pl.UTF-8): Pliki nagłówkowe SQLite
17b8c9f1 72Group: Development/Libraries
73Requires: %{name} = %{version}-%{release}
74
75%description devel
76SQLite is a C library that implements an SQL database engine. A large
77subset of SQL92 is supported. A complete database is stored in a
78single disk file. The API is designed for convenience and ease of use.
79Applications that link against SQLite can enjoy the power and
80flexiblity of an SQL database without the administrative hassles of
81supporting a separate database server. Because it omits the
82client-server interaction overhead and writes directly to disk, SQLite
83is also faster than the big database servers for most operations. In
84addition to the C library, the SQLite distribution includes a
85command-line tool for interacting with SQLite databases and SQLite
86bindings for Tcl/Tk.
87
88This package contains the header files needed to develop programs that
89use these SQLite.
90
b7c0e1f2
JR
91%description devel -l pl.UTF-8
92SQLite jest biblioteką języka C, która implementuje silnik baz danych
93SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
94przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
95bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
96danych bez konieczności utrzymywania osobnego serwera baz danych.
97Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
98bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
99bazodanowych przy większości operacji na bazie danych. Dodatkowo
100oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 101bazami danych.
102
b7c0e1f2
JR
103Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
104używających biblioteki SQLite.
17b8c9f1 105
106%package static
107Summary: Static libraries for SQLite development
e882a99f 108Summary(pl.UTF-8): Statyczne biblioteki SQLite
17b8c9f1 109Group: Development/Libraries
110Requires: %{name}-devel = %{version}-%{release}
111
112%description static
113SQLite is a C library that implements an SQL database engine. A large
114subset of SQL92 is supported. A complete database is stored in a
115single disk file. The API is designed for convenience and ease of use.
116Applications that link against SQLite can enjoy the power and
117flexiblity of an SQL database without the administrative hassles of
118supporting a separate database server. Because it omits the
119client-server interaction overhead and writes directly to disk, SQLite
120is also faster than the big database servers for most operations. In
121addition to the C library, the SQLite distribution includes a
122command-line tool for interacting with SQLite databases and SQLite
123bindings for Tcl/Tk.
124
125This package contains the static SQLite libraries.
126
b7c0e1f2
JR
127%description static -l pl.UTF-8
128SQLite jest biblioteką języka C, która implementuje silnik baz danych
129SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
130przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
131bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
132danych bez konieczności utrzymywania osobnego serwera baz danych.
133Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
134bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
135bazodanowych przy większości operacji na bazie danych. Dodatkowo
136oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 137bazami danych.
138
139Pakiet zawiera statyczne biblioteki SQLite.
140
c743401f 141%package -n tcl-%{name}
8e66772b 142Summary: sqlite3 tcl extension
e882a99f 143Summary(pl.UTF-8): Rozszerzenie sqlite3 dla Tcl
8e66772b 144Group: Development/Languages/Tcl
c743401f
AM
145
146%description -n tcl-%{name}
147sqlite3 tcl extension.
148
b7c0e1f2 149%description -n tcl-%{name} -l pl.UTF-8
c743401f
AM
150Rozszerzenie sqlite3 dla Tcl.
151
17b8c9f1 152%prep
c743401f 153%setup -q -n sqlite-%{version}
30682d5a 154%patch0 -p1
1cd2f537 155%patch1 -p1
156
17b8c9f1 157sed -i 's/mkdir doc/#mkdir doc/' Makefile*
158
159%build
160%{__libtoolize}
161cp -f /usr/share/automake/config.sub .
162%{__aclocal}
163%{__autoconf}
164%configure \
1a6aae8d 165 %{?with_tcl:--with-tcl=%{_ulibdir}} \
166 %{!?with_tcl:--disable-tcl} \
17b8c9f1 167 --enable-threadsafe
168%{__make}
1a6aae8d 169
e16bc4b1 170%if %{with doc}
17b8c9f1 171%{__make} doc
1a6aae8d 172%endif
17b8c9f1 173
3e5df83c 174%{?with_tests:LC_ALL=C %{__make} test}
17b8c9f1 175
176%install
177rm -rf $RPM_BUILD_ROOT
178install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
179
180%{__make} install \
80deaf18
JR
181 DESTDIR=$RPM_BUILD_ROOT \
182 TCLLIBDIR=%{_libdir}/tcl%{tclver}
17b8c9f1 183
22de4c1c 184%if %{with tcl}
80deaf18 185sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl*/sqlite3/*.tcl
22de4c1c 186%endif
ec30f86a 187
c743401f 188install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
17b8c9f1 189
190%clean
191rm -rf $RPM_BUILD_ROOT
192
193%post -p /sbin/ldconfig
194%postun -p /sbin/ldconfig
195
196%files
197%defattr(644,root,root,755)
198%doc README
199%attr(755,root,root) %{_bindir}/sqlite3
200%attr(755,root,root) %{_libdir}/lib*.so.*.*
c743401f 201%{_mandir}/man1/sqlite3.1*
17b8c9f1 202
203%files devel
204%defattr(644,root,root,755)
205%doc doc/*
206%attr(755,root,root) %{_libdir}/lib*.so
207%{_libdir}/lib*.la
208%{_includedir}/sqlite3.h
ef88c71c 209%{_includedir}/sqlite3ext.h
17b8c9f1 210%{_pkgconfigdir}/*.pc
211
212%files static
213%defattr(644,root,root,755)
214%{_libdir}/lib*.a
c743401f 215
1a6aae8d 216%if %{with tcl}
c743401f
AM
217%files -n tcl-%{name}
218%defattr(644,root,root,755)
80deaf18
JR
219%dir %{_libdir}/tcl*/sqlite3
220%attr(755,root,root) %{_libdir}/tcl*/sqlite3/*.so
221%{_libdir}/tcl*/sqlite3/*.tcl
1a6aae8d 222%endif
This page took 0.415024 seconds and 4 git commands to generate.