]> git.pld-linux.org Git - packages/sqlite3.git/blame - sqlite3.spec
- updated to 3.4.2
[packages/sqlite3.git] / sqlite3.spec
CommitLineData
c743401f
AM
1# TODO:
2# - fix lib64 in tcl module
7c673bd5
JB
3# - date test fail on tcl8.5 because of missing tcl library initialization
4# (and thus unavailable clock command)
17b8c9f1 5#
6# Conditional build:
7%bcond_without tests # don't run tests
1a6aae8d 8%bcond_without tcl # disable tcl extension
e16bc4b1 9%bcond_without doc # disable documentation building
17b8c9f1 10#
11Summary: SQLite library
e882a99f 12Summary(pl.UTF-8): Biblioteka SQLite
22ef5ab8 13Name: sqlite3
22de4c1c 14Version: 3.4.2
114e3074 15Release: 1
17b8c9f1 16License: LGPL
17Group: Libraries
18# Source0Download: http://sqlite.org/download.html
e56bde73 19Source0: http://sqlite.org/sqlite-%{version}.tar.gz
22de4c1c 20# Source0-md5: 2feec9b429f9298c9f288420c8b449f8
a3d8a32d 21Patch0: %{name}-sign-function.patch
1cd2f537 22Patch1: %{name}-pkgconfig.patch
17b8c9f1 23URL: http://sqlite.org/
24BuildRequires: autoconf
25BuildRequires: automake
26BuildRequires: libtool
27BuildRequires: readline-devel
1a6aae8d 28%{?with_tcl:BuildRequires: tcl-devel}
17b8c9f1 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
10c96aa0 31%ifarch alpha sparc %{x8664}
0a0f5bcf
AM
32%undefine with_tests
33%endif
34
c4d7d942
35# disabling tcl currently breaks making test target,
36# some hack in Makefile needs to be done
b197e0ac 37%if !%{with tcl}
c4d7d942
38%undefine with_tests
39%endif
40
c743401f
AM
41%define _ulibdir /usr/lib
42
17b8c9f1 43%description
44SQLite is a C library that implements an SQL database engine. A large
45subset of SQL92 is supported. A complete database is stored in a
46single disk file. The API is designed for convenience and ease of use.
47Applications that link against SQLite can enjoy the power and
48flexiblity of an SQL database without the administrative hassles of
49supporting a separate database server. Because it omits the
50client-server interaction overhead and writes directly to disk, SQLite
51is also faster than the big database servers for most operations. In
52addition to the C library, the SQLite distribution includes a
53command-line tool for interacting with SQLite databases and SQLite
54bindings for Tcl/Tk.
55
b7c0e1f2
JR
56%description -l pl.UTF-8
57SQLite jest biblioteką języka C, która implementuje silnik baz danych
58SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
59przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
60bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
61danych bez konieczności utrzymywania osobnego serwera baz danych.
62Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
63bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
64bazodanowych przy większości operacji na bazie danych. Dodatkowo
65oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 66bazami danych.
67
68%package devel
69Summary: Header files for SQLite development
e882a99f 70Summary(pl.UTF-8): Pliki nagłówkowe SQLite
17b8c9f1 71Group: Development/Libraries
72Requires: %{name} = %{version}-%{release}
73
74%description devel
75SQLite is a C library that implements an SQL database engine. A large
76subset of SQL92 is supported. A complete database is stored in a
77single disk file. The API is designed for convenience and ease of use.
78Applications that link against SQLite can enjoy the power and
79flexiblity of an SQL database without the administrative hassles of
80supporting a separate database server. Because it omits the
81client-server interaction overhead and writes directly to disk, SQLite
82is also faster than the big database servers for most operations. In
83addition to the C library, the SQLite distribution includes a
84command-line tool for interacting with SQLite databases and SQLite
85bindings for Tcl/Tk.
86
87This package contains the header files needed to develop programs that
88use these SQLite.
89
b7c0e1f2
JR
90%description devel -l pl.UTF-8
91SQLite jest biblioteką języka C, która implementuje silnik baz danych
92SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
93przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
94bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
95danych bez konieczności utrzymywania osobnego serwera baz danych.
96Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
97bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
98bazodanowych przy większości operacji na bazie danych. Dodatkowo
99oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 100bazami danych.
101
b7c0e1f2
JR
102Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
103używających biblioteki SQLite.
17b8c9f1 104
105%package static
106Summary: Static libraries for SQLite development
e882a99f 107Summary(pl.UTF-8): Statyczne biblioteki SQLite
17b8c9f1 108Group: Development/Libraries
109Requires: %{name}-devel = %{version}-%{release}
110
111%description static
112SQLite is a C library that implements an SQL database engine. A large
113subset of SQL92 is supported. A complete database is stored in a
114single disk file. The API is designed for convenience and ease of use.
115Applications that link against SQLite can enjoy the power and
116flexiblity of an SQL database without the administrative hassles of
117supporting a separate database server. Because it omits the
118client-server interaction overhead and writes directly to disk, SQLite
119is also faster than the big database servers for most operations. In
120addition to the C library, the SQLite distribution includes a
121command-line tool for interacting with SQLite databases and SQLite
122bindings for Tcl/Tk.
123
124This package contains the static SQLite libraries.
125
b7c0e1f2
JR
126%description static -l pl.UTF-8
127SQLite jest biblioteką języka C, która implementuje silnik baz danych
128SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
129przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
130bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
131danych bez konieczności utrzymywania osobnego serwera baz danych.
132Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
133bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
134bazodanowych przy większości operacji na bazie danych. Dodatkowo
135oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 136bazami danych.
137
138Pakiet zawiera statyczne biblioteki SQLite.
139
c743401f 140%package -n tcl-%{name}
8e66772b 141Summary: sqlite3 tcl extension
e882a99f 142Summary(pl.UTF-8): Rozszerzenie sqlite3 dla Tcl
8e66772b 143Group: Development/Languages/Tcl
c743401f
AM
144
145%description -n tcl-%{name}
146sqlite3 tcl extension.
147
b7c0e1f2 148%description -n tcl-%{name} -l pl.UTF-8
c743401f
AM
149Rozszerzenie sqlite3 dla Tcl.
150
17b8c9f1 151%prep
c743401f 152%setup -q -n sqlite-%{version}
30682d5a 153%patch0 -p1
1cd2f537 154%patch1 -p1
155
17b8c9f1 156sed -i 's/mkdir doc/#mkdir doc/' Makefile*
157
158%build
159%{__libtoolize}
160cp -f /usr/share/automake/config.sub .
161%{__aclocal}
162%{__autoconf}
163%configure \
1a6aae8d 164 %{?with_tcl:--with-tcl=%{_ulibdir}} \
165 %{!?with_tcl:--disable-tcl} \
17b8c9f1 166 --enable-threadsafe
167%{__make}
1a6aae8d 168
e16bc4b1 169%if %{with doc}
17b8c9f1 170%{__make} doc
1a6aae8d 171%endif
17b8c9f1 172
3e5df83c 173%{?with_tests:LC_ALL=C %{__make} test}
17b8c9f1 174
175%install
176rm -rf $RPM_BUILD_ROOT
177install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
178
179%{__make} install \
180 DESTDIR=$RPM_BUILD_ROOT
181
22de4c1c 182%if %{with tcl}
ec30f86a 183sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_ulibdir}/tcl*/sqlite3/*.tcl
22de4c1c 184%endif
ec30f86a 185
c743401f 186install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
17b8c9f1 187
188%clean
189rm -rf $RPM_BUILD_ROOT
190
191%post -p /sbin/ldconfig
192%postun -p /sbin/ldconfig
193
194%files
195%defattr(644,root,root,755)
196%doc README
197%attr(755,root,root) %{_bindir}/sqlite3
198%attr(755,root,root) %{_libdir}/lib*.so.*.*
c743401f 199%{_mandir}/man1/sqlite3.1*
17b8c9f1 200
201%files devel
202%defattr(644,root,root,755)
203%doc doc/*
204%attr(755,root,root) %{_libdir}/lib*.so
205%{_libdir}/lib*.la
206%{_includedir}/sqlite3.h
ef88c71c 207%{_includedir}/sqlite3ext.h
17b8c9f1 208%{_pkgconfigdir}/*.pc
209
210%files static
211%defattr(644,root,root,755)
212%{_libdir}/lib*.a
c743401f 213
1a6aae8d 214%if %{with tcl}
c743401f
AM
215%files -n tcl-%{name}
216%defattr(644,root,root,755)
217%dir %{_ulibdir}/tcl*/sqlite3
218%attr(755,root,root) %{_ulibdir}/tcl*/sqlite3/*.so
219%{_ulibdir}/tcl*/sqlite3/*.tcl
1a6aae8d 220%endif
This page took 0.083942 seconds and 4 git commands to generate.