]> git.pld-linux.org Git - packages/spirv-tools.git/blame - spirv-tools.spec
revert last commit, spirv-headers should be fixed
[packages/spirv-tools.git] / spirv-tools.spec
CommitLineData
af1c7ed7 1
85dcd294
JK
2%define snap 20161027
3%define commit b371439d6fbc6b7b7cd5b4ef7046faa6cdf0e9e2
dc0fdaa7
JK
4%define _ver %(echo %{version} | tr _ -)
5Summary: SPIR-V Tools
6Name: spirv-tools
85dcd294 7Version: v2016.6.s%{snap}
43bb1953 8Release: 2
dc0fdaa7
JK
9License: MIT-like
10Group: Applications
af1c7ed7 11Source0: https://github.com/KhronosGroup/SPIRV-Tools/archive/%{commit}/%{name}-s%{snap}.tar.gz
85dcd294 12# Source0-md5: 7312ed45ce0e279aa5829c867ce227e1
dc0fdaa7 13Patch0: cmake-lib64.patch
d0e0a7d3 14Patch1: no-git-describe.patch
dc0fdaa7
JK
15URL: https://github.com/KhronosGroup/SPIRV-Tools
16BuildRequires: cmake
85dcd294 17BuildRequires: spirv-headers
dc0fdaa7
JK
18Requires: %{name}-libs = %{version}-%{release}
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22The SPIR-V Tools project provides an API and commands for processing
23SPIR-V modules.
24
25The project includes an assembler, binary module parser, disassembler,
26and validator for SPIR-V, all based on a common static library. The
27library contains all of the implementation details, and is used in the
28standalone tools whilst also enabling integration into other code
29bases directly.
30
31The interfaces are still under development, and are expected to
32change.
33
34SPIR-V is defined by the Khronos Group Inc.
35
36%package libs
37Summary: SPIR-V Tools library
38Group: Libraries
39
40%description libs
41The SPIR-V Tools project provides an API for processing SPIR-V
42modules.
43
44%package devel
45Summary: Header files for %{name} library
46Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
47Group: Development/Libraries
85dcd294 48Requires: spirv-headers
dc0fdaa7
JK
49Requires: %{name}-libs = %{version}-%{release}
50
51%description devel
52Header files for %{name} library.
53
54%description devel -l pl.UTF-8
55Pliki nagłówkowe biblioteki %{name}.
56
57%prep
85dcd294 58%setup -q -n SPIRV-Tools-%{commit}
8036bc88 59
dc0fdaa7 60%patch0 -p1
d0e0a7d3 61%patch1 -p1
dc0fdaa7
JK
62
63%build
85dcd294
JK
64install -d build external/spirv-headers/include
65ln -s /usr/include/spirv external/spirv-headers/include/spirv
66
dc0fdaa7
JK
67cd build
68%cmake \
69 ../
70
d0e0a7d3
JK
71# we know better than utils/update_build_version.py
72echo '"spirv-tools %{commit}\\n"' > build-version.inc
73
dc0fdaa7
JK
74%{__make}
75
76%install
77rm -rf $RPM_BUILD_ROOT
78
79cd build
80%{__make} install \
81 DESTDIR=$RPM_BUILD_ROOT
625333b6
JK
82cd ..
83
dc0fdaa7
JK
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post libs -p /sbin/ldconfig
88%postun libs -p /sbin/ldconfig
89
90%files
91%defattr(644,root,root,755)
92%doc LICENSE README.md syntax.md
93%attr(755,root,root) %{_bindir}/spirv-*
94
95%files libs
96%defattr(644,root,root,755)
97%attr(755,root,root) %{_libdir}/libSPIRV-Tools.so
85dcd294 98%attr(755,root,root) %{_libdir}/libSPIRV-Tools-opt.so
dc0fdaa7
JK
99
100%files devel
101%defattr(644,root,root,755)
dc0fdaa7 102%{_includedir}/spirv-tools
This page took 0.125259 seconds and 4 git commands to generate.