]> git.pld-linux.org Git - packages/spirv-tools.git/blame - spirv-tools.spec
new package
[packages/spirv-tools.git] / spirv-tools.spec
CommitLineData
dc0fdaa7
JK
1%define _ver %(echo %{version} | tr _ -)
2Summary: SPIR-V Tools
3Name: spirv-tools
4Version: 1.0_rev3
5Release: 0.1
6License: MIT-like
7Group: Applications
8Source0: https://github.com/KhronosGroup/SPIRV-Tools/archive/spirv-%{_ver}/%{name}-%{version}.tar.gz
9# Source0-md5: 81a72c33f7d50d010de760d55a96683f
10Patch0: cmake-lib64.patch
11URL: https://github.com/KhronosGroup/SPIRV-Tools
12BuildRequires: cmake
13Requires: %{name}-libs = %{version}-%{release}
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17The SPIR-V Tools project provides an API and commands for processing
18SPIR-V modules.
19
20The project includes an assembler, binary module parser, disassembler,
21and validator for SPIR-V, all based on a common static library. The
22library contains all of the implementation details, and is used in the
23standalone tools whilst also enabling integration into other code
24bases directly.
25
26The interfaces are still under development, and are expected to
27change.
28
29SPIR-V is defined by the Khronos Group Inc.
30
31%package libs
32Summary: SPIR-V Tools library
33Group: Libraries
34
35%description libs
36The SPIR-V Tools project provides an API for processing SPIR-V
37modules.
38
39%package devel
40Summary: Header files for %{name} library
41Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
42Group: Development/Libraries
43Requires: %{name}-libs = %{version}-%{release}
44
45%description devel
46Header files for %{name} library.
47
48%description devel -l pl.UTF-8
49Pliki nagłówkowe biblioteki %{name}.
50
51%prep
52%setup -q -n SPIRV-Tools-spirv-%{_ver}
53%patch0 -p1
54
55%build
56install -d build
57cd build
58%cmake \
59 ../
60
61%{__make}
62
63%install
64rm -rf $RPM_BUILD_ROOT
65
66cd build
67%{__make} install \
68 DESTDIR=$RPM_BUILD_ROOT
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%post libs -p /sbin/ldconfig
74%postun libs -p /sbin/ldconfig
75
76%files
77%defattr(644,root,root,755)
78%doc LICENSE README.md syntax.md
79%attr(755,root,root) %{_bindir}/spirv-*
80
81%files libs
82%defattr(644,root,root,755)
83%attr(755,root,root) %{_libdir}/libSPIRV-Tools.so
84
85%files devel
86%defattr(644,root,root,755)
87%{_includedir}/spirv
88%{_includedir}/spirv-tools
This page took 0.092146 seconds and 4 git commands to generate.