]> git.pld-linux.org Git - packages/sphinx-pdg.git/blame - sphinx-pdg.spec
- release 2 (by relup.sh)
[packages/sphinx-pdg.git] / sphinx-pdg.spec
CommitLineData
992edea4 1# there are sphinx.spec, sphinx2.spec... Sphinx.spec is too confusing
2# therefore the name for this package is sphinx-pdg (pdg - python
3# documentation generator)
79af714d
JB
4Summary: Sphinx - Python documentation generator
5Summary(pl.UTF-8): Sphinx - narzędzie do tworzenia dokumentacji dla Pythona
4acf166f 6Name: sphinx-pdg
3cf2dc54 7Version: 1.1.3
d529d9e4 8Release: 2
4acf166f 9License: BSD
10Group: Development/Languages/Python
11Source0: http://pypi.python.org/packages/source/S/Sphinx/Sphinx-%{version}.tar.gz
3cf2dc54 12# Source0-md5: 8f55a6d4f87fc6d528120c5d1f983e98
b844f666 13URL: http://sphinx.pocoo.org/
5c7437a8 14BuildRequires: python-devel >= 1:2.5
7f1d6506 15BuildRequires: python-distribute
5c7437a8 16BuildRequires: python-modules >= 1:2.5
7f1d6506
AF
17BuildRequires: python3-2to3
18BuildRequires: python3-devel
19BuildRequires: python3-distribute
f82fee34 20BuildRequires: python3-modules
d6f62011 21BuildRequires: rpm-pythonprov
79af714d 22BuildRequires: rpmbuild(macros) >= 1.219
8dffcc23 23Requires: python-Sphinx = %{version}-%{release}
4acf166f 24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
d6f62011 28Sphinx is a tool that makes it easy to create intelligent and
29beautiful documentation for Python projects (or other documents
30consisting of multiple reStructuredText sources), written by Georg
31Brandl. It was originally created to translate the new Python
32documentation, but has now been cleaned up in the hope that it will be
33useful to many other projects.
4acf166f 34
79af714d
JB
35%description -l pl.UTF-8
36Sphinx to narzędzie ułatwiające tworzenie inteligentnej i ładnej
37dokumentacji dla projektów w Pythonie (lub innych dokumentów
38składających się z wielu źródeł w formacie reStructuredText), napisane
39przez Georga Brandla. Pierwotnie powstało do tłumaczenia nowej
40dokumentacji Pythona, ale potem zostało wyczyszczone w nadziei, że
41będzie przydatne dla wielu innych projektów.
42
43%package 3
44Summary: Sphinx Python documentation generator (Python 3 version)
45Summary(pl.UTF-8): Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (wersja dla Pythona 3)
e7b5373a 46Group: Development/Languages/Python
8dffcc23 47Requires: python3-Sphinx = %{version}-%{release}
e7b5373a 48
79af714d 49%description 3
e7b5373a 50Sphinx is a tool that makes it easy to create intelligent and
51beautiful documentation for Python projects (or other documents
52consisting of multiple reStructuredText sources), written by Georg
53Brandl. It was originally created to translate the new Python
54documentation, but has now been cleaned up in the hope that it will be
55useful to many other projects.
56
79af714d
JB
57%description 3 -l pl.UTF-8
58Sphinx to narzędzie ułatwiające tworzenie inteligentnej i ładnej
59dokumentacji dla projektów w Pythonie (lub innych dokumentów
60składających się z wielu źródeł w formacie reStructuredText), napisane
61przez Georga Brandla. Pierwotnie powstało do tłumaczenia nowej
62dokumentacji Pythona, ale potem zostało wyczyszczone w nadziei, że
63będzie przydatne dla wielu innych projektów.
64
8dffcc23
JB
65%package -n python-Sphinx
66Summary: Sphinx Python documentation generator (Python 2.x modules)
67Summary(pl.UTF-8): Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły Pythona 2.x)
68Group: Development/Languages/Python
69Requires: python-distribute
ac0b54ce
JB
70Requires: python-docutils >= 0.7
71Requires: python-jinja2 >= 2.3
72Requires: python-pygments >= 1.2
8dffcc23
JB
73%pyrequires_eq python-modules
74Conflicts: sphinx-pdg < 1.0.7-2
75
76%description -n python-Sphinx
77Sphinx Python documentation generator (Python 2.x modules).
78
79For command-line utilities, see sphinx-pdg package.
80
81%description -n python-Sphinx -l pl.UTF-8
82Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły
83Pythona 2.x).
84
85Narzędzia działające z linii poleceń znajdują się w pakiecie
86sphinx-pdg.
87
88%package -n python3-Sphinx
89Summary: Sphinx Python documentation generator (Python 3.x modules)
90Summary(pl.UTF-8): Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły Pythona 3.x)
91Group: Development/Languages/Python
92Requires: python3-distribute
93Requires: python3-docutils >= 0.8
ac0b54ce
JB
94Requires: python3-jinja2 >= 2.3
95Requires: python3-pygments >= 1.2
8dffcc23
JB
96Conflicts: sphinx-pdg-3 < 1.0.7-2
97
98%description -n python3-Sphinx
99Sphinx Python documentation generator (Python 3.x modules).
100
101For command-line utilities, see sphinx-pdg-3 package.
102
103%description -n python3-Sphinx -l pl.UTF-8
104Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły
105Pythona 3.x).
106
107Narzędzia działające z linii poleceń znajdują się w pakiecie
108sphinx-pdg-3.
109
4acf166f 110%prep
111%setup -q -n Sphinx-%{version}
112
113%build
e7b5373a 114%{__python} setup.py build -b build-2
7f1d6506 115rm sphinx/__init__.pyc
e7b5373a 116%{__python3} setup.py build -b build-3
7f1d6506 117rm -r sphinx/__pycache__
4acf166f 118
119%install
120rm -rf $RPM_BUILD_ROOT
4acf166f 121
e7b5373a 122%{__python3} setup.py build -b build-3 install \
123 --optimize=2 \
124 --root=$RPM_BUILD_ROOT
7f1d6506 125rm -r sphinx/__pycache__
e7b5373a 126
127for f in $RPM_BUILD_ROOT%{_bindir}/*; do
128 mv "${f}" "${f}-3"
129done
130
131%{__python} setup.py build -b build-2 install \
132 --optimize=2 \
133 --root=$RPM_BUILD_ROOT
7f1d6506 134rm sphinx/__init__.pyc
4acf166f 135
136%py_postclean
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%files
142%defattr(644,root,root,755)
79af714d
JB
143%doc AUTHORS CHANGES EXAMPLES LICENSE PKG-INFO README TODO
144%attr(755,root,root) %{_bindir}/sphinx-autogen
1f35fc81 145%attr(755,root,root) %{_bindir}/sphinx-apidoc
79af714d
JB
146%attr(755,root,root) %{_bindir}/sphinx-build
147%attr(755,root,root) %{_bindir}/sphinx-quickstart
e7b5373a 148
79af714d 149%files 3
e7b5373a 150%defattr(644,root,root,755)
79af714d
JB
151%doc AUTHORS CHANGES EXAMPLES LICENSE PKG-INFO README TODO
152%attr(755,root,root) %{_bindir}/sphinx-autogen-3
1f35fc81 153%attr(755,root,root) %{_bindir}/sphinx-apidoc-3
79af714d
JB
154%attr(755,root,root) %{_bindir}/sphinx-build-3
155%attr(755,root,root) %{_bindir}/sphinx-quickstart-3
8dffcc23
JB
156
157%files -n python-Sphinx
158%defattr(644,root,root,755)
159%{py_sitescriptdir}/sphinx
160%{py_sitescriptdir}/Sphinx-%{version}-py*.egg-info
161
162%files -n python3-Sphinx
163%defattr(644,root,root,755)
e7b5373a 164%{py3_sitescriptdir}/sphinx
79af714d 165%{py3_sitescriptdir}/Sphinx-%{version}-py*.egg-info
This page took 0.143201 seconds and 4 git commands to generate.