]> git.pld-linux.org Git - packages/setup.git/blame - setup.spec
ldd logs to stderr now
[packages/setup.git] / setup.spec
CommitLineData
bf515c7b
PG
1# TODO:
2# - make some README.PLD with system features description
86056b15 3#
ba725839 4%bcond_without diet # compile binaries with diet cc
878a6b3b 5
c06b68d0 6%define iana_etc_ver 2.30
f97bd99d 7Summary: Simple setup files
8551200d
ER
8Summary(de.UTF-8): Einfache Setup-Dateien
9Summary(es.UTF-8): Varios archivos básicos de configuración
10Summary(fr.UTF-8): Fichiers de configuration simples
11Summary(ja.UTF-8): サンプルセットアップファイル
12Summary(pl.UTF-8): Podstawowe pliki systemu Linux
13Summary(pt_BR.UTF-8): Vários arquivos básicos de configuração
14Summary(tr.UTF-8): Basit kurulum dosyaları
f97bd99d 15Name: setup
1244ac5c
ER
16Version: 2.10.0
17Release: 1
bf515c7b 18License: Public Domain, partially BSD-like
f97bd99d 19Group: Base
dc79bfc1 20Source0: %{name}-%{version}.tar.bz2
1244ac5c 21# Source0-md5: 1ecb6d9865ce3300881fa466d0c97583
7d7bb07f 22# http://sethwklein.net/iana-etc
d0a84d4c 23Source1: http://sethwklein.net/projects/iana-etc/downloads/iana-etc-%{iana_etc_ver}.tar.bz2
b67e9502 24# Source1-md5: 3ba3afb1d1b261383d247f46cb135ee8
7d7bb07f
ER
25Source2: http://www.iana.org/assignments/protocol-numbers/index.txt
26# Source2-md5: 33440b7d913303a6051ae64290f0ab21
27Source3: http://www.iana.org/assignments/port-numbers
28# Source3-md5: 8e19a2c7cf60baabf919de1cc89a1cbb
39438d8e 29Patch0: %{name}-iana-etc.patch
d0a84d4c 30# This is source of non-iana changes in services file
39438d8e 31Patch1: %{name}-services.patch
7d7bb07f 32Patch2: protocols-fmt.patch
a0098a54 33%if %{with diet}
fe293510 34BuildRequires: dietlibc-static
a0098a54
AM
35%else
36BuildRequires: glibc-static
37%endif
36832d85 38BuildRequires: gawk
00ef0f6f 39BuildRequires: glibc-misc
f2dcd3fa 40Requires: FHS >= 2.3-24.1
39438d8e 41Provides: group(fuse)
2b40f793 42Conflicts: PowerChutePlus < 4.5.3-2
ee80b4de 43Conflicts: glibc < 6:2.4-4.1
f1b9589b
JR
44# tape,dialout and cdrom groups support
45Conflicts: dev < 3.4-4
46Conflicts: udev < 1:138-5
6480c437
AM
47# /etc/mtab being symlink to /proc/self/mounts
48Conflicts: rc-scripts < 0.4.5.1-3
50ba189c 49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6be1ce2e 50
3d5c2a8f 51%define _sbindir /sbin
878a6b3b 52%undefine with_ccache
3d5c2a8f 53
ba725839
ER
54%ifnarch x32
55# not on x32, see 02e9d04
56%define specflags -Os
57%endif
58
6be1ce2e 59%description
7a8444bd
SZ
60This package contains a number of very important configuration and
61setup files, including the passwd, group, profile files, etc.
6be1ce2e 62
2f487416
JR
63%description -l de.UTF-8
64Dieses Paket enthält wichtige Konfigurations- und Setup-Dateien, u.a.
a9f190e7 65passwd-, group-, profile-Dateien usw.
6be1ce2e 66
2f487416
JR
67%description -l es.UTF-8
68Este paquete contiene una variedad de archivos de configuración y
05f14211
TP
69setup muy importantes, incluyendo el passwd, group, archivos de
70"perfil", etc.
71
2f487416
JR
72%description -l fr.UTF-8
73Ce paquetage contient un nombre de fichiers de configuration très
6be1ce2e 74importants, comme passwd, group, les fichiers profile, etc.
75
2f487416
JR
76%description -l ja.UTF-8
77このsetupパッケージには、passwd, group, profile などの、
78重要なシステム設定ファイルが含まれてます。
05f14211 79
2f487416
JR
80%description -l pl.UTF-8
81Pakiet ten zawiera wiele bardzo ważnych plików konfiguracyjnych dla
a6f7ca8d 82Twojego systemu.
87946706 83
2f487416
JR
84%description -l pt_BR.UTF-8
85Este pacote contém uma variedade de arquivos de configuração e setup
ea4c6647
JB
86muito importantes, incluindo o passwd, group, arquivos de "perfil",
87etc.
d0944bc6 88
2f487416
JR
89%description -l tr.UTF-8
90Bu paket, passwd, group, profile gibi çok önemli ayar ve kurulum
91dosyalarını içerir.
d0944bc6 92
6be1ce2e 93%prep
dc79bfc1 94%setup -q -a1
150c6f35 95mv iana-etc{-%{iana_etc_ver},}
1244ac5c 96%patch0 -p1
7d7bb07f
ER
97%patch2 -p1
98
1244ac5c
ER
99cp -p %{SOURCE2} iana-etc/protocol-numbers.iana
100cp -p %{SOURCE3} iana-etc/port-numbers.iana
bf515c7b
PG
101
102%build
150c6f35
ER
103%{__make} -C iana-etc
104%{__patch} iana-etc/services %{PATCH1}
105
106# kill trailing spaces/tabs
7d7bb07f 107%{__sed} -i -e 's,[ \t]\+$,,' iana-etc/{services,protocols}
0b6becf4 108
bf515c7b 109%{__make} \
a0098a54 110 CC="%{?with_diet:diet }%{__cc}" \
02e9d04f 111 OPT_FLAGS="%{rpmcflags} -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64" \
3aa38c78
AM
112 LDFLAGS="%{rpmcflags} %{rpmldflags} -static"
113
7a3e4d83 114ldd postshell 2>&1 | grep "not a dynamic executable" || exit 1
6be1ce2e 115
116%install
797d0215 117rm -rf $RPM_BUILD_ROOT
93f8153d 118install -d $RPM_BUILD_ROOT%{_sysconfdir}/shrc.d
bf515c7b
PG
119%{__make} install \
120 DESTDIR=$RPM_BUILD_ROOT
0b6becf4 121
ba725839 122cp -p iana-etc/{services,protocols} $RPM_BUILD_ROOT%{_sysconfdir}
0b6becf4 123
f2dcd3fa 124# not packaged
ea53b031 125%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/{netgroup,suid_profile}
f2dcd3fa 126
6be1ce2e 127%clean
797d0215 128rm -rf $RPM_BUILD_ROOT
6be1ce2e 129
ba725839 130# trigger to ensure /etc/mtab is symlink
c06b68d0
ER
131%triggerprein -p /sbin/postshell -- %{name} < %{version}-%{release}
132-/bin/sh -c '/usr/bin/test -L /etc/mtab || /bin/mv -v /etc/mtab /etc/mtab.rpmsave'
133
778eea73
JR
134%triggerpostun -p /sbin/postshell -- %{name} < %{version}-%{release}
135%{_sbindir}/joinpasswd
136%{_sbindir}/delpasswd -g ttyS cdwrite
81b992a1 137
7cf4e42c 138%triggerin -p %{_sbindir}/update-fstab -- %{name} < 2.4.10-1
a2b3dd01 139
544edbb0
ER
140%post -p /sbin/postshell
141-/sbin/env-update -u
142
143%postun -p /sbin/postshell
144-/sbin/env-update -u
145
6be1ce2e 146%files
f97bd99d 147%defattr(644,root,root,755)
bf515c7b 148%doc ChangeLog
778eea73 149%attr(755,root,root) %{_sbindir}/delpasswd
bf515c7b 150%attr(755,root,root) %{_sbindir}/joinpasswd
47f42bc8 151%attr(755,root,root) %{_sbindir}/postshell
7cf4e42c 152%attr(755,root,root) %{_sbindir}/update-fstab
bf515c7b 153%dir /etc/profile.d
9bee86ed
AM
154%config(noreplace,missingok) %verify(not md5 mtime size) %attr(755,root,root) /etc/profile.d/00-tmp-dir.sh
155%config(noreplace,missingok) %verify(not md5 mtime size) %attr(755,root,root) /etc/profile.d/00-tmp-dir.csh
4db3fb34 156%dir %{_sysconfdir}/env.d
ea53b031
JB
157%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/env.d/EDITOR
158%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/env.d/HISTFILESIZE
159%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/env.d/HOME_ETC
160%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/env.d/MAILCHECK
161%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/env.d/MAILPATH
162%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/env.d/NNTPSERVER
163%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/env.d/ORGANIZATION
164%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/env.d/TMOUT
165%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/env.d/VISUAL
4db3fb34 166%dir %{_sysconfdir}/shrc.d
391e8940
JR
167%config(noreplace) %verify(not md5 mtime size) /etc/shrc.d/256term.sh
168%config(noreplace) %verify(not md5 mtime size) /etc/shrc.d/256term.csh
9310ed4f
ER
169%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fstab
170%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/group
171%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/host.conf
172%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hosts
173%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/passwd
174%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/profile
175%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/protocols
1244ac5c
ER
176%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/subgid
177%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/subuid
ea53b031 178%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/securetty
9310ed4f
ER
179%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/services
180%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/filesystems
181%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/motd
182%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/resolv.conf
bf515c7b 183%ghost %{_sysconfdir}/shells
59e09c3d
AM
184# symlink to /proc/self/mounts
185%{_sysconfdir}/mtab
1244ac5c
ER
186
187
This page took 0.106254 seconds and 4 git commands to generate.