]> git.pld-linux.org Git - packages/selinux-python.git/blame - selinux-python.spec
- adapter
[packages/selinux-python.git] / selinux-python.spec
CommitLineData
15e8762f
JB
1Summary: SELinux Python policy utilities
2Summary(pl.UTF-8): Narzędzia do polityk SELinuksa napisane w Pythonie
3Name: selinux-python
3226cfc1 4Version: 2.9
cf20819c 5Release: 1
15e8762f
JB
6License: GPL v2 (sepolgen), GPL v2+ (semodule, sepolicy)
7Group: Applications/System
8#Source0Download: https://github.com/SELinuxProject/selinux/wiki/Releases
3226cfc1
JR
9Source0: https://github.com/SELinuxProject/selinux/releases/download/20190315/%{name}-%{version}.tar.gz
10# Source0-md5: e9dfedd1139dd9998f5a09abfb670454
15e8762f
JB
11URL: https://github.com/SELinuxProject/selinux/wiki
12BuildRequires: libsepol-static >= 2.7
eb4ac7d6 13BuildRequires: python3-modules
15e8762f
JB
14BuildRequires: rpm-pythonprov
15BuildRequires: rpmbuild(macros) >= 1.714
16Requires: policycoreutils >= 2.7
eb4ac7d6 17Requires: python3-sepolicy = %{version}-%{release}
15e8762f
JB
18Obsoletes: policycoreutils-sepolicy < 2.7
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22Security-enhanced Linux is a patch of the Linux kernel and a number of
23utilities with enhanced security functionality designed to add
24mandatory access controls to Linux. The Security-enhanced Linux kernel
25contains new architectural components originally developed to improve
26the security of the Flask operating system. These architectural
27components provide general support for the enforcement of many kinds
28of mandatory access control policies, including those based on the
29concepts of Type Enforcement, Role-based Access Control, and
30Multi-level Security.
31
32This package contains Python based SELinux policy utilities.
33
34%description -l pl.UTF-8
35Security-enhanced Linux jest prototypem jądra Linuksa i wielu
36aplikacji użytkowych o funkcjach podwyższonego bezpieczeństwa.
37Zaprojektowany jest tak, aby w prosty sposób ukazać znaczenie
38obowiązkowej kontroli dostępu dla społeczności linuksowej. Ukazuje
39również jak taką kontrolę można dodać do istniejącego systemu typu
40Linux. Jądro SELinux zawiera nowe składniki architektury pierwotnie
41opracowane w celu ulepszenia bezpieczeństwa systemu operacyjnego
42Flask. Te elementy zapewniają ogólne wsparcie we wdrażaniu wielu typów
43polityk obowiązkowej kontroli dostępu, włączając te wzorowane na: Type
44Enforcement (TE), kontroli dostępu opartej na rolach (RBAC) i
45zabezpieczeniach wielopoziomowych.
46
47Ten pakiet zawiera narzędzia do polityk SELinuksa napisane w Pythonie.
48
49%package -n bash-completion-%{name}
50Summary: Bash completion for semanage and sepolicy commands
51Summary(pl.UTF-8): Bashowe dopełnianie składni poleceń semanage i sepolicy
52Group: Applications/Shells
53Requires: %{name} = %{version}-%{release}
54Requires: bash-completion >= 2
55
56%description -n bash-completion-%{name}
57Bash completion for semanage and sepolicy commands.
58
59%description -n bash-completion-%{name} -l pl.UTF-8
60Bashowe dopełnianie składni poleceń semanage i sepolicy.
61
15e8762f
JB
62%package -n python3-sepolgen
63Summary: sepolgen - Python 3 module for policy generation
64Summary(pl.UTF-8): Moduł Pythona 3 sepolgen do generowania polityki
65License: GPL v2
60c0ba6e 66Group: Libraries/Python
15e8762f 67Requires: python3-selinux >= 2.7
eb4ac7d6
JR
68Suggests: python3-setools
69Obsoletes: python-sepolgen-common < 2.9-1
15e8762f
JB
70BuildArch: noarch
71
72%description -n python3-sepolgen
73sepolgen - Python module for policy generation.
74
75%description -n python3-sepolgen -l pl.UTF-8
76Moduł Pythona sepolgen do generowania polityki.
77
eb4ac7d6 78%package -n python3-sepolicy
15e8762f
JB
79Summary: Python modules for SELinux policy manipulation
80Summary(pl.UTF-8): Moduły Pythona do operowania na politykach SELinuksa
60c0ba6e 81Group: Libraries/Python
15e8762f
JB
82# seobject and sepolicy use translations from policycoreutils domain
83Requires: policycoreutils >= 2.7
eb4ac7d6
JR
84Requires: python3-IPy
85Requires: python3-dbus
86Requires: python3-semanage >= 2.7
87Requires: python3-sepolgen = %{version}-%{release}
88Requires: python3-setools
89Requires: python3-slip-dbus
15e8762f
JB
90# for sepolicy.gui additionally:
91Requires: gtk+3 >= 3
eb4ac7d6 92Requires: python3-pygobject3 >= 3
15e8762f 93Conflicts: policycoreutils-sepolicy < 2.7
15e8762f 94
eb4ac7d6 95%description -n python3-sepolicy
15e8762f
JB
96Python modules for SELinux policy manipulation.
97
eb4ac7d6 98%description -n python3-sepolicy -l pl.UTF-8
15e8762f
JB
99Moduły Pythona do operowania na politykach SELinuksa.
100
101%prep
102%setup -q
15e8762f
JB
103
104%build
105CFLAGS="%{rpmcflags} %{rpmcppflags}" \
106%{__make} \
107 CC="%{__cc}" \
108 LIBDIR="%{_libdir}"
109
110%install
111rm -rf $RPM_BUILD_ROOT
112
113%{__make} install \
114 DESTDIR=$RPM_BUILD_ROOT \
eb4ac7d6 115 PYTHONLIBDIR=%{py3_sitescriptdir} \
15e8762f
JB
116 LIBSEPOLA=%{_libdir}/libsepol.a
117
15e8762f
JB
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%files
122%defattr(644,root,root,755)
123%attr(755,root,root) %{_bindir}/audit2allow
124%attr(755,root,root) %{_bindir}/audit2why
125%attr(755,root,root) %{_bindir}/chcat
126%attr(755,root,root) %{_bindir}/sepolgen
127%attr(755,root,root) %{_bindir}/sepolgen-ifgen
128%attr(755,root,root) %{_bindir}/sepolgen-ifgen-attr-helper
129%attr(755,root,root) %{_bindir}/sepolicy
130%attr(755,root,root) %{_sbindir}/semanage
131%{_mandir}/man1/audit2allow.1*
132%{_mandir}/man1/audit2why.1*
133%{_mandir}/man8/chcat.8*
134%{_mandir}/man8/sepolgen.8*
135%{_mandir}/man8/sepolicy*.8*
136%{_mandir}/man8/semanage*.8*
eb4ac7d6 137%lang(ru) %{_mandir}/ru/man*/*
15e8762f
JB
138
139%files -n bash-completion-%{name}
140%defattr(644,root,root,755)
141%{bash_compdir}/semanage
142%{bash_compdir}/sepolicy
143
15e8762f
JB
144%files -n python3-sepolgen
145%defattr(644,root,root,755)
146%{py3_sitescriptdir}/sepolgen
eb4ac7d6
JR
147%dir /var/lib/sepolgen
148%config(noreplace) %verify(not md5 mtime size) /var/lib/sepolgen/perm_map
15e8762f 149
eb4ac7d6 150%files -n python3-sepolicy
15e8762f 151%defattr(644,root,root,755)
eb4ac7d6
JR
152%{py3_sitescriptdir}/seobject.py
153%dir %{py3_sitedir}/sepolicy
60c0ba6e 154%{py3_sitedir}/sepolicy/__pycache__
eb4ac7d6
JR
155%{py3_sitedir}/sepolicy/*.py
156%{py3_sitedir}/sepolicy/sepolicy.glade
157%dir %{py3_sitedir}/sepolicy/help
60c0ba6e 158%{py3_sitedir}/sepolicy/help/__pycache__
eb4ac7d6
JR
159%{py3_sitedir}/sepolicy/help/__init__.py
160%{py3_sitedir}/sepolicy/help/*.png
161%{py3_sitedir}/sepolicy/help/*.txt
162%dir %{py3_sitedir}/sepolicy/templates
60c0ba6e 163%{py3_sitedir}/sepolicy/templates/__pycache__
eb4ac7d6
JR
164%{py3_sitedir}/sepolicy/templates/*.py
165%{py3_sitedir}/sepolicy-1.1-py*.egg-info
This page took 0.095133 seconds and 4 git commands to generate.