]> git.pld-linux.org Git - packages/selinux-python.git/blame - selinux-python.spec
rebuild with python 3.10
[packages/selinux-python.git] / selinux-python.spec
CommitLineData
15e8762f
JB
1Summary: SELinux Python policy utilities
2Summary(pl.UTF-8): Narzędzia do polityk SELinuksa napisane w Pythonie
3Name: selinux-python
0819d737 4Version: 3.1
0fb63193 5Release: 2
15e8762f
JB
6License: GPL v2 (sepolgen), GPL v2+ (semodule, sepolicy)
7Group: Applications/System
8#Source0Download: https://github.com/SELinuxProject/selinux/wiki/Releases
0819d737
JB
9Source0: https://github.com/SELinuxProject/selinux/releases/download/20200710/%{name}-%{version}.tar.gz
10# Source0-md5: ec75687b680e0dd63e3ded05bd41cb5a
15e8762f 11URL: https://github.com/SELinuxProject/selinux/wiki
0819d737 12BuildRequires: libsepol-static >= 3.1
eb4ac7d6 13BuildRequires: python3-modules
15e8762f
JB
14BuildRequires: rpm-pythonprov
15BuildRequires: rpmbuild(macros) >= 1.714
0e8f51be
JB
16# audit2allow requires sepolgen,selinux modules
17# chcat requires selinux,seobject modules and "policycoreutils" translations domain
18# semanage requires seobject module (part of semanage in fact) and "policycoreutils" translations domain
0819d737
JB
19Requires: policycoreutils >= 3.1
20Requires: python3-selinux >= 3.1
eb4ac7d6 21Requires: python3-sepolicy = %{version}-%{release}
15e8762f
JB
22Obsoletes: policycoreutils-sepolicy < 2.7
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Security-enhanced Linux is a patch of the Linux kernel and a number of
27utilities with enhanced security functionality designed to add
28mandatory access controls to Linux. The Security-enhanced Linux kernel
29contains new architectural components originally developed to improve
30the security of the Flask operating system. These architectural
31components provide general support for the enforcement of many kinds
32of mandatory access control policies, including those based on the
33concepts of Type Enforcement, Role-based Access Control, and
34Multi-level Security.
35
36This package contains Python based SELinux policy utilities.
37
38%description -l pl.UTF-8
39Security-enhanced Linux jest prototypem jądra Linuksa i wielu
40aplikacji użytkowych o funkcjach podwyższonego bezpieczeństwa.
41Zaprojektowany jest tak, aby w prosty sposób ukazać znaczenie
42obowiązkowej kontroli dostępu dla społeczności linuksowej. Ukazuje
43również jak taką kontrolę można dodać do istniejącego systemu typu
44Linux. Jądro SELinux zawiera nowe składniki architektury pierwotnie
45opracowane w celu ulepszenia bezpieczeństwa systemu operacyjnego
46Flask. Te elementy zapewniają ogólne wsparcie we wdrażaniu wielu typów
47polityk obowiązkowej kontroli dostępu, włączając te wzorowane na: Type
48Enforcement (TE), kontroli dostępu opartej na rolach (RBAC) i
49zabezpieczeniach wielopoziomowych.
50
51Ten pakiet zawiera narzędzia do polityk SELinuksa napisane w Pythonie.
52
53%package -n bash-completion-%{name}
54Summary: Bash completion for semanage and sepolicy commands
55Summary(pl.UTF-8): Bashowe dopełnianie składni poleceń semanage i sepolicy
56Group: Applications/Shells
57Requires: %{name} = %{version}-%{release}
58Requires: bash-completion >= 2
59
60%description -n bash-completion-%{name}
61Bash completion for semanage and sepolicy commands.
62
63%description -n bash-completion-%{name} -l pl.UTF-8
64Bashowe dopełnianie składni poleceń semanage i sepolicy.
65
15e8762f
JB
66%package -n python3-sepolgen
67Summary: sepolgen - Python 3 module for policy generation
68Summary(pl.UTF-8): Moduł Pythona 3 sepolgen do generowania polityki
69License: GPL v2
60c0ba6e 70Group: Libraries/Python
0819d737 71Requires: python3-selinux >= 3.1
eb4ac7d6
JR
72Suggests: python3-setools
73Obsoletes: python-sepolgen-common < 2.9-1
15e8762f
JB
74BuildArch: noarch
75
76%description -n python3-sepolgen
77sepolgen - Python module for policy generation.
78
79%description -n python3-sepolgen -l pl.UTF-8
80Moduł Pythona sepolgen do generowania polityki.
81
eb4ac7d6 82%package -n python3-sepolicy
15e8762f
JB
83Summary: Python modules for SELinux policy manipulation
84Summary(pl.UTF-8): Moduły Pythona do operowania na politykach SELinuksa
60c0ba6e 85Group: Libraries/Python
0e8f51be 86# seobject uses selinux,semanage,sepolicy,setools +IPy modules and "policycoreutils" translations domain
15e8762f 87# seobject and sepolicy use translations from policycoreutils domain
0819d737 88Requires: policycoreutils >= 3.1
eb4ac7d6
JR
89Requires: python3-IPy
90Requires: python3-dbus
0819d737 91Requires: python3-semanage >= 3.1
eb4ac7d6
JR
92Requires: python3-sepolgen = %{version}-%{release}
93Requires: python3-setools
94Requires: python3-slip-dbus
15e8762f
JB
95# for sepolicy.gui additionally:
96Requires: gtk+3 >= 3
eb4ac7d6 97Requires: python3-pygobject3 >= 3
15e8762f 98Conflicts: policycoreutils-sepolicy < 2.7
15e8762f 99
eb4ac7d6 100%description -n python3-sepolicy
15e8762f
JB
101Python modules for SELinux policy manipulation.
102
eb4ac7d6 103%description -n python3-sepolicy -l pl.UTF-8
15e8762f
JB
104Moduły Pythona do operowania na politykach SELinuksa.
105
106%prep
107%setup -q
15e8762f
JB
108
109%build
110CFLAGS="%{rpmcflags} %{rpmcppflags}" \
111%{__make} \
112 CC="%{__cc}" \
113 LIBDIR="%{_libdir}"
114
115%install
116rm -rf $RPM_BUILD_ROOT
117
118%{__make} install \
119 DESTDIR=$RPM_BUILD_ROOT \
eb4ac7d6 120 PYTHONLIBDIR=%{py3_sitescriptdir} \
15e8762f
JB
121 LIBSEPOLA=%{_libdir}/libsepol.a
122
15e8762f
JB
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%files
127%defattr(644,root,root,755)
128%attr(755,root,root) %{_bindir}/audit2allow
129%attr(755,root,root) %{_bindir}/audit2why
130%attr(755,root,root) %{_bindir}/chcat
131%attr(755,root,root) %{_bindir}/sepolgen
132%attr(755,root,root) %{_bindir}/sepolgen-ifgen
133%attr(755,root,root) %{_bindir}/sepolgen-ifgen-attr-helper
134%attr(755,root,root) %{_bindir}/sepolicy
135%attr(755,root,root) %{_sbindir}/semanage
136%{_mandir}/man1/audit2allow.1*
137%{_mandir}/man1/audit2why.1*
138%{_mandir}/man8/chcat.8*
0e8f51be 139%{_mandir}/man8/semanage*.8*
15e8762f
JB
140%{_mandir}/man8/sepolgen.8*
141%{_mandir}/man8/sepolicy*.8*
0819d737
JB
142%lang(ru) %{_mandir}/ru/man1/audit2allow.1*
143%lang(ru) %{_mandir}/ru/man1/audit2why.1*
144%lang(ru) %{_mandir}/ru/man8/chcat.8*
145%lang(ru) %{_mandir}/ru/man8/semanage*.8*
146%lang(ru) %{_mandir}/ru/man8/sepolgen.8*
147%lang(ru) %{_mandir}/ru/man8/sepolicy*.8*
15e8762f
JB
148
149%files -n bash-completion-%{name}
150%defattr(644,root,root,755)
151%{bash_compdir}/semanage
152%{bash_compdir}/sepolicy
153
15e8762f
JB
154%files -n python3-sepolgen
155%defattr(644,root,root,755)
156%{py3_sitescriptdir}/sepolgen
eb4ac7d6
JR
157%dir /var/lib/sepolgen
158%config(noreplace) %verify(not md5 mtime size) /var/lib/sepolgen/perm_map
15e8762f 159
eb4ac7d6 160%files -n python3-sepolicy
15e8762f 161%defattr(644,root,root,755)
eb4ac7d6
JR
162%{py3_sitescriptdir}/seobject.py
163%dir %{py3_sitedir}/sepolicy
60c0ba6e 164%{py3_sitedir}/sepolicy/__pycache__
eb4ac7d6
JR
165%{py3_sitedir}/sepolicy/*.py
166%{py3_sitedir}/sepolicy/sepolicy.glade
167%dir %{py3_sitedir}/sepolicy/help
60c0ba6e 168%{py3_sitedir}/sepolicy/help/__pycache__
eb4ac7d6
JR
169%{py3_sitedir}/sepolicy/help/__init__.py
170%{py3_sitedir}/sepolicy/help/*.png
171%{py3_sitedir}/sepolicy/help/*.txt
172%dir %{py3_sitedir}/sepolicy/templates
60c0ba6e 173%{py3_sitedir}/sepolicy/templates/__pycache__
eb4ac7d6 174%{py3_sitedir}/sepolicy/templates/*.py
0819d737 175%{py3_sitedir}/sepolicy-%{version}-py*.egg-info
This page took 0.149722 seconds and 4 git commands to generate.