]> git.pld-linux.org Git - packages/sdcc.git/blame - sdcc.spec
- updated to 3.6.0
[packages/sdcc.git] / sdcc.spec
CommitLineData
ad45c647 1#
2# Conditional build:
3%bcond_without doc # don't rebuild documentation
4
396dd56d 5Summary: C compiler for Intel 8051 and Zilog Z80
6e9646c0 6Summary(pl.UTF-8): Kompilator C dla Intel 8051 i Zilog Z80
2766fe68 7Name: sdcc
079010b6
JB
8Version: 3.6.0
9Release: 1
ea490d2d 10License: GPL v2+ (tools), GPL v2+ with linking exception (runtime)
79712cbc 11Group: Development/Languages
edea8164 12Source0: http://downloads.sourceforge.net/sdcc/%{name}-src-%{version}.tar.bz2
079010b6 13# Source0-md5: 4c4cf17d8d2b2d37af66c5b7511f62d8
2766fe68 14URL: http://sdcc.sourceforge.net/
79712cbc 15BuildRequires: bison
100f1d12 16BuildRequires: boost-devel
79712cbc 17BuildRequires: flex
2804323a 18BuildRequires: gc-devel
21a15d8c 19BuildRequires: gputils
79712cbc 20BuildRequires: libstdc++-devel
079010b6 21BuildRequires: python >= 1:2.4
ea490d2d 22BuildRequires: sed >= 4.0
ad45c647 23%if %{with doc}
24BuildRequires: latex2html
64937913 25BuildRequires: lyx >= 1.4.4
ecf69603 26BuildRequires: texlive-fonts-cmsuper
27BuildRequires: texlive-fonts-type1-urw
28BuildRequires: texlive-format-pdflatex
29BuildRequires: texlive-latex-ams
30BuildRequires: texlive-makeindex
31BuildRequires: texlive-tex-babel
100f1d12 32BuildRequires: texlive-xetex
ad45c647 33%endif
80a5a011 34Obsoletes: ucsim
d62c156f 35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2766fe68 36
100f1d12 37%define _noautostrip .*%{_datadir}/%{name}/.*
21a15d8c 38
2766fe68 39%description
ea490d2d
JB
40SDCC is retargettable, optimizing ANSI-C compiler. The current version
41targets the Intel 8051 and recently the Zilog Z80 based MCUs. SDCC can
42be retargeted for other 8 bit MCUs or PICs and some day soon will be.
43Supported data types are short (8 bits, 1 byte), char (8 bits, 1
44byte), int (16 bits, 2 bytes), long (32 bit, 4 bytes) and float (4
45byte IEEE). SDCC also comes with the source level debugger SDCDB.
79712cbc 46
2d52e5b2 47%description -l pl.UTF-8
ea490d2d
JB
48SDCC jest optymalizującym kompilatorem ANSI C dla wielu platform.
49Aktualna wersja obsługuje procesory Intel 8051 oraz Zilog Z80. SDCC
50może być łatwo zmodyfikowany by obsługiwać inne 8-bitowe jednostki.
51Obsługiwane typy danych to short (8 bitów, 1 bajt), char (8 bitów, 1
52bajt), int (16 bitów, 2 bajty), long (32 bity, 4 bajty) oraz float (4
53bajty IEEE). SDCC dostarcza również debugger oparty na emulatorze
54ucsim.
55
56%package -n emacs-sdcdb
57Summary: SDCDB debugger support for Emacs
58Summary(pl.UTF-8): Obsługa debuggera SDCDB dla Emacsa
59Group: Development/Tools
60Requires: %{name} = %{version}-%{release}
61Requires: emacs
62
63%description -n emacs-sdcdb
64SDCDB debugger support for Emacs.
65
66%description -n emacs-sdcdb -l pl.UTF-8
67Obsługa debuggera SDCDB dla Emacsa.
2766fe68
MP
68
69%prep
edea8164 70%setup -q
2766fe68 71
ea490d2d 72%{__sed} -i -e '1s,/usr/bin/env python,/usr/bin/python,' support/scripts/as2gbmap.py
9bd8989f 73
ea490d2d 74%build
9bd8989f 75%configure \
76352eee 76 PDFOPT=/bin/cp \
ad45c647 77 %{__enable_disable doc} \
2804323a 78 --enable-libgc \
79 --enable-ucsim \
80 --enable-xa \
81 --enable-serio \
82 --enable-statistic
9bd8989f 83
ecf69603 84%{__make} -j1
2766fe68 85
ea490d2d 86%{__make} -C device/lib -j1 model-mcs51-stack-auto model-mcs51-xstack-auto
386e1cdb 87
2766fe68
MP
88%install
89rm -rf $RPM_BUILD_ROOT
f81fe682 90install -d $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
80a5a011 91
92%{__make} install \
93 "DESTDIR=$RPM_BUILD_ROOT" \
94 "docdir=%{_docdir}/%{name}-%{version}" \
95 "STRIP=/bin/true"
2766fe68 96
f81fe682 97%{__mv} $RPM_BUILD_ROOT%{_bindir}/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
25ff8dc3 98
079010b6
JB
99%{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
100
2766fe68
MP
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%files
79712cbc 105%defattr(644,root,root,755)
25ff8dc3 106%doc %{_docdir}/%{name}-%{version}
ea490d2d
JB
107%attr(755,root,root) %{_bindir}/as2gbmap
108%attr(755,root,root) %{_bindir}/makebin
109%attr(755,root,root) %{_bindir}/packihx
110%attr(755,root,root) %{_bindir}/s51
ea490d2d
JB
111%attr(755,root,root) %{_bindir}/sdar
112%attr(755,root,root) %{_bindir}/sdas*
113%attr(755,root,root) %{_bindir}/sdcc
114%attr(755,root,root) %{_bindir}/sdcclib
115%attr(755,root,root) %{_bindir}/sdcdb
116%attr(755,root,root) %{_bindir}/sdcpp
117%attr(755,root,root) %{_bindir}/sdld*
118%attr(755,root,root) %{_bindir}/sdnm
119%attr(755,root,root) %{_bindir}/sdobjcopy
120%attr(755,root,root) %{_bindir}/sdranlib
121%attr(755,root,root) %{_bindir}/shc08
ea490d2d 122%attr(755,root,root) %{_bindir}/sstm8
ea490d2d 123%attr(755,root,root) %{_bindir}/sz80
25ff8dc3 124%{_datadir}/%{name}
ea490d2d
JB
125
126%files -n emacs-sdcdb
127%defattr(644,root,root,755)
f81fe682
JR
128%{_datadir}/emacs/site-lisp/sdcdb.el
129%{_datadir}/emacs/site-lisp/sdcdbsrc.el
This page took 0.091294 seconds and 4 git commands to generate.