]> git.pld-linux.org Git - packages/ruby-rubytree.git/blame - ruby-rubytree.spec
- ruby 2.0 rebuild
[packages/ruby-rubytree.git] / ruby-rubytree.spec
CommitLineData
1487b78a
JR
1%define pkgname rubytree
2Summary: Ruby implementation of the generic tree data structure
3Name: ruby-%{pkgname}
4Version: 0.6.2
063762fc 5Release: 3
1487b78a
JR
6License: MIT/Ruby License
7Source0: http://rubygems.org/downloads/%{pkgname}-%{version}.gem
8# Source0-md5: 04acabb6a1da7271a1505cecbea507cf
9Group: Development/Languages
10URL: http://rubytree.rubyforge.org/
11BuildRequires: rpmbuild(macros) >= 1.484
12BuildRequires: ruby >= 1:1.8.6
13BuildRequires: ruby-modules
14%{?ruby_mod_ver_requires_eq}
15#BuildArch: noarch
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18# nothing to be placed there. we're not noarch only because of ruby packaging
19%define _enable_debug_packages 0
20
21%description
0196d995
JR
22RubyTree is a Ruby implementation of the generic tree data structure.
23It provides a node-based model to store keyed node-elements in the
24tree and simple APIs to access, modify and traverse the structure.
25RubyTree is node-centric, where individual nodes on the tree are the
26primary compositional and structural elements. This implementation
27also mixes in the Enumerable module to allow standard access to the
28tree as a collection.
1487b78a
JR
29
30%package rdoc
31Summary: HTML documentation for %{pkgname}
32Summary(pl.UTF-8): Dokumentacja w formacie HTML dla %{pkgname}
33Group: Documentation
34Requires: ruby >= 1:1.8.7-4
35
36%description rdoc
37HTML documentation for %{pkgname}.
38
39%description rdoc -l pl.UTF-8
40Dokumentacja w formacie HTML dla %{pkgname}.
41
42%package ri
43Summary: ri documentation for %{pkgname}
44Summary(pl.UTF-8): Dokumentacja w formacie ri dla %{pkgname}
45Group: Documentation
46Requires: ruby
47
48%description ri
49ri documentation for %{pkgname}.
50
51%description ri -l pl.UTF-8
52Dokumentacji w formacie ri dla %{pkgname}.
53
54%prep
55%setup -q -c
56%{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
57find -newer README -o -print | xargs touch --reference %{SOURCE0}
58
59%build
60rdoc --ri --op ri lib
61rdoc --op rdoc lib
62# rm -r ri/NOT_THIS_MODULE_RELATED_DIRS
63rm ri/created.rid
64
65%install
66rm -rf $RPM_BUILD_ROOT
67install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
68
69cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
70cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
71cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%files
77%defattr(644,root,root,755)
78%doc ChangeLog History.txt README TODO
79%{ruby_rubylibdir}/tree.rb
80%{ruby_rubylibdir}/tree
81
82%files rdoc
83%defattr(644,root,root,755)
84%{ruby_rdocdir}/%{name}-%{version}
85
86%files ri
87%defattr(644,root,root,755)
88%{ruby_ridir}/Tree
This page took 0.0558 seconds and 4 git commands to generate.