]> git.pld-linux.org Git - packages/ruby-rspec-expectations.git/blame - ruby-rspec-expectations.spec
rebuild with gemspec provides
[packages/ruby-rspec-expectations.git] / ruby-rspec-expectations.spec
CommitLineData
52931357
ER
1#
2# Conditional build:
52931357 3%bcond_without tests # build without tests
91ccb939 4# test needs rspec-core, however rspec-core depends on rspec-mocks
52931357
ER
5# runtime part of rspec-mocks does not depend on rspec-core
6
a7fe20cc 7%define pkgname rspec-expectations
52931357 8Summary: Rspec-2 expectations (should and matchers)
8e310de3 9Summary(pl.UTF-8): Oczekiwania Rspec-2 (should oraz matchers)
a7fe20cc 10Name: ruby-%{pkgname}
52931357 11Version: 2.13.0
a7fe20cc 12Release: 3
52931357
ER
13License: MIT
14Group: Development/Languages
a7fe20cc 15Source0: http://rubygems.org/gems/%{pkgname}-%{version}.gem
52931357
ER
16# Source0-md5: 2873d31ef1f8f65d3a04ac40e27825a1
17URL: http://github.com/rspec/rspec-expectations
18BuildRequires: rpm-rubyprov
19BuildRequires: rpmbuild(macros) >= 1.656
05967f06 20%if %{with tests}
52931357
ER
21BuildRequires: ruby-minitest
22BuildRequires: ruby-rspec
23%endif
24Requires: ruby-diff-lcs
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29rspec-expectations adds `should` and `should_not` to every object and
30includes RSpec::Matchers, a library of standard matchers.
31
8e310de3
JB
32%description -l pl.UTF-8
33rspec-expectations dodaje `should` oraz `should_not` do każdego
34obiektu oraz zawiera RSpec::Matchers - bibliotekę standardowych
35funkcji dopasowujących.
52931357 36
52931357 37%prep
a7fe20cc 38%setup -q -n %{pkgname}-%{version}
52931357 39
52931357 40%build
a7fe20cc
ER
41# write .gemspec
42%__gem_helper spec
43
52931357
ER
44%if %{with tests}
45ruby -rubygems -Ilib/ -S rspec spec/
46%endif
47
48%install
49rm -rf $RPM_BUILD_ROOT
a7fe20cc 50install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
52931357 51cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
a7fe20cc 52cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
52931357
ER
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files
58%defattr(644,root,root,755)
59%doc README.md Changelog.md License.txt
60%{ruby_vendorlibdir}/rspec-expectations.rb
61%{ruby_vendorlibdir}/rspec/matchers.rb
62%{ruby_vendorlibdir}/rspec/matchers
63%{ruby_vendorlibdir}/rspec/expectations.rb
64%{ruby_vendorlibdir}/rspec/expectations
a7fe20cc 65%{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.059568 seconds and 4 git commands to generate.