]> git.pld-linux.org Git - packages/ruby-rest-client.git/blame - ruby-rest-client.spec
- rebuild for ruby 2.0
[packages/ruby-rest-client.git] / ruby-rest-client.spec
CommitLineData
74ff2d9a
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
5%define gem_name rest-client
6Summary: Simple REST client for Ruby
7Name: ruby-%{gem_name}
8Version: 1.6.7
63951f65 9Release: 2
74ff2d9a
ER
10License: MIT
11Group: Development/Languages
12Source0: http://gems.rubyforge.org/gems/%{gem_name}-%{version}.gem
13# Source0-md5: 1f2d6b3b6ceb88e3ee2b327f5e508c22
14URL: http://github.com/archiloque/rest-client
15BuildRequires: rpm-rubyprov
16BuildRequires: rpmbuild(macros) >= 1.656
17%if %{with tests}
18BuildRequires: ruby-mime-types >= 1.16
19BuildRequires: ruby-netrc
20BuildRequires: ruby-rspec
21BuildRequires: ruby-webmock >= 0.9.1
22%endif
23Requires: ruby-mime-types >= 1.16
24Requires: ruby-netrc
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29A simple Simple HTTP and REST client for Ruby, inspired by the Sinatra
30microframework style of specifying actions: get, put, post, delete.
31
32%prep
33%setup -q -n %{gem_name}-%{version}
34
35%build
36%if %{with tests}
37# TODO: According to comment in %%{PATCH0}, at least one test does not passes on
38# R1.9.3. I gon't go to investigate further ATM.
39rspec spec | grep -e "188 examples, [34] failures"
40%endif
41
42%install
43rm -rf $RPM_BUILD_ROOT
44install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
45cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
46cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%files
52%defattr(644,root,root,755)
53%doc README.rdoc history.md
54%attr(755,root,root) %{_bindir}/restclient
55%{ruby_vendorlibdir}/rest-client.rb
56%{ruby_vendorlibdir}/rest_client.rb
57%{ruby_vendorlibdir}/restclient.rb
58%{ruby_vendorlibdir}/restclient
This page took 0.097229 seconds and 4 git commands to generate.