]> git.pld-linux.org Git - packages/ruby-mixlib-config.git/blame - ruby-mixlib-config.spec
rel 1
[packages/ruby-mixlib-config.git] / ruby-mixlib-config.spec
CommitLineData
f9f2d55b
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
1e41923d
ER
5%define pkgname mixlib-config
6Summary: Simple ruby config mix-in
7Name: ruby-%{pkgname}
8c126815 8Version: 2.0.0
c6a96222 9Release: 1
1e41923d
ER
10License: Apache v2.0
11Group: Development/Languages
12Source0: http://gems.rubyforge.org/gems/%{pkgname}-%{version}.gem
8c126815 13# Source0-md5: 95a69a41f70d5f0c64a93bbc982df7a9
1e41923d
ER
14# Silence verbose test output. Fixed upstream in master but not yet released
15# https://github.com/opscode/mixlib-config/commit/fa42def234f3a2d69229340733131b93a887be8d
16Patch0: mixlib-config-silence-tests.patch
17URL: http://github.com/opscode/mixlib-config
18BuildRequires: rpm-rubyprov
f9f2d55b 19BuildRequires: rpmbuild(macros) >= 1.665
8c126815
ER
20%if %{with tests}
21BuildRequires: ruby-rspec
22%endif
1e41923d
ER
23BuildArch: noarch
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27A class based config mix-in, similar to the one found in Chef.
28
29%package doc
30Summary: Documentation for %{name}
31Group: Documentation
32Requires: %{name} = %{version}-%{release}
33
34%description doc
35This package contains documentation for %{name}.
36
37%prep
38%setup -q
39
40%build
f9f2d55b
ER
41%__gem_helper spec
42
1e41923d
ER
43%if %{with tests}
44rspec
45%endif
46
47%install
48rm -rf $RPM_BUILD_ROOT
f9f2d55b 49install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
1e41923d 50cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
f9f2d55b 51cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
1e41923d
ER
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(644,root,root,755)
8c126815 58%doc README.md NOTICE
1e41923d 59%{ruby_vendorlibdir}/mixlib/config.rb
8c126815 60%{ruby_vendorlibdir}/mixlib/config
f9f2d55b 61%{ruby_specdir}/%{pkgname}-%{version}.gemspec
1e41923d
ER
62
63# FIXME, who owns the dir?
64%dir %{ruby_vendorlibdir}/mixlib
This page took 0.093664 seconds and 4 git commands to generate.