]> git.pld-linux.org Git - packages/ruby-listen.git/blame - ruby-listen.spec
up to 2.7.11
[packages/ruby-listen.git] / ruby-listen.spec
CommitLineData
12d31bac
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
5%define pkgname listen
6Summary: Listen to file modifications
7Name: ruby-%{pkgname}
41f79f5a 8Version: 2.7.11
2c8bc52a 9Release: 1
12d31bac
ER
10License: MIT
11Group: Development/Languages
c3397968 12Source0: https://github.com/guard/listen/archive/v%{version}/%{pkgname}-%{version}.tar.gz
41f79f5a 13# Source0-md5: 2b1378df84cd0e5ab94d172c3a92d70d
12d31bac
ER
14Patch0: deps.patch
15URL: https://github.com/guard/listen
16BuildRequires: rpm-rubyprov
17BuildRequires: rpmbuild(macros) >= 1.656
18%if %{with tests}
2c8bc52a
ER
19BuildRequires: ruby-bundler >= 1.3.5
20BuildRequires: ruby-rake
21BuildRequires: ruby-rspec >= 2.14
22BuildRequires: ruby-rspec-retry
12d31bac 23%endif
2c8bc52a
ER
24Requires: ruby-celluloid >= 0.15.2
25Requires: ruby-celluloid-io >= 0.15.0
12d31bac
ER
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30The Listen gem listens to file modifications and notifies you about
31the changes. Works everywhere!
32
33%prep
c3397968
ER
34%setup -q -n %{pkgname}-%{version}
35%patch0 -p1
12d31bac
ER
36
37%build
c3397968
ER
38# make gemspec self-contained
39ruby -r rubygems -e 'spec = eval(File.read("%{pkgname}.gemspec"))
40 File.open("%{pkgname}-%{version}.gemspec", "w") do |file|
41 file.puts spec.to_ruby_for_cache
42end'
50949763 43
12d31bac
ER
44%if %{with tests}
45rspec spec
46%endif
47
48%install
49rm -rf $RPM_BUILD_ROOT
50949763 50install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
12d31bac 51cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
50949763 52cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
12d31bac
ER
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files
58%defattr(644,root,root,755)
59%doc README.md CHANGELOG.md
60%{ruby_vendorlibdir}/%{pkgname}.rb
61%{ruby_vendorlibdir}/%{pkgname}
50949763 62%{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.07422 seconds and 4 git commands to generate.