]> git.pld-linux.org Git - packages/ruby-hashicorp-checkpoint.git/blame - ruby-hashicorp-checkpoint.spec
- release 2 (by relup.sh)
[packages/ruby-hashicorp-checkpoint.git] / ruby-hashicorp-checkpoint.spec
CommitLineData
17fe6e10
ER
1#
2# Conditional build:
3%bcond_with tests # tests. requires RSpec3
4
5%define pkgname hashicorp-checkpoint
6Summary: Internal HashiCorp service to check version information
7Name: ruby-%{pkgname}
dff182cf 8Version: 0.1.5
70ea144a 9Release: 2
17fe6e10
ER
10License: MPL v2.0
11Group: Development/Languages
12Source0: http://rubygems.org/downloads/%{pkgname}-%{version}.gem
dff182cf 13# Source0-md5: b0a723177d1485a5d4538270ff77ca09
17fe6e10
ER
14URL: http://www.hashicorp.com
15BuildRequires: rpm-rubyprov
16BuildRequires: rpmbuild(macros) >= 1.656
17%if %{with tests}
18BuildRequires: ruby-bundler < 2
19BuildRequires: ruby-bundler >= 1.6
20BuildRequires: ruby-rake
21BuildRequires: ruby-rspec < 3.1
22BuildRequires: ruby-rspec >= 3.0.0
23BuildRequires: ruby-rspec-its < 1.1
24BuildRequires: ruby-rspec-its >= 1.0.0
25%endif
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30Internal HashiCorp service to check version information.
31
32%prep
33%setup -q -n %{pkgname}-%{version}
34
35%build
36# write .gemspec
37%__gem_helper spec
38
39%if %{with tests}
40rspec spec
41%endif
42
43%install
44rm -rf $RPM_BUILD_ROOT
45install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
46cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
47cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52%files
53%defattr(644,root,root,755)
54%doc README.md LICENSE.txt
55%{ruby_vendorlibdir}/checkpoint.rb
56%{ruby_vendorlibdir}/checkpoint
57%{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.092235 seconds and 4 git commands to generate.