]> git.pld-linux.org Git - packages/ruby-celluloid.git/blame - ruby-celluloid.spec
rebuild with gemspec deps
[packages/ruby-celluloid.git] / ruby-celluloid.spec
CommitLineData
2677b4f5
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
5%define pkgname celluloid
6Summary: Actor-based concurrent object framework for Ruby
7Name: ruby-%{pkgname}
763b7e22 8Version: 0.15.2
b45592ec 9Release: 2
2677b4f5
ER
10License: MIT
11Group: Development/Languages
12Source0: http://rubygems.org/downloads/%{pkgname}-%{version}.gem
763b7e22 13# Source0-md5: ceaf6e864471fa988290bd18b69dc799
2677b4f5
ER
14URL: https://github.com/celluloid/celluloid
15BuildRequires: rpm-rubyprov
10fa8dc2 16BuildRequires: rpmbuild(macros) >= 1.665
2677b4f5
ER
17%if %{with tests}
18BuildRequires: ruby-benchmark_suite
19BuildRequires: ruby-guard-rspec
20BuildRequires: ruby-rake
21BuildRequires: ruby-rspec
22%endif
23Requires: ruby-rubygems >= 1.3.6
10fa8dc2
ER
24Requires: ruby-timers < 1.2
25Requires: ruby-timers >= 1.1.0
2677b4f5
ER
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30Celluloid enables people to build concurrent programs out of
31concurrent objects just as easily as they build sequential programs
32out of sequential objects.
33
34%prep
35%setup -q -n %{pkgname}-%{version}
36
10fa8dc2
ER
37%build
38# write .gemspec
39%__gem_helper spec
40
2677b4f5
ER
41%install
42rm -rf $RPM_BUILD_ROOT
10fa8dc2 43install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
2677b4f5 44cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
10fa8dc2 45cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
2677b4f5
ER
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%files
51%defattr(644,root,root,755)
10fa8dc2
ER
52%{ruby_vendorlibdir}/celluloid.rb
53%{ruby_vendorlibdir}/celluloid
54%{ruby_specdir}/celluloid-%{version}.gemspec
This page took 0.121617 seconds and 4 git commands to generate.