]> git.pld-linux.org Git - packages/ruby-aruba.git/blame - ruby-aruba.spec
fix package name
[packages/ruby-aruba.git] / ruby-aruba.spec
CommitLineData
4ca6e49a
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
5%define pkgname aruba
6Summary: CLI Steps for Cucumber, hand-crafted for you in Aruba
b8f5f033 7Name: ruby-%{pkgname}
4ca6e49a
ER
8Version: 0.5.2
9Release: 1
10Group: Development/Languages
11# aruba itself is MIT
12# icons in templates/images are CC-BY
13# jquery.js itself is MIT or GPLv2
14# jquery.js includes sizzle.js, which is MIT or BSD or GPLv2
15License: MIT and CC-BY and (MIT or GPLv2) and (MIT or BSD or GPLv2)
16Source0: http://rubygems.org/gems/%{pkgname}-%{version}.gem
17# Source0-md5: e048f42c74d41f6587bfdec83bec7a31
18URL: http://github.com/cucumber/aruba
19BuildRequires: rpm-rubyprov
20BuildRequires: rpmbuild(macros) >= 1.656
21%if %{with tests}
22BuildRequires: ruby-bcat >= 0.6.1
23BuildRequires: ruby-kramdown < 1
24BuildRequires: ruby-kramdown >= 0.14
25BuildRequires: ruby-rake >= 0.9.2
26BuildRequires: ruby-rspec >= 2.7.0
27%endif
28# Doesn't work with ffi 1.0.10, see https://github.com/cucumber/aruba/issues/114
29BuildConflicts: ruby-ffi = 1.0.10
30# used in one of the features
31BuildRequires: bc
32Requires: ruby-childprocess < 0.4
33Requires: ruby-childprocess >= 0.3.6
34Requires: ruby-cucumber >= 1.1.1
35Requires: ruby-rspec-expectations >= 2.7.0
36Conflicts: ruby-ffi = 1.0.10
37BuildArch: noarch
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41Aruba is Cucumber extension for Command line applications written in
42any programming language.
43
44%prep
45%setup -q -n %{pkgname}-%{version}
46
47%build
48%if %{with tests}
49cucumber
50rspec spec
51%endif
52
53%install
54rm -rf $RPM_BUILD_ROOT
55install -d $RPM_BUILD_ROOT%{ruby_vendorlibdir}
56cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
63%doc README.md History.md LICENSE
64%{ruby_vendorlibdir}/%{pkgname}.rb
65%{ruby_vendorlibdir}/%{pkgname}
This page took 0.085299 seconds and 4 git commands to generate.