]> git.pld-linux.org Git - packages/ruby-arr-pm.git/blame - ruby-arr-pm.spec
up to 0.0.10
[packages/ruby-arr-pm.git] / ruby-arr-pm.spec
CommitLineData
b24ec9cf
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
17438ad6
ER
5%define pkgname arr-pm
6Summary: RPM reader and writer library
7Name: ruby-%{pkgname}
b24ec9cf
ER
8Version: 0.0.10
9Release: 1
17438ad6
ER
10License: Apache v2.0
11Group: Development/Languages
12Source0: http://rubygems.org/downloads/%{pkgname}-%{version}.gem
b24ec9cf 13# Source0-md5: 6c23ba073b590440c37042a85e0786d3
17438ad6
ER
14URL: https://github.com/jordansissel/ruby-arr-pm
15BuildRequires: rpm-rubyprov
3ea98c3e 16BuildRequires: rpmbuild(macros) >= 1.665
b24ec9cf
ER
17%if %{with tests}
18BuildRequires: ruby-flores
19%endif
17438ad6
ER
20Requires: ruby-cabin
21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25This library allows to you to read and write rpm packages. Written in
26pure ruby because librpm is not available on all systems
27
28%prep
29%setup -q -n %{pkgname}-%{version}
30
3ea98c3e
ER
31%build
32%__gem_helper spec
33
17438ad6
ER
34%install
35rm -rf $RPM_BUILD_ROOT
3ea98c3e 36install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
17438ad6 37cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
3ea98c3e 38cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
17438ad6
ER
39
40%clean
41rm -rf $RPM_BUILD_ROOT
42
43%files
44%defattr(644,root,root,755)
45%{ruby_vendorlibdir}/%{pkgname}.rb
46%{ruby_vendorlibdir}/%{pkgname}
3ea98c3e 47%{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.201076 seconds and 4 git commands to generate.