]> git.pld-linux.org Git - packages/rubberband.git/blame - rubberband.spec
- updated to 1.9.2
[packages/rubberband.git] / rubberband.spec
CommitLineData
2508a369
JB
1#
2# Conditional build:
3%bcond_without java # JNI library
4
e291abb8 5Summary: An audio time-stretching and pitch-shifting library and utility program
ff525031 6Summary(pl.UTF-8): Biblioteka i narzędzie do rozciągania i harmonizowania dźwięku
e291abb8 7Name: rubberband
880b04f2 8Version: 1.9.2
2508a369 9Release: 1
ff525031 10License: GPL v2+
e291abb8 11Group: Applications/Sound
2508a369 12Source0: https://breakfastquay.com/files/releases/%{name}-%{version}.tar.bz2
880b04f2 13# Source0-md5: fb433216aff9c5e396052ce0f116c11e
ff525031 14Patch0: %{name}-pc.patch
6a803cf6 15URL: https://www.breakfastquay.com/rubberband/
8ef19e9b 16BuildRequires: fftw3-devel >= 3.0.0
2508a369 17%{?with_jni:BuildRequires: jdk}
e291abb8 18BuildRequires: ladspa-devel
8ef19e9b
JB
19BuildRequires: libsamplerate-devel >= 0.1.8
20BuildRequires: libsndfile-devel >= 1.0.16
21BuildRequires: libstdc++-devel >= 6:5
22BuildRequires: meson >= 0.53.0
23BuildRequires: ninja >= 1.5
ff525031 24BuildRequires: pkgconfig
8ef19e9b
JB
25BuildRequires: rpmbuild(macros) >= 1.736
26BuildRequires: vamp-devel >= 2.9
e291abb8 27Requires: %{name}-libs = %{version}-%{release}
8ef19e9b 28Requires: libsndfile >= 1.0.16
e291abb8
SS
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32Rubber Band is a library and utility program that permits you to
33change the tempo and pitch of an audio recording independently of one
34another.
35
50242447 36%description -l pl.UTF-8
ff525031
JB
37Rubber Band to biblioteka i program narzędziowy, który pozwala na
38zmianę tempa i wysokości tonu nagrywanego dźwięku niezależnie.
50242447 39
e291abb8 40%package libs
ff525031
JB
41Summary: Shared rubberband library
42Summary(pl.UTF-8): Biblioteka współdzielona rubberband
e291abb8 43Group: Libraries
8ef19e9b 44Requires: libsamplerate >= 0.1.8
e291abb8
SS
45
46%description libs
ff525031 47Shared rubberband library.
e291abb8
SS
48
49%description libs -l pl.UTF-8
ff525031 50Biblioteka współdzielona rubberband.
e291abb8
SS
51
52%package devel
53Summary: Header files for rubberband library
54Summary(pl.UTF-8): Pliki nagłówkowe biblioteki rubberband
55Group: Development/Libraries
56Requires: %{name}-libs = %{version}-%{release}
8ef19e9b 57Requires: libsamplerate-devel >= 0.1.8
e291abb8
SS
58
59%description devel
60Header files for rubberband library.
61
62%description devel -l pl.UTF-8
63Pliki nagłówkowe biblioteki rubberband.
64
65%package static
66Summary: Static rubberband library
67Summary(pl.UTF-8): Statyczna biblioteka rubberband
68Group: Development/Libraries
69Requires: %{name}-devel = %{version}-%{release}
70
71%description static
72Static rubberband library.
73
74%description static -l pl.UTF-8
75Statyczna biblioteka rubberband.
76
2508a369
JB
77%package -n java-rubberband
78Summary: Java JNI interface for rubberband
79Summary(pl.UTF-8): Interfejs Javy JNI do rubberband
80Group: Libraries/Java
81Requires: jre
8ef19e9b 82Requires: libsamplerate >= 0.1.8
2508a369
JB
83
84%description -n java-rubberband
85Java JNI interface for rubberband.
86
87%description -n java-rubberband -l pl.UTF-8
88Interfejs Javy JNI do rubberband.
89
e291abb8 90%package -n ladspa-rubberband-plugins
ff525031
JB
91Summary: rubberband LADSPA plugin
92Summary(pl.UTF-8): Wtyczka LADSPA rubberband
e291abb8 93Group: Applications/Sound
ff525031 94Requires: ladspa-common
8ef19e9b 95Requires: libsamplerate >= 0.1.8
e291abb8
SS
96
97%description -n ladspa-rubberband-plugins
ff525031
JB
98rubberband LADSPA plugin.
99
100%description -n ladspa-rubberband-plugins -l pl.UTF-8
101Wtyczka LADSPA rubberband.
e291abb8
SS
102
103%package -n vamp-plugins-rubberband
ff525031
JB
104Summary: rubberband Vamp plugin
105Summary(pl.UTF-8): Wtyczka Vamp rubberband
e291abb8 106Group: Applications/Sound
8ef19e9b
JB
107Requires: libsamplerate >= 0.1.8
108Requires: vamp >= 2.9
e291abb8
SS
109
110%description -n vamp-plugins-rubberband
ff525031
JB
111rubberband Vamp plugin.
112
113%description -n vamp-plugins-rubberband -l pl.UTF-8
114Wtyczka Vamp rubberband.
e291abb8
SS
115
116%prep
117%setup -q
ff525031 118%patch0 -p1
e291abb8
SS
119
120%build
8ef19e9b
JB
121%meson build \
122 %{?with_java:-Dextra_include_dirs="%{_jvmdir}/java/include,%{_jvmdir}/java/include/linux"}
123
124%ninja_build -C build
e291abb8
SS
125
126%install
127rm -rf $RPM_BUILD_ROOT
128
8ef19e9b 129%ninja_install -C build
e291abb8 130
2508a369
JB
131%if %{with java}
132install -d $RPM_BUILD_ROOT%{_javadir}
8ef19e9b 133cp -p build/rubberband.jar $RPM_BUILD_ROOT%{_javadir}
2508a369
JB
134%endif
135
e291abb8
SS
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%post libs -p /sbin/ldconfig
140%postun libs -p /sbin/ldconfig
141
2508a369
JB
142%post -n java-rubberband -p /sbin/ldconfig
143%postun -n java-rubberband -p /sbin/ldconfig
144
e291abb8
SS
145%files
146%defattr(644,root,root,755)
6a803cf6 147%doc CHANGELOG README.md
346f97e8 148%attr(755,root,root) %{_bindir}/rubberband
e291abb8
SS
149
150%files libs
151%defattr(644,root,root,755)
152%attr(755,root,root) %{_libdir}/librubberband.so.*.*.*
5abf6277 153%attr(755,root,root) %ghost %{_libdir}/librubberband.so.2
e291abb8
SS
154
155%files devel
156%defattr(644,root,root,755)
346f97e8 157%attr(755,root,root) %{_libdir}/librubberband.so
8ef19e9b 158%{_includedir}/rubberband
e291abb8
SS
159%{_pkgconfigdir}/rubberband.pc
160
161%files static
162%defattr(644,root,root,755)
346f97e8 163%{_libdir}/librubberband.a
e291abb8 164
2508a369
JB
165%if %{with java}
166%files -n java-rubberband
167%defattr(644,root,root,755)
168%attr(755,root,root) %{_libdir}/librubberband-jni.so
169%{_javadir}/rubberband.jar
170%endif
171
e291abb8
SS
172%files -n ladspa-rubberband-plugins
173%defattr(644,root,root,755)
346f97e8 174%attr(755,root,root) %{_libdir}/ladspa/ladspa-rubberband.so
e291abb8 175%{_libdir}/ladspa/ladspa-rubberband.cat
e291abb8
SS
176%{_datadir}/ladspa/rdf/ladspa-rubberband.rdf
177
178%files -n vamp-plugins-rubberband
179%defattr(644,root,root,755)
346f97e8 180%attr(755,root,root) %{_libdir}/vamp/vamp-rubberband.so
e291abb8 181%{_libdir}/vamp/vamp-rubberband.cat
This page took 0.117522 seconds and 4 git commands to generate.