]> git.pld-linux.org Git - packages/roundcubemail.git/blame - roundcubemail.spec
- tabs in preamble
[packages/roundcubemail.git] / roundcubemail.spec
CommitLineData
600b6f8b 1# TODO:
600b6f8b
PG
2# - prepare config for lighttp
3# - add logrotate file
4# - it has PEAR boundled inside - use system ones
32abe254 5# - use pear-deps system?
32abe254 6# - package: http://blog.ilohamail.org/ and remove boundled classess from it
600b6f8b 7#
a1b7722e
8#define _svn svn445
9%define _snap 20070108
911123ab 10#define _beta beta2
a1b7722e 11%define _rel 1
600b6f8b 12Summary: RoundCube Webmail
07c0744d 13Summary(pl.UTF-8): RoundCube Webmail - poczta przez WWW
600b6f8b
PG
14Name: roundcubemail
15Version: 0.1
a1b7722e 16Release: 4.%{?_svn}%{?_snap}%{?_beta}.%{_rel}
600b6f8b
PG
17License: GPL v2
18Group: Applications/WWW
911123ab 19#Source0: http://dl.sourceforge.net/roundcubemail/%{name}-%{version}%{_beta}.tar.gz
a1b7722e
20#Source0: %{name}-%{version}%{_svn}.tar.bz2
21Source0: http://dl.sourceforge.net/roundcubemail/%{name}-nightly-%{_snap}.tar.gz
22# Source0-md5: 8e96ba85239c8cf3344c8f230ba30532
32abe254 23Source1: %{name}.config
600b6f8b
PG
24Patch0: %{name}-config.patch
25URL: http://www.roundcube.net/
26BuildRequires: rpmbuild(macros) >= 1.268
e06157c8 27Requires: php(pcre)
32abe254 28# Some php-database backend. Suggests?
836a6bed 29# php-sockets is required to make spellcheck working
600b6f8b
PG
30Requires: webapps
31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%define _webapps /etc/webapps
5737afb2 35%define _webapp roundcube
600b6f8b
PG
36%define _sysconfdir %{_webapps}/%{_webapp}
37%define _appdir %{_datadir}/%{_webapp}
38%define _appdatadir /var/lib/roundcube
8f3a4fab 39%define _applogdir /var/log/roundcube
600b6f8b
PG
40
41%description
42RoundCube Webmail is a browser-based multilingual IMAP client with an
43application-like user interface. It provides full functionality you
44expect from an e-mail client, including MIME support, address book,
45folder manipulation and message filters. RoundCube Webmail is written
46in PHP and requires the MySQL database. The user interface is fully
47skinnable using XHTML and CSS 2.
48
d9bffeff
JR
49%description -l pl.UTF-8
50RoundCube Webmail to oparty na przeglądarce wielojęzyczny klient PHP z
51interfejsem użytkownika podobnym do aplikacji. Udostępnia pełną
52funkcjonalność jakiej można oczekiwać od klienta pocztowego, w tym
53obsługę MIME, książkę adresową, operacje na folderach i filtry
54wiadomości. RoundCube Webmail jest napisany w PHP i wymaga bazy danych
55MySQL. Interfejs użytkownika można w pełni obudować skórką przy użyciu
5d23c484
JB
56XHTML-a i CSS 2.
57
600b6f8b 58%prep
5babd4c9 59%setup -q -n %{name}-%{?_snap:nightly-%{_snap}}%{!?_snap:%{version}%{?_svn}%{?_beta}}
600b6f8b
PG
60%patch0 -p1
61
5737afb2
ER
62find -name .svn | xargs -r rm -rf
63
600b6f8b
PG
64%install
65rm -rf $RPM_BUILD_ROOT
8f3a4fab 66install -d $RPM_BUILD_ROOT{%{_appdatadir},%{_applogdir},%{_sysconfdir}} \
600b6f8b
PG
67 $RPM_BUILD_ROOT%{_appdir}/{config,program,skins}
68
69# Main application part:
70cp -R program/* $RPM_BUILD_ROOT%{_appdir}/program
7e88f091 71install index.php $RPM_BUILD_ROOT%{_appdir}
600b6f8b
PG
72
73# Skins installation (maybe it should be as config??)
74cp -R skins/* $RPM_BUILD_ROOT%{_appdir}/skins
75
76## Configuration:
77install config/db.inc.php.dist $RPM_BUILD_ROOT%{_sysconfdir}/db.inc.php
78install config/main.inc.php.dist $RPM_BUILD_ROOT%{_sysconfdir}/main.inc.php
79ln -sf %{_sysconfdir}/db.inc.php $RPM_BUILD_ROOT%{_appdir}/config/db.inc.php
80ln -sf %{_sysconfdir}/main.inc.php $RPM_BUILD_ROOT%{_appdir}/config/main.inc.php
81
32abe254
PG
82install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
83install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
84
5d23c484
JB
85%clean
86rm -rf $RPM_BUILD_ROOT
87
4fddc0f8 88%triggerin -- apache1 < 1.3.37-3, apache1-base
600b6f8b
PG
89%webapp_register apache %{_webapp}
90
4fddc0f8 91%triggerun -- apache1 < 1.3.37-3, apache1-base
600b6f8b
PG
92%webapp_unregister apache %{_webapp}
93
94%triggerin -- apache < 2.2.0, apache-base
95%webapp_register httpd %{_webapp}
96
97%triggerun -- apache < 2.2.0, apache-base
98%webapp_unregister httpd %{_webapp}
99
600b6f8b
PG
100%files
101%defattr(644,root,root,755)
102%doc CHANGELOG INSTALL README UPGRADING SQL
103%dir %attr(750,root,http) %{_sysconfdir}
32abe254
PG
104%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
105%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
600b6f8b
PG
106%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
107%dir %{_appdir}
7e88f091 108%{_appdir}/*.php
600b6f8b
PG
109%dir %{_appdir}/config
110%{_appdir}/config/*.php
111%dir %{_appdir}/program
112%{_appdir}/program/*
113%dir %{_appdir}/skins
114%{_appdir}/skins/default
8f3a4fab 115%dir %attr(770,root,http) %{_applogdir}
600b6f8b 116%dir %attr(770,root,http) %{_appdatadir}
8f3a4fab 117# %ghost logfile
This page took 0.043923 seconds and 4 git commands to generate.