]> git.pld-linux.org Git - packages/robin-map.git/blame - robin-map.spec
- updated to 0.6.3
[packages/robin-map.git] / robin-map.spec
CommitLineData
9a4928aa 1Summary: A C++ implementation of a fast hash map and hash set using robin hood hashing
df4bf2bd 2Summary(pl.UTF-8): Implementacja C++ szybkiej tablicy asocjacyjnej i zbioru wykorzytujących haszowanie robin hood
9a4928aa 3Name: robin-map
a629c552 4Version: 0.6.3
9b6d243d 5Release: 1
9a4928aa
JR
6License: MIT
7Group: Libraries
e9242af9 8#Source0Download: https://github.com/Tessil/robin-map/releases
9a4928aa 9Source0: https://github.com/Tessil/robin-map/archive/v%{version}/%{name}-%{version}.tar.gz
a629c552 10# Source0-md5: e6a362bff8372bbb4d901d2e28993a8a
9a4928aa 11URL: https://github.com/Tessil/robin-map
e9242af9 12BuildRequires: cmake >= 3.1
9a4928aa
JR
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15%description
16The robin-map library is a C++ implementation of a fast hash map and
17hash set using open-addressing and linear robin hood hashing with
18backward shift deletion to resolve collisions.
19
e9242af9
JB
20%description -l pl.UTF-8
21Biblioteka robin-map to implementacja C++ szybkiej tablicy
22asocjacyjnej (mapy) i zbioru wykorzystujących adresowanie otwarte i
23haszowanie robin hood z usuwaniem przez przesunięcie wstecz przy
24rozwiązywaniu kolizji.
25
9a4928aa 26%package devel
e9242af9
JB
27Summary: Header files for robin-map library
28Summary(pl.UTF-8): Pliki nagłówkowe biblioteki robin-map
9a4928aa 29Group: Development/Libraries
e9242af9 30Requires: libstdc++-devel >= 6:4.8
9a4928aa
JR
31
32%description devel
e9242af9 33Header files for robin-map library.
9a4928aa
JR
34
35The robin-map library is a C++ implementation of a fast hash map and
36hash set using open-addressing and linear robin hood hashing with
37backward shift deletion to resolve collisions.
38
39%description devel -l pl.UTF-8
e9242af9
JB
40Pliki nagłówkowe biblioteki robin-map.
41
42Biblioteka robin-map to implementacja C++ szybkiej tablicy
43asocjacyjnej (mapy) i zbioru wykorzystujących adresowanie otwarte i
44haszowanie robin hood z usuwaniem przez przesunięcie wstecz przy
45rozwiązywaniu kolizji.
9a4928aa
JR
46
47%prep
48%setup -q
49
50%build
51mkdir -p build
52cd build
e9242af9 53%cmake ..
9a4928aa
JR
54%{__make}
55
56%install
57rm -rf $RPM_BUILD_ROOT
58
59%{__make} -C build install \
60 DESTDIR=$RPM_BUILD_ROOT
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files devel
66%defattr(644,root,root,755)
e9242af9 67%doc LICENSE README.md
9a4928aa
JR
68%dir %{_includedir}/tsl
69%{_includedir}/tsl/robin*.h
70%{_datadir}/cmake/tsl-robin-map
This page took 0.106825 seconds and 4 git commands to generate.