]> git.pld-linux.org Git - packages/rest.git/blame - rest.spec
- updated to 0.8.0 (still API 0.7)
[packages/rest.git] / rest.spec
CommitLineData
a0729406
MB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4%bcond_without static_libs # don't build static libraries
534f5ac1 5
a0729406 6%define apiver 0.7
a0729406 7Summary: A library for access to RESTful web services
e4f3e6ef 8Summary(pl.UTF-8): Biblioteka dostępu do REST-owych serwisów WWW
a0729406 9Name: rest
fd5eb743 10Version: 0.8.0
c0229fb2 11Release: 1
a0729406
MB
12License: LGPL v2
13Group: Libraries
fd5eb743
JB
14Source0: http://ftp.gnome.org/pub/GNOME/sources/rest/0.8/%{name}-%{version}.tar.xz
15# Source0-md5: 07ae736561aab03ee9bdd451445926ba
a0729406
MB
16URL: http://www.gnome.org/
17BuildRequires: autoconf >= 2.63
18BuildRequires: automake >= 1:1.11
023ec758 19BuildRequires: glib2-devel >= 1:2.24
a0729406
MB
20BuildRequires: gobject-introspection-devel >= 0.6.7
21BuildRequires: gtk-doc >= 1.13
22BuildRequires: libsoup-gnome-devel >= 2.26.0
23BuildRequires: libtool >= 2:2.2.6
023ec758 24BuildRequires: libxml2-devel >= 2
a0729406 25BuildRequires: pkgconfig
5ea56938
MB
26BuildRequires: tar >= 1:1.22
27BuildRequires: xz
023ec758 28Requires: glib2 >= 1:2.24
6558a390
JB
29Requires: libsoup-gnome >= 2.26.0
30Suggests: ca-certificates
a0729406
MB
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
e4f3e6ef
JB
34This library was designed to make it easier to access web services
35that claim to be "RESTful". A RESTful service should have URLs that
36represent remote objects, which methods can then be called on. The
37majority of services don't actually adhere to this strict definition.
38Instead, their RESTful end point usually has an API that is just
39simpler to use compared to other types of APIs they may support
40(XML-RPC, for instance). It is this kind of API that this library is
41attempting to support.
42
43%description -l pl.UTF-8
44Ta biblioteka została zaprojektowana, aby ułatwić dostęp do serwisów
45WWW, które uznają się za "REST-owe". Serwis REST-owy powinien mieć
46URL-e reprezentujące zdalne obiekty, na których można wywoływać
47metody. Większość serwisów nie jest w pełni zgodna z tą definicją, ale
48ich REST-owy interfejs zwykle ma API prostsze od innych (np. XML-RPC).
49Ten rodzaj API próbuje obsłużyć ta biblioteka.
a0729406
MB
50
51%package devel
52Summary: Header files for rest library
53Summary(pl.UTF-8): Pliki nagłówkowe biblioteki rest
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
023ec758 56Requires: glib2-devel >= 1:2.24
a0729406 57Requires: libsoup-devel >= 2.26.0
023ec758 58Requires: libxml2-devel >= 2
a0729406
MB
59
60%description devel
61Header files for rest library.
62
63%description devel -l pl.UTF-8
64Pliki nagłówkowe biblioteki rest.
65
66%package static
67Summary: Static rest library
68Summary(pl.UTF-8): Statyczna biblioteka rest
69Group: Development/Libraries
70Requires: %{name}-devel = %{version}-%{release}
71
72%description static
73Static rest library.
74
75%description static -l pl.UTF-8
76Statyczna biblioteka rest.
77
78%package apidocs
79Summary: rest API documentation
80Summary(pl.UTF-8): Dokumentacja API biblioteki rest
81Group: Documentation
534f5ac1
ER
82%if "%{_rpmversion}" >= "5"
83BuildArch: noarch
84%endif
a0729406
MB
85
86%description apidocs
87API documentation for rest library.
88
89%description apidocs -l pl.UTF-8
90Dokumentacja API biblioteki rest.
91
92%prep
93%setup -q
94
95%build
96%{__libtoolize}
97%{__aclocal}
98%{__autoconf}
99%{__autoheader}
100%{__automake}
101%configure \
102 --disable-silent-rules \
103 %{__enable_disable apidocs gtk-doc} \
104 %{__enable_disable static_libs static} \
c15f5f10
ŁK
105 --with-html-dir=%{_gtkdocdir} \
106 --with-ca-certificates=/etc/certs/ca-certificates.crt
a0729406
MB
107%{__make}
108
109%install
110rm -rf $RPM_BUILD_ROOT
a0729406
MB
111%{__make} install \
112 DESTDIR=$RPM_BUILD_ROOT
113
114%{!?with_apidocs:%{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}}
115%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post -p /sbin/ldconfig
121%postun -p /sbin/ldconfig
122
123%files
124%defattr(644,root,root,755)
023ec758 125%doc AUTHORS README
a0729406
MB
126%attr(755,root,root) %{_libdir}/librest-%{apiver}.so.*.*.*
127%attr(755,root,root) %ghost %{_libdir}/librest-%{apiver}.so.0
128%attr(755,root,root) %{_libdir}/librest-extras-%{apiver}.so.*.*.*
129%attr(755,root,root) %ghost %{_libdir}/librest-extras-%{apiver}.so.0
130%{_libdir}/girepository-1.0/Rest-0.7.typelib
131%{_libdir}/girepository-1.0/RestExtras-0.7.typelib
132
133%files devel
134%defattr(644,root,root,755)
135%attr(755,root,root) %{_libdir}/librest-%{apiver}.so
136%attr(755,root,root) %{_libdir}/librest-extras-%{apiver}.so
137%{_datadir}/gir-1.0/Rest-%{apiver}.gir
138%{_datadir}/gir-1.0/RestExtras-%{apiver}.gir
139%{_includedir}/rest-%{apiver}
140%{_pkgconfigdir}/rest-%{apiver}.pc
141%{_pkgconfigdir}/rest-extras-%{apiver}.pc
142
143%if %{with static_libs}
144%files static
145%defattr(644,root,root,755)
146%{_libdir}/librest-%{apiver}.a
147%{_libdir}/librest-extras-%{apiver}.a
148%endif
149
150%if %{with apidocs}
151%files apidocs
152%defattr(644,root,root,755)
153%{_gtkdocdir}/rest-%{apiver}
154%endif
This page took 0.108598 seconds and 4 git commands to generate.