]> git.pld-linux.org Git - packages/rest1.git/blame - rest.spec
- updated to 0.7.91
[packages/rest1.git] / rest.spec
CommitLineData
a0729406
MB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4%bcond_without static_libs # don't build static libraries
5#
6%define apiver 0.7
7#
8Summary: A library for access to RESTful web services
e4f3e6ef 9Summary(pl.UTF-8): Biblioteka dostępu do REST-owych serwisów WWW
a0729406 10Name: rest
5d1b0a81 11Version: 0.7.91
a0729406
MB
12Release: 1
13License: LGPL v2
14Group: Libraries
5ea56938 15Source0: http://ftp.gnome.org/pub/GNOME/sources/rest/0.7/%{name}-%{version}.tar.xz
5d1b0a81 16# Source0-md5: abd6211788b9b8dac432a26767099a27
a0729406
MB
17URL: http://www.gnome.org/
18BuildRequires: autoconf >= 2.63
19BuildRequires: automake >= 1:1.11
023ec758 20BuildRequires: glib2-devel >= 1:2.24
a0729406
MB
21BuildRequires: gobject-introspection-devel >= 0.6.7
22BuildRequires: gtk-doc >= 1.13
23BuildRequires: libsoup-gnome-devel >= 2.26.0
24BuildRequires: libtool >= 2:2.2.6
023ec758 25BuildRequires: libxml2-devel >= 2
a0729406 26BuildRequires: pkgconfig
5ea56938
MB
27BuildRequires: tar >= 1:1.22
28BuildRequires: xz
023ec758 29Requires: glib2 >= 1:2.24
6558a390
JB
30Requires: libsoup-gnome >= 2.26.0
31Suggests: ca-certificates
a0729406
MB
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
e4f3e6ef
JB
35This library was designed to make it easier to access web services
36that claim to be "RESTful". A RESTful service should have URLs that
37represent remote objects, which methods can then be called on. The
38majority of services don't actually adhere to this strict definition.
39Instead, their RESTful end point usually has an API that is just
40simpler to use compared to other types of APIs they may support
41(XML-RPC, for instance). It is this kind of API that this library is
42attempting to support.
43
44%description -l pl.UTF-8
45Ta biblioteka została zaprojektowana, aby ułatwić dostęp do serwisów
46WWW, które uznają się za "REST-owe". Serwis REST-owy powinien mieć
47URL-e reprezentujące zdalne obiekty, na których można wywoływać
48metody. Większość serwisów nie jest w pełni zgodna z tą definicją, ale
49ich REST-owy interfejs zwykle ma API prostsze od innych (np. XML-RPC).
50Ten rodzaj API próbuje obsłużyć ta biblioteka.
a0729406
MB
51
52%package devel
53Summary: Header files for rest library
54Summary(pl.UTF-8): Pliki nagłówkowe biblioteki rest
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
023ec758 57Requires: glib2-devel >= 1:2.24
a0729406 58Requires: libsoup-devel >= 2.26.0
023ec758 59Requires: libxml2-devel >= 2
a0729406
MB
60
61%description devel
62Header files for rest library.
63
64%description devel -l pl.UTF-8
65Pliki nagłówkowe biblioteki rest.
66
67%package static
68Summary: Static rest library
69Summary(pl.UTF-8): Statyczna biblioteka rest
70Group: Development/Libraries
71Requires: %{name}-devel = %{version}-%{release}
72
73%description static
74Static rest library.
75
76%description static -l pl.UTF-8
77Statyczna biblioteka rest.
78
79%package apidocs
80Summary: rest API documentation
81Summary(pl.UTF-8): Dokumentacja API biblioteki rest
82Group: Documentation
83
84%description apidocs
85API documentation for rest library.
86
87%description apidocs -l pl.UTF-8
88Dokumentacja API biblioteki rest.
89
90%prep
91%setup -q
92
93%build
94%{__libtoolize}
95%{__aclocal}
96%{__autoconf}
97%{__autoheader}
98%{__automake}
99%configure \
100 --disable-silent-rules \
101 %{__enable_disable apidocs gtk-doc} \
102 %{__enable_disable static_libs static} \
c15f5f10
ŁK
103 --with-html-dir=%{_gtkdocdir} \
104 --with-ca-certificates=/etc/certs/ca-certificates.crt
a0729406
MB
105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110%{__make} install \
111 DESTDIR=$RPM_BUILD_ROOT
112
113%{!?with_apidocs:%{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}}
114%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
121
122%files
123%defattr(644,root,root,755)
023ec758 124%doc AUTHORS README
a0729406
MB
125%attr(755,root,root) %{_libdir}/librest-%{apiver}.so.*.*.*
126%attr(755,root,root) %ghost %{_libdir}/librest-%{apiver}.so.0
127%attr(755,root,root) %{_libdir}/librest-extras-%{apiver}.so.*.*.*
128%attr(755,root,root) %ghost %{_libdir}/librest-extras-%{apiver}.so.0
129%{_libdir}/girepository-1.0/Rest-0.7.typelib
130%{_libdir}/girepository-1.0/RestExtras-0.7.typelib
131
132%files devel
133%defattr(644,root,root,755)
134%attr(755,root,root) %{_libdir}/librest-%{apiver}.so
135%attr(755,root,root) %{_libdir}/librest-extras-%{apiver}.so
136%{_datadir}/gir-1.0/Rest-%{apiver}.gir
137%{_datadir}/gir-1.0/RestExtras-%{apiver}.gir
138%{_includedir}/rest-%{apiver}
139%{_pkgconfigdir}/rest-%{apiver}.pc
140%{_pkgconfigdir}/rest-extras-%{apiver}.pc
141
142%if %{with static_libs}
143%files static
144%defattr(644,root,root,755)
145%{_libdir}/librest-%{apiver}.a
146%{_libdir}/librest-extras-%{apiver}.a
147%endif
148
149%if %{with apidocs}
150%files apidocs
151%defattr(644,root,root,755)
152%{_gtkdocdir}/rest-%{apiver}
153%endif
This page took 0.04622 seconds and 4 git commands to generate.