]> git.pld-linux.org Git - packages/rav1e.git/blame - rav1e.spec
- updated to 0.4.1
[packages/rav1e.git] / rav1e.spec
CommitLineData
7d9459ec
JB
1Summary: The fastest and safest AV1 encoder
2Summary(pl.UTF-8): Najszybszy i najbezpieczniejszy koder AV1
3Name: rav1e
64f6d1ea 4Version: 0.4.1
7d9459ec
JB
5Release: 1
6License: BSD
7Group: Libraries
8#Source0Download: https://github.com/xiph/rav1e/releases
9Source0: https://github.com/xiph/rav1e/archive/v%{version}/%{name}-%{version}.tar.gz
64f6d1ea 10# Source0-md5: e9c3c833c33bcf1bbafbdf1dcc170e10
7d9459ec
JB
11# cd %{name}-%{version}
12# cargo vendor
13# cd ..
14# tar cJf rav1e-crates-%{version}.tar.xz %{name}-%{version}/{vendor,Cargo.lock}
15Source1: %{name}-crates-%{version}.tar.xz
64f6d1ea 16# Source1-md5: cb04c9255da1a4b5caca116652a7781e
7d9459ec
JB
17URL: https://github.com/xiph/rav1e
18BuildRequires: cargo
19BuildRequires: cargo-c
20%ifarch %{x8664}
21BuildRequires: nasm
22%endif
23BuildRequires: rust
24# for tests only?
25#BuildRequires: aom-devel
26#BuildRequires: dav1d-devel
27ExclusiveArch: %{ix86} %{x8664} aarch64
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31rav1e is an AV1 video encoder. It is designed to eventually cover all
32use cases, though in its current form it is most suitable for cases
33where libaom (the reference encoder) is too slow.
34
35%description -l pl.UTF-8
36rav1e to koder obrazu AV1. Jest projektowany, aby ewentualnie pokrywać
37wszystkie przypadki użycia, ale w obecnej postaci nadaje się najlepiej
38tam, gdzie libaom (koder referencyjny) jest zbyt wolny.
39
40%package libs
41Summary: Shared rav1e library
42Summary(pl.UTF-8): Biblioteka współdzielona rav1e
43Group: Libraries
44
45%description libs
46Shared rav1e library.
47
48%description libs -l pl.UTF-8
49Biblioteka współdzielona rav1e.
50
51%package devel
52Summary: Header files for rav1e library
53Summary(pl.UTF-8): Pliki nagłówkowe biblioteki rav1e
54Group: Development/Libraries
55Requires: %{name}-libs = %{version}-%{release}
56
57%description devel
58Header files for rav1e library.
59
60%description devel -l pl.UTF-8
61Pliki nagłówkowe biblioteki rav1e.
62
63%package static
64Summary: Static rav1e library
65Summary(pl.UTF-8): Statyczna biblioteka rav1e
66Group: Development/Libraries
67Requires: %{name}-devel = %{version}-%{release}
68
69%description static
70Static rav1e library.
71
72%description static -l pl.UTF-8
73Statyczna biblioteka rav1e.
74
75%prep
76%setup -q -b1
77
78# use our offline registry
79export CARGO_HOME="$(pwd)/.cargo"
80
81mkdir -p "$CARGO_HOME"
82cat >.cargo/config <<EOF
83[source.crates-io]
84replace-with = 'vendored-sources'
85
86[source.vendored-sources]
87directory = '$PWD/vendor'
88EOF
89
90%build
91export CARGO_HOME="$(pwd)/.cargo"
92
93cargo -v build --release --frozen
94
95cargo -v cbuild --release --frozen
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100cargo -v install --frozen --path . --root $RPM_BUILD_ROOT%{_prefix}
101
102cargo -v cinstall --frozen --release \
103 --destdir $RPM_BUILD_ROOT \
104 --prefix %{_prefix} \
105 --bindir %{_bindir} \
106 --includedir %{_includedir} \
107 --libdir %{_libdir}
108
109%{__rm} $RPM_BUILD_ROOT%{_prefix}/.crates*
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post libs -p /sbin/ldconfig
115%postun libs -p /sbin/ldconfig
116
117%files
118%defattr(644,root,root,755)
119%doc LICENSE PATENTS README.md
120%attr(755,root,root) %{_bindir}/rav1e
121
122%files libs
123%defattr(644,root,root,755)
124%doc LICENSE PATENTS README.md doc/GLOSSARY.md
125%attr(755,root,root) %{_libdir}/librav1e.so.*.*.*
126%attr(755,root,root) %ghost %{_libdir}/librav1e.so.0
127
128%files devel
129%defattr(644,root,root,755)
130%attr(755,root,root) %{_libdir}/librav1e.so
131%{_includedir}/rav1e
132%{_pkgconfigdir}/rav1e.pc
133
134%files static
135%defattr(644,root,root,755)
136%{_libdir}/librav1e.a
This page took 0.138061 seconds and 4 git commands to generate.