]> git.pld-linux.org Git - packages/rabbitmq-c.git/blame - rabbitmq-c.spec
- releases URL for download
[packages/rabbitmq-c.git] / rabbitmq-c.spec
CommitLineData
9730ef10
JB
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
4#
5Summary: RabbitMQ C AMQP client library
6Summary(pl.UTF-8): Biblioteka kliencka C RabbitMQ AMQP
7Name: rabbitmq-c
a0114413
JB
8Version: 0.10.0
9Release: 1
9730ef10
JB
10License: MIT
11Group: Libraries
568f712c 12#Source0Download: https://github.com/alanxz/rabbitmq-c/releases
a0114413
JB
13Source0: https://github.com/alanxz/rabbitmq-c/archive/v%{version}/%{name}-%{version}.tar.gz
14# Source0-md5: 6f09f0cb07cea221657a768bd9c7dff7
9730ef10 15URL: https://github.com/alanxz/rabbitmq-c
a0114413 16BuildRequires: cmake >= 2.8.12
93aca067
JB
17BuildRequires: openssl-devel >= 0.9.8
18BuildRequires: popt-devel
19BuildRequires: pkgconfig >= 1:0.17
9730ef10 20BuildRequires: xmlto
93aca067 21Requires: openssl >= 0.9.8
9730ef10
JB
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25This is a C-language AMQP client library for use with AMQP servers
26speaking protocol versions 0-9-1.
27
28%description -l pl.UTF-8
29Ten pakiet zawiera bibliotekę kliencką AMQP dla języka C, przeznaczoną
30do użycia z serwerami AMQP obsługującymi protokół w wersjach 0-9-1.
31
32%package devel
33Summary: Header files for rabbitmq-c library
34Summary(pl.UTF-8): Pliki nagłówkowe biblioteki rabbitmq-c
35Group: Development/Libraries
36Requires: %{name} = %{version}-%{release}
93aca067 37Requires: openssl-devel >= 0.9.8
9730ef10
JB
38
39%description devel
40Header files for rabbitmq-c library.
41
42%description devel -l pl.UTF-8
43Pliki nagłówkowe biblioteki rabbitmq-c.
44
45%package static
46Summary: Static rabbitmq-c library
47Summary(pl.UTF-8): Statyczna biblioteka rabbitmq-c
48Group: Development/Libraries
49Requires: %{name}-devel = %{version}-%{release}
50
51%description static
52Static rabbitmq-c library.
53
54%description static -l pl.UTF-8
55Statyczna biblioteka rabbitmq-c.
56
57%package tools
58Summary: Example tools utilizing the rabbitmq-c library
59Summary(pl.UTF-8): Przykładowe narzędzia wykorzystujące bibliotekę rabbitmq-c
60Group: Applications
61Requires: %{name} = %{version}-%{release}
62
63%description tools
64Example tools utilizing the rabbitmq-c library.
65
66%description tools -l pl.UTF-8
67Przykładowe narzędzia wykorzystujące bibliotekę rabbitmq-c.
68
69%prep
93aca067 70%setup -q
9730ef10
JB
71
72%build
a0114413
JB
73install -d build
74cd build
75%cmake .. \
76 %{!?with_static_libs:-DBUILD_STATIC_LIBS=OFF} \
77 -DBUILD_TOOLS_DOCS=ON
78
9730ef10
JB
79%{__make}
80
81%install
82rm -rf $RPM_BUILD_ROOT
83
a0114413 84%{__make} -C build install \
9730ef10
JB
85 DESTDIR=$RPM_BUILD_ROOT
86
9730ef10
JB
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91%postun -p /sbin/ldconfig
92
93%files
94%defattr(644,root,root,755)
95%doc AUTHORS CONTRIBUTING.md LICENSE-MIT README.md THANKS TODO
96%attr(755,root,root) %{_libdir}/librabbitmq.so.*.*.*
93aca067 97%attr(755,root,root) %ghost %{_libdir}/librabbitmq.so.4
9730ef10
JB
98
99%files devel
100%defattr(644,root,root,755)
101%attr(755,root,root) %{_libdir}/librabbitmq.so
102%{_includedir}/amqp.h
103%{_includedir}/amqp_framing.h
93aca067
JB
104%{_includedir}/amqp_ssl_socket.h
105%{_includedir}/amqp_tcp_socket.h
9730ef10
JB
106%{_pkgconfigdir}/librabbitmq.pc
107
108%if %{with static_libs}
109%files static
110%defattr(644,root,root,755)
111%{_libdir}/librabbitmq.a
112%endif
113
114%files tools
115%defattr(644,root,root,755)
116%attr(755,root,root) %{_bindir}/amqp-consume
117%attr(755,root,root) %{_bindir}/amqp-declare-queue
118%attr(755,root,root) %{_bindir}/amqp-delete-queue
119%attr(755,root,root) %{_bindir}/amqp-get
120%attr(755,root,root) %{_bindir}/amqp-publish
121%{_mandir}/man1/amqp-consume.1*
122%{_mandir}/man1/amqp-declare-queue.1*
123%{_mandir}/man1/amqp-delete-queue.1*
124%{_mandir}/man1/amqp-get.1*
125%{_mandir}/man1/amqp-publish.1*
126%{_mandir}/man7/librabbitmq-tools.7*
This page took 0.099791 seconds and 4 git commands to generate.