]> git.pld-linux.org Git - packages/quicklz.git/blame - quicklz.spec
update .h md5sum
[packages/quicklz.git] / quicklz.spec
CommitLineData
8d481680
ER
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
4
5Summary: Fast compression library
6Name: quicklz
7Version: 1.5.0
8Release: 1
9License: GPL v1, GPL v2, GPL v3
10Group: Libraries
11Source0: http://www.quicklz.com/%{name}.c
12# Source0-md5: 76c8722e413ee99aff2ded50ced8b666
13Source1: http://www.quicklz.com/%{name}.h
6c2852aa 14# Source1-md5: 35e9b485b15c447f8306654ed0d584de
8d481680
ER
15URL: http://www.quicklz.com/
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%define abi 0
19
20%description
21QuickLZ is the world's fastest compression library, reaching 308
22Mbyte/s per core.
23
24%package devel
25Summary: Header files for %{name} library
26Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
27Group: Development/Libraries
28Requires: %{name} = %{version}-%{release}
29
30%description devel
31Header files for %{name} library.
32
33%description devel -l pl.UTF-8
34Pliki nagłówkowe biblioteki %{name}.
35
36%package static
37Summary: Static %{name} library
38Summary(pl.UTF-8): Statyczna biblioteka %{name}
39Group: Development/Libraries
40Requires: %{name}-devel = %{version}-%{release}
41
42%description static
43Static %{name} library.
44
45%description static -l pl.UTF-8
46Statyczna biblioteka %{name}.
47
48%prep
49%setup -qcT
50cp -p %{S:0} %{S:1} .
51
52%build
53%{__cc} %{rpmcflags} -fPIC -c quicklz.c -o quicklz.o
54
55# Build the shared library
56%{__cc} %{rpmcflags} -fPIC %{rpmldflags} -shared -Wl,-soname -Wl,lib%{name}.so.%{abi} -o lib%{name}.so.%{abi} quicklz.o
57
58# Build the static library
59%if %{with static_libs}
60ar rcs lib%{name}.a quicklz.o
61%endif
62
63%install
64rm -rf $RPM_BUILD_ROOT
65install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
66
67install -p lib%{name}.so.%{abi} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.%{abi}.0.0
68ln -s lib%{name}.so.%{abi} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
69/sbin/ldconfig -n $RPM_BUILD_ROOT%{_libdir}
70cp -p %{name}.h $RPM_BUILD_ROOT%{_includedir}
71
72%if %{with static_libs}
73cp -p lib%{name}.a $RPM_BUILD_ROOT%{_libdir}
74%endif
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post -p /sbin/ldconfig
80%postun -p /sbin/ldconfig
81
82%files
83%defattr(644,root,root,755)
84%attr(755,root,root) %{_libdir}/libquicklz.so.*.*.*
85%attr(755,root,root) %ghost %{_libdir}/libquicklz.so.0
86
87%files devel
88%defattr(644,root,root,755)
89%{_includedir}/quicklz.h
90%{_libdir}/libquicklz.so
91
92%if %{with static_libs}
93%files static
94%defattr(644,root,root,755)
95%{_libdir}/libquicklz.a
96%endif
This page took 0.055039 seconds and 4 git commands to generate.