]> git.pld-linux.org Git - packages/qt5-qtwebchannel.git/blame - qt5-qtwebchannel.spec
- unconditional noarch subpackages
[packages/qt5-qtwebchannel.git] / qt5-qtwebchannel.spec
CommitLineData
1302c287
JB
1#
2# Conditional build:
a0bb59d8 3%bcond_without doc # Documentation
1302c287
JB
4
5%define orgname qtwebchannel
6%define qtbase_ver %{version}
7%define qtdeclarative_ver %{version}
8%define qttools_ver %{version}
a4e247e7 9%define qtwebsockets_ver %{version}
1302c287
JB
10Summary: The Qt5 WebChannel library
11Summary(pl.UTF-8): Biblioteka Qt5 WebChannel
12Name: qt5-%{orgname}
7cea6b49 13Version: 5.15.2
9199af96 14Release: 2
a4e247e7 15License: LGPL v3 or GPL v2 or GPL v3 or commercial
1302c287 16Group: X11/Libraries
3e984a24 17Source0: http://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
7cea6b49 18# Source0-md5: 77937260f831c0d9a68900ca10a3bff0
a4e247e7 19URL: https://www.qt.io/
1302c287
JB
20BuildRequires: Qt5Core-devel >= %{qtbase_ver}
21BuildRequires: Qt5Network-devel >= %{qtbase_ver}
22BuildRequires: Qt5Qml-devel >= %{qtdeclarative_ver}
23BuildRequires: Qt5Quick-devel >= %{qtdeclarative_ver}
a4e247e7
JB
24# for examples
25BuildRequires: Qt5WebSockets-devel >= %{qtwebsockets_ver}
a0bb59d8 26%if %{with doc}
1302c287
JB
27BuildRequires: qt5-assistant >= %{qttools_ver}
28%endif
29BuildRequires: qt5-build >= %{qtbase_ver}
30BuildRequires: qt5-qmake >= %{qtbase_ver}
a4e247e7 31BuildRequires: rpmbuild(macros) >= 1.752
1302c287
JB
32BuildRequires: tar >= 1:1.22
33BuildRequires: xz
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%define specflags -fno-strict-aliasing
37%define qt5dir %{_libdir}/qt5
38
39%description
40Qt is a cross-platform application and UI framework. Using Qt, you can
41write web-enabled applications once and deploy them across desktop,
42mobile and embedded systems without rewriting the source code.
43
44This package contains Qt5 WebChannel library.
45
46%description -l pl.UTF-8
47Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
48Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
49systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
50źródłowego.
51
52Ten pakiet zawiera bibliotekę Qt5 WebChannel.
53
54%package -n Qt5WebChannel
55Summary: The Qt5 WebChannel library
56Summary(pl.UTF-8): Biblioteka Qt5 WebChannel
57Group: Libraries
58Requires: Qt5Core >= %{qtbase_ver}
59Requires: Qt5Network >= %{qtbase_ver}
60Requires: Qt5Qml >= %{qtdeclarative_ver}
61
62%description -n Qt5WebChannel
63Qt5 WebChannel library provides seamless integration of C++ and QML
64applications with HTML/JavaScript clients.
65
66%description -n Qt5WebChannel -l pl.UTF-8
67Biblioteka Qt5 WebChannel udostępnia integrację aplikacji C++ i QML z
68klientami w HTML-u/JavaScripcie.
69
70%package -n Qt5WebChannel-devel
71Summary: Qt5 WebChannel library - development files
72Summary(pl.UTF-8): Biblioteka Qt5 WebChannel - pliki programistyczne
73Group: Development/Libraries
74Requires: Qt5Core-devel >= %{qtbase_ver}
75Requires: Qt5Network-devel >= %{qtbase_ver}
76Requires: Qt5Qml-devel >= %{qtdeclarative_ver}
77Requires: Qt5WebChannel = %{version}-%{release}
78
79%description -n Qt5WebChannel-devel
80Qt5 WebChannel library - development files.
81
82%description -n Qt5WebChannel-devel -l pl.UTF-8
83Biblioteka Qt5 WebChannel - pliki programistyczne.
84
85%package doc
86Summary: Qt5 WebChannel documentation in HTML format
87Summary(pl.UTF-8): Dokumentacja do biblioteki Qt5 WebChannel w formacie HTML
88Group: Documentation
89Requires: qt5-doc-common >= %{qtbase_ver}
d770636d 90BuildArch: noarch
1302c287
JB
91
92%description doc
93Qt5 WebChannel documentation in HTML format.
94
95%description doc -l pl.UTF-8
96Dokumentacja do biblioteki Qt5 WebChannel w formacie HTML.
97
98%package doc-qch
99Summary: Qt5 WebChannel documentation in QCH format
100Summary(pl.UTF-8): Dokumentacja do biblioteki Qt5 WebChannel w formacie QCH
101Group: Documentation
102Requires: qt5-doc-common >= %{qtbase_ver}
d770636d 103BuildArch: noarch
1302c287
JB
104
105%description doc-qch
106Qt5 WebChannel documentation in QCH format.
107
108%description doc-qch -l pl.UTF-8
109Dokumentacja do biblioteki Qt5 WebChannel w formacie QCH.
110
111%package examples
112Summary: Qt5 WebChannel examples
113Summary(pl.UTF-8): Przykłady do biblioteki Qt5 WebChannel
114Group: X11/Development/Libraries
d770636d 115BuildArch: noarch
1302c287
JB
116
117%description examples
118Qt5 WebChannel examples.
119
120%description examples -l pl.UTF-8
121Przykłady do biblioteki Qt5 WebChannel.
122
123%prep
c7f74bb9 124%setup -q -n %{orgname}-everywhere-src-%{version}
1302c287 125
898b061f
JP
126%{__sed} -i -e '1{
127 s,^#!.*bin/env node,#!/usr/bin/node,
128}' \
129 examples/webchannel/qwclient/qwclient.js
130
1302c287
JB
131%build
132qmake-qt5
133%{__make}
a0bb59d8 134%{?with_doc:%{__make} docs}
1302c287
JB
135
136%install
137rm -rf $RPM_BUILD_ROOT
138%{__make} install \
139 INSTALL_ROOT=$RPM_BUILD_ROOT
140
a0bb59d8
JR
141%if %{with doc}
142%{__make} install_docs \
1302c287 143 INSTALL_ROOT=$RPM_BUILD_ROOT
a0bb59d8 144%endif
1302c287
JB
145
146# useless symlinks
c7f74bb9 147%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
1302c287
JB
148# actually drop *.la, follow policy of not packaging them when *.pc exist
149%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
150
151# Prepare some files list
152ifecho() {
153 r="$RPM_BUILD_ROOT$2"
154 if [ -d "$r" ]; then
155 echo "%%dir $2" >> $1.files
156 elif [ -x "$r" ] ; then
157 echo "%%attr(755,root,root) $2" >> $1.files
158 elif [ -f "$r" ]; then
159 echo "$2" >> $1.files
160 else
161 echo "Error generation $1 files list!"
162 echo "$r: no such file or directory!"
163 return 1
164 fi
165}
166ifecho_tree() {
167 ifecho $1 $2
168 for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
169 ifecho $1 $2/$f
170 done
171}
172
173echo "%defattr(644,root,root,755)" > examples.files
1302c287
JB
174ifecho_tree examples %{_examplesdir}/qt5/webchannel
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179%post -n Qt5WebChannel -p /sbin/ldconfig
180%postun -n Qt5WebChannel -p /sbin/ldconfig
181
182%files -n Qt5WebChannel
183%defattr(644,root,root,755)
c7f74bb9 184%doc LICENSE.GPL3-EXCEPT README.md
a4e247e7 185# R: Core Qml
1302c287
JB
186%attr(755,root,root) %{_libdir}/libQt5WebChannel.so.*.*.*
187%attr(755,root,root) %ghost %{_libdir}/libQt5WebChannel.so.5
188%dir %{qt5dir}/qml/QtWebChannel
a4e247e7 189# R: Core Qml
1302c287
JB
190%attr(755,root,root) %{qt5dir}/qml/QtWebChannel/libdeclarative_webchannel.so
191%{qt5dir}/qml/QtWebChannel/plugins.qmltypes
192%{qt5dir}/qml/QtWebChannel/qmldir
193
194%files -n Qt5WebChannel-devel
195%defattr(644,root,root,755)
196%attr(755,root,root) %{_libdir}/libQt5WebChannel.so
197%{_libdir}/libQt5WebChannel.prl
198%{_includedir}/qt5/QtWebChannel
199%{_pkgconfigdir}/Qt5WebChannel.pc
200%{_libdir}/cmake/Qt5WebChannel
201%{qt5dir}/mkspecs/modules/qt_lib_webchannel.pri
202%{qt5dir}/mkspecs/modules/qt_lib_webchannel_private.pri
203
a0bb59d8 204%if %{with doc}
1302c287
JB
205%files doc
206%defattr(644,root,root,755)
207%{_docdir}/qt5-doc/qtwebchannel
208
1302c287
JB
209%files doc-qch
210%defattr(644,root,root,755)
211%{_docdir}/qt5-doc/qtwebchannel.qch
212%endif
213
214%files examples -f examples.files
215%defattr(644,root,root,755)
216# XXX: dir shared with qt5-qtbase-examples
217%dir %{_examplesdir}/qt5
This page took 0.152739 seconds and 4 git commands to generate.