]> git.pld-linux.org Git - packages/qt5-qtwayland.git/blame - qt5-qtwayland.spec
up to 5.13.2
[packages/qt5-qtwayland.git] / qt5-qtwayland.spec
CommitLineData
a8039504
JB
1# TODO:
2# - brcm_egl, libhybris_egl_server
a8039504
JB
3#
4# Conditional build:
3e38b839 5%bcond_without doc # Build documentation
7bafbebe 6%bcond_without qtcompositor # QtCompositor API
a8039504
JB
7
8%define orgname qtwayland
9%define qtbase_ver %{version}
10%define qtdeclarative_ver %{version}
11%define qttools_ver %{version}
12Summary: The Qt5 Wayland libraries
13Summary(pl.UTF-8): Biblioteki Qt5 Wayland
14Name: qt5-%{orgname}
c5f110eb 15Version: 5.13.2
4368f08c 16Release: 1
a8039504
JB
17License: LGPL v2.1 with Digia Qt LGPL Exception v1.1 or GPL v3.0
18Group: Libraries
51a4f380 19Source0: http://download.qt.io/official_releases/qt/5.13/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
c5f110eb 20# Source0-md5: cdd20ba344d3786b69ced5510f04feed
c4b09868 21URL: http://www.qt.io/
a8039504 22BuildRequires: EGL-devel
a8039504 23BuildRequires: OpenGL-GLX-devel
51a4f380 24BuildRequires: Qt5AccessibilitySupport-devel >= %{qtbase_ver}
a8039504 25BuildRequires: Qt5Core-devel >= %{qtbase_ver}
7bbe6e0b
JR
26BuildRequires: Qt5EglSupport-devel >= %{qtbase_ver}
27BuildRequires: Qt5EventDispatcherSupport-devel >= %{qtbase_ver}
28BuildRequires: Qt5FontDatabaseSupport-devel >= %{qtbase_ver}
29BuildRequires: Qt5GlxSupport-devel >= %{qtbase_ver}
a8039504 30BuildRequires: Qt5Gui-devel >= %{qtbase_ver}
7bbe6e0b
JR
31BuildRequires: Qt5PlatformCompositorSupport-devel >= %{qtbase_ver}
32BuildRequires: Qt5ServiceSupport-devel >= %{qtbase_ver}
33BuildRequires: Qt5ThemeSupport-devel >= %{qtbase_ver}
51a4f380 34BuildRequires: Qt5XkbCommonSupport-devel >= %{qtbase_ver}
a8039504 35BuildRequires: pkgconfig
3e38b839 36%if %{with doc}
a8039504
JB
37BuildRequires: qt5-assistant >= %{qttools_ver}
38%endif
39BuildRequires: qt5-build >= %{qtbase_ver}
40BuildRequires: qt5-qmake >= %{qtbase_ver}
41BuildRequires: rpmbuild(macros) >= 1.654
42BuildRequires: tar >= 1:1.22
c4b09868 43BuildRequires: wayland-devel >= 1.4.0
fd01c400 44BuildRequires: wayland-egl-devel
a8039504
JB
45BuildRequires: xorg-lib-libXcomposite-devel
46BuildRequires: xorg-lib-libxkbcommon-devel >= 0.2.0
47BuildRequires: xz
7bafbebe
JB
48%if %{with qtcompositor}
49BuildRequires: Qt5Qml-devel >= %{qtdeclarative_ver}
50BuildRequires: Qt5Quick-devel >= %{qtdeclarative_ver}
51BuildRequires: xorg-lib-libX11-devel
52%endif
a8039504
JB
53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55%define specflags -fno-strict-aliasing
56%define qt5dir %{_libdir}/qt5
57
58%description
59Qt is a cross-platform application and UI framework. Using Qt, you can
60write web-enabled applications once and deploy them across desktop,
61mobile and embedded systems without rewriting the source code.
62
63This package contains Qt5 Wayland libraries.
64
65%description -l pl.UTF-8
66Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
67Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
68systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
69źródłowego.
70
71Ten pakiet zawiera biblioteki Qt5 Wayland.
72
7bbe6e0b
JR
73%package -n Qt5WaylandCompositor
74Summary: The Qt5 WaylandCompositor library
75Summary(pl.UTF-8): Biblioteka Qt5 WaylandCompositor
7bafbebe
JB
76Group: Libraries
77Requires: Qt5Core >= %{qtbase_ver}
78Requires: Qt5Gui >= %{qtbase_ver}
79Requires: Qt5Network >= %{qtbase_ver}
80Requires: Qt5Qml >= %{qtdeclarative_ver}
81Requires: Qt5Quick >= %{qtdeclarative_ver}
c4b09868 82Requires: wayland >= 1.4.0
7bafbebe 83Requires: xorg-lib-libxkbcommon >= 0.2.0
7bbe6e0b 84Obsoletes: Qt5Compositor
7bafbebe 85
7bbe6e0b
JR
86%description -n Qt5WaylandCompositor
87Qt5 WaylandCompositor library enables the creation of Wayland
88compositors using Qt and QtQuick.
7bafbebe 89
7bbe6e0b
JR
90%description -n Qt5WaylandCompositor -l pl.UTF-8
91Biblioteka Qt5 WaylandCompositor pozwala na tworzenie kompozytorów
92Wayland przy użyciu bibliotek Qt i QtQuick.
7bafbebe 93
7bbe6e0b
JR
94%package -n Qt5WaylandCompositor-devel
95Summary: Qt5 WaylandCompositor library - development files
96Summary(pl.UTF-8): Biblioteka Qt5 WaylandCompositor - pliki programistyczne
7bafbebe
JB
97Group: Development/Libraries
98Requires: OpenGL-devel
178f84e3 99Requires: Qt5WaylandCompositor = %{version}-%{release}
7bafbebe
JB
100Requires: Qt5Core-devel >= %{qtbase_ver}
101Requires: Qt5Gui-devel >= %{qtbase_ver}
102Requires: Qt5Network-devel >= %{qtbase_ver}
103Requires: Qt5Qml-devel >= %{qtdeclarative_ver}
104Requires: Qt5Quick-devel >= %{qtdeclarative_ver}
c4b09868 105Requires: wayland-devel >= 1.4.0
7bafbebe 106Requires: xorg-lib-libxkbcommon-devel >= 0.2.0
7bbe6e0b 107Obsoletes: Qt5Compositor-devel
7bafbebe 108
7bbe6e0b
JR
109%description -n Qt5WaylandCompositor-devel
110Qt5 WaylandCompositor library - development files.
7bafbebe 111
7bbe6e0b
JR
112%description -n Qt5WaylandCompositor-devel -l pl.UTF-8
113Biblioteka Qt5 WaylandCompositor - pliki programistyczne.
7bafbebe 114
a8039504
JB
115%package -n Qt5WaylandClient
116Summary: The Qt5 WaylandClient library
117Summary(pl.UTF-8): Biblioteka Qt5 WaylandClient
118Group: Libraries
119Requires: Qt5Core >= %{qtbase_ver}
120Requires: Qt5Gui >= %{qtbase_ver}
c4b09868 121Requires: wayland >= 1.4.0
7bafbebe 122Requires: xorg-lib-libxkbcommon >= 0.2.0
a8039504
JB
123
124%description -n Qt5WaylandClient
125Qt5 WaylandClient library enables Qt applications to be run as Wayland
126clients.
127
128%description -n Qt5WaylandClient -l pl.UTF-8
129Biblioteka Qt5 WaylandClient pozwala na uruchamianie aplikacji Qt jako
130klientów Wayland.
131
132%package -n Qt5WaylandClient-devel
133Summary: Qt5 WaylandClient library - development files
134Summary(pl.UTF-8): Biblioteka Qt5 WaylandClient - pliki programistyczne
135Group: Development/Libraries
136Requires: Qt5Core-devel >= %{qtbase_ver}
137Requires: Qt5DBus-devel >= %{qtbase_ver}
138Requires: Qt5Gui-devel >= %{qtbase_ver}
178f84e3 139Requires: Qt5PlatformCompositorSupport-devel >= %{qtbase_ver}
a8039504 140Requires: Qt5WaylandClient = %{version}-%{release}
c4b09868 141Requires: wayland-devel >= 1.4.0
7bafbebe 142Requires: xorg-lib-libxkbcommon-devel >= 0.2.0
a8039504
JB
143
144%description -n Qt5WaylandClient-devel
145Qt5 WaylandClient library - development files.
146
147%description -n Qt5WaylandClient-devel -l pl.UTF-8
148Biblioteka Qt5 WaylandClient - pliki programistyczne.
149
150%package doc
151Summary: Qt5 Wayland documentation in HTML format
152Summary(pl.UTF-8): Dokumentacja do bibliotek Qt5 Wayland w formacie HTML
153Group: Documentation
154Requires: qt5-doc-common >= %{qtbase_ver}
155%if "%{_rpmversion}" >= "5"
156BuildArch: noarch
157%endif
158
159%description doc
160Qt5 Wayland documentation in HTML format.
161
162%description doc -l pl.UTF-8
163Dokumentacja do bibliotek Qt5 Wayland w formacie HTML.
164
165%package doc-qch
166Summary: Qt5 Wayland documentation in QCH format
167Summary(pl.UTF-8): Dokumentacja do bibliotek Qt5 Wayland w formacie QCH
168Group: Documentation
169Requires: qt5-doc-common >= %{qtbase_ver}
170%if "%{_rpmversion}" >= "5"
171BuildArch: noarch
172%endif
173
174%description doc-qch
175Qt5 Wayland documentation in QCH format.
176
177%description doc-qch -l pl.UTF-8
178Dokumentacja do bibliotek Qt5 Wayland w formacie QCH.
179
180%package examples
181Summary: Qt5 Wayland examples
182Summary(pl.UTF-8): Przykłady do bibliotek Qt5 Wayland
183Group: X11/Development/Libraries
184%if "%{_rpmversion}" >= "5"
185BuildArch: noarch
186%endif
187
188%description examples
189Qt5 Wayland examples.
190
191%description examples -l pl.UTF-8
192Przykłady do bibliotek Qt5 Wayland.
193
194%prep
4368f08c 195%setup -q -n %{orgname}-everywhere-src-%{version}
a8039504
JB
196
197%build
7bafbebe
JB
198qmake-qt5 \
199 %{?with_qtcompositor:CONFIG+=wayland-compositor}
a8039504 200%{__make}
3e38b839 201%{?with_doc:%{__make} docs}
a8039504
JB
202
203%install
204rm -rf $RPM_BUILD_ROOT
205%{__make} install \
206 INSTALL_ROOT=$RPM_BUILD_ROOT
207
3e38b839
JR
208%if %{with doc}
209%{__make} install_docs \
a8039504 210 INSTALL_ROOT=$RPM_BUILD_ROOT
3e38b839 211%endif
a8039504
JB
212
213# useless symlinks
4368f08c 214%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
a8039504 215# actually drop *.la, follow policy of not packaging them when *.pc exist
7bafbebe 216%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
a8039504 217
a8039504
JB
218# Prepare some files list
219ifecho() {
220 r="$RPM_BUILD_ROOT$2"
221 if [ -d "$r" ]; then
222 echo "%%dir $2" >> $1.files
223 elif [ -x "$r" ] ; then
224 echo "%%attr(755,root,root) $2" >> $1.files
225 elif [ -f "$r" ]; then
226 echo "$2" >> $1.files
227 else
228 echo "Error generation $1 files list!"
229 echo "$r: no such file or directory!"
230 return 1
231 fi
232}
233ifecho_tree() {
234 ifecho $1 $2
235 for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
236 ifecho $1 $2/$f
237 done
238}
239
c4b09868 240# examples present only for QtCompositor (as of 5.5.1)
7bafbebe
JB
241%if %{with qtcompositor}
242echo "%defattr(644,root,root,755)" > examples.files
243ifecho_tree examples %{_examplesdir}/qt5/wayland
244%endif
a8039504
JB
245
246%clean
247rm -rf $RPM_BUILD_ROOT
248
7bbe6e0b
JR
249%post -n Qt5WaylandCompositor -p /sbin/ldconfig
250%postun -n Qt5WaylandCompositor -p /sbin/ldconfig
7bafbebe 251
a8039504
JB
252%post -n Qt5WaylandClient -p /sbin/ldconfig
253%postun -n Qt5WaylandClient -p /sbin/ldconfig
254
7bafbebe 255%if %{with qtcompositor}
7bbe6e0b 256%files -n Qt5WaylandCompositor
7bafbebe 257%defattr(644,root,root,755)
7bbe6e0b
JR
258%attr(755,root,root) %{_libdir}/libQt5WaylandCompositor.so.*.*.*
259%attr(755,root,root) %ghost %{_libdir}/libQt5WaylandCompositor.so.5
7bafbebe
JB
260%attr(755,root,root) %{qt5dir}/plugins/platforms/libqwayland-xcomposite-egl.so
261%attr(755,root,root) %{qt5dir}/plugins/platforms/libqwayland-xcomposite-glx.so
262%dir %{qt5dir}/plugins/wayland-graphics-integration-server
263%attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-server/libdrm-egl-server.so
fd01c400 264%attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-server/libqt-plugin-wayland-egl.so
4368f08c 265%attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-server/libshm-emulation-server.so
fd01c400 266%attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-server/libwayland-eglstream-controller.so
7bafbebe
JB
267%attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-server/libxcomposite-egl.so
268%attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-server/libxcomposite-glx.so
7bbe6e0b
JR
269%dir %{qt5dir}/qml/QtWayland
270%dir %{qt5dir}/qml/QtWayland/Compositor
271%attr(755,root,root) %{qt5dir}/qml/QtWayland/Compositor/libqwaylandcompositorplugin.so
272%{qt5dir}/qml/QtWayland/Compositor/plugins.qmltypes
273%{qt5dir}/qml/QtWayland/Compositor/qmldir
7bafbebe 274
7bbe6e0b 275%files -n Qt5WaylandCompositor-devel
7bafbebe 276%defattr(644,root,root,755)
7bbe6e0b
JR
277%attr(755,root,root) %{_libdir}/libQt5WaylandCompositor.so
278%{_libdir}/libQt5WaylandCompositor.prl
279%{_includedir}/qt5/QtWaylandCompositor
280%{_pkgconfigdir}/Qt5WaylandCompositor.pc
4368f08c
BS
281%{_libdir}/cmake/Qt5Gui/Qt5Gui_QWaylandXCompositeEglPlatformIntegrationPlugin.cmake
282%{_libdir}/cmake/Qt5Gui/Qt5Gui_QWaylandXCompositeGlxPlatformIntegrationPlugin.cmake
7bbe6e0b
JR
283%{_libdir}/cmake/Qt5WaylandCompositor
284%{qt5dir}/mkspecs/modules/qt_lib_waylandcompositor.pri
285%{qt5dir}/mkspecs/modules/qt_lib_waylandcompositor_private.pri
7bafbebe
JB
286%endif
287
a8039504
JB
288%files -n Qt5WaylandClient
289%defattr(644,root,root,755)
4368f08c 290%doc LICENSE.GPL3-EXCEPT README
a8039504
JB
291# dist/changes-*
292%attr(755,root,root) %{_libdir}/libQt5WaylandClient.so.*.*.*
293%attr(755,root,root) %ghost %{_libdir}/libQt5WaylandClient.so.5
294%attr(755,root,root) %{qt5dir}/bin/qtwaylandscanner
295%attr(755,root,root) %{qt5dir}/plugins/platforms/libqwayland-egl.so
296%attr(755,root,root) %{qt5dir}/plugins/platforms/libqwayland-generic.so
297%dir %{qt5dir}/plugins/wayland-decoration-client
298%attr(755,root,root) %{qt5dir}/plugins/wayland-decoration-client/libbradient.so
299%dir %{qt5dir}/plugins/wayland-graphics-integration-client
300%attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-client/libdrm-egl-server.so
4368f08c
BS
301%attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-client/libqt-plugin-wayland-egl.so
302%attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-client/libshm-emulation-server.so
a8039504
JB
303%attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-client/libxcomposite-egl.so
304%attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-client/libxcomposite-glx.so
7bbe6e0b 305%dir %{qt5dir}/plugins/wayland-shell-integration
51a4f380 306%attr(755,root,root) %{qt5dir}/plugins/wayland-shell-integration/libfullscreen-shell-v1.so
7bbe6e0b 307%attr(755,root,root) %{qt5dir}/plugins/wayland-shell-integration/libivi-shell.so
fd01c400
JP
308%attr(755,root,root) %{qt5dir}/plugins/wayland-shell-integration/libwl-shell.so
309%attr(755,root,root) %{qt5dir}/plugins/wayland-shell-integration/libxdg-shell.so
310%attr(755,root,root) %{qt5dir}/plugins/wayland-shell-integration/libxdg-shell-v5.so
311%attr(755,root,root) %{qt5dir}/plugins/wayland-shell-integration/libxdg-shell-v6.so
a8039504
JB
312
313%files -n Qt5WaylandClient-devel
314%defattr(644,root,root,755)
315%attr(755,root,root) %{_libdir}/libQt5WaylandClient.so
316%{_libdir}/libQt5WaylandClient.prl
317%{_includedir}/qt5/QtWaylandClient
318%{_pkgconfigdir}/Qt5WaylandClient.pc
4368f08c
BS
319%{_libdir}/cmake/Qt5Gui/Qt5Gui_QWaylandEglPlatformIntegrationPlugin.cmake
320%{_libdir}/cmake/Qt5Gui/Qt5Gui_QWaylandIntegrationPlugin.cmake
7bbe6e0b 321%{_libdir}/cmake/Qt5WaylandClient
a8039504
JB
322%{qt5dir}/mkspecs/modules/qt_lib_waylandclient.pri
323%{qt5dir}/mkspecs/modules/qt_lib_waylandclient_private.pri
324
3e38b839 325%if %{with doc}
a8039504
JB
326%files doc
327%defattr(644,root,root,755)
3e38b839 328%{_docdir}/qt5-doc/qtwaylandcompositor
a8039504 329
a8039504
JB
330%files doc-qch
331%defattr(644,root,root,755)
3e38b839 332%{_docdir}/qt5-doc/qtwaylandcompositor.qch
a8039504
JB
333%endif
334
7bafbebe 335%if %{with qtcompositor}
a8039504
JB
336%files examples -f examples.files
337%defattr(644,root,root,755)
338# XXX: dir shared with qt5-qtbase-examples
339%dir %{_examplesdir}/qt5
340%endif
This page took 0.103625 seconds and 4 git commands to generate.