]> git.pld-linux.org Git - packages/qt5-qtserialport.git/blame - qt5-qtserialport.spec
- pl, partially cleaned up/unified with other qt5-*
[packages/qt5-qtserialport.git] / qt5-qtserialport.spec
CommitLineData
2950c847
WF
1# TODO:
2# - cleanup
c639f547
JB
3#
4# Conditional build:
5%bcond_without qch # documentation in QCH format
2950c847
WF
6
7%define orgname qtserialport
c639f547
JB
8%define qtbase_ver %{version}
9%define qttools_ver %{version}
10Summary: The Qt5 SerialPort library
11Summary(pl.UTF-8): Biblioteka Qt5 SerialPort
2950c847
WF
12Name: qt5-%{orgname}
13Version: 5.2.0
14Release: 0.1
15License: LGPL v2.1 or GPL v3.0
16Group: Libraries
17Source0: http://download.qt-project.org/official_releases/qt/5.2/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
18# Source0-md5: 7b90e0707b698331226e662bd39945e9
19URL: http://qt-project.org/
c639f547
JB
20BuildRequires: qt5-qtbase-devel = %{qtbase_ver}
21BuildRequires: qt5-qttools-devel = %{qttools_ver}
22%if %{with qch}
23BuildRequires: qt5-assistant >= %{qttools_ver}
24%endif
25BuildRequires: qt5-build >= %{qtbase_ver}
26BuildRequires: qt5-qmake >= %{qtbase_ver}
2950c847 27BuildRequires: rpmbuild(macros) >= 1.654
16017d76
ER
28BuildRequires: tar >= 1:1.22
29BuildRequires: xz
2950c847
WF
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
2950c847 32%define specflags -fno-strict-aliasing
c639f547 33%define qt5dir %{_libdir}/qt5
2950c847
WF
34
35%description
c639f547
JB
36Qt is a cross-platform application and UI framework. Using Qt, you can
37write web-enabled applications once and deploy them across desktop,
38mobile and embedded systems without rewriting the source code.
39
40This package contains Qt5 SerialPort library.
41
42%description -l pl.UTF-8
43Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
44Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
45systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
46źródłowego.
47
48Ten pakiet zawiera bibliotekę Qt5 SerialPort.
49
50%package -n Qt5SerialPort
51Summary: The Qt5 SerialPort library
52Summary(pl.UTF-8): Biblioteka Qt5 SerialPort
53Group: Libraries
54Requires: Qt5Core >= %{qtbase_ver}
55Obsoletes: qt5-qtserialport
2950c847 56
c639f547
JB
57%description -n Qt5SerialPort
58Qt5 SerialPort library provides [...]
59
60%description -n Qt5SerialPort -l pl.UTF_8
61Biblioteka Qt5 SerialPort [...]
62
63%package -n Qt5SerialPort-devel
64Summary: Qt5 SerialPort library - development files
65Summary(pl.UTF-8): Biblioteka Qt5 SerialPort - pliki programistyczne
2950c847 66Group: Development/Libraries
c639f547
JB
67Requires: Qt5Core-devel >= %{qtbase_ver}
68Requires: Qt5SerialPort = %{version}-%{release}
69Obsoletes: qt5-qtserialport-devel
70
71%description -n Qt5SerialPort-devel
72Qt5 SerialPort library - development files.
2950c847 73
c639f547
JB
74%description -n Qt5SerialPort-devel -l pl.UTF-8
75Biblioteka Qt5 SerialPort - pliki programistyczne.
2950c847
WF
76
77%package doc
c639f547
JB
78Summary: Qt5 SerialPort documentation in HTML format
79Summary(pl.UTF-8): Dokumentacja do biblioteki Qt5 SerialPort w formacie HTML
2950c847 80Group: Documentation
c639f547 81Requires: qt5-doc-common >= %{qtbase_ver}
16017d76
ER
82%if "%{_rpmversion}" >= "5"
83BuildArch: noarch
84%endif
2950c847
WF
85
86%description doc
c639f547
JB
87Qt5 SerialPort documentation in HTML format.
88
89%description doc -l pl.UTF-8
90Dokumentacja do biblioteki Qt5 SerialPort w formacie HTML.
91
92%package doc-qch
93Summary: Qt5 SerialPort documentation in QCH format
94Summary(pl.UTF-8): Dokumentacja do biblioteki Qt5 SerialPort w formacie QCH
95Group: Documentation
96Requires: qt5-doc-common >= %{qtbase_ver}
97%if "%{_rpmversion}" >= "5"
98BuildArch: noarch
99%endif
100
101%description doc-qch
102Qt5 SerialPort documentation in QCH format.
103
104%description doc-qch -l pl.UTF-8
105Dokumentacja do biblioteki Qt5 SerialPort w formacie QCH.
2950c847
WF
106
107%package examples
c639f547
JB
108Summary: Qt5 SerialPort examples
109Summary(pl.UTF-8): Przykłady do biblioteki Qt5 SerialPort
2950c847 110Group: Development/Libraries
16017d76
ER
111%if "%{_rpmversion}" >= "5"
112BuildArch: noarch
113%endif
2950c847
WF
114
115%description examples
c639f547
JB
116Qt5 SerialPort examples.
117
118%description examples -l pl.UTF-8
119Przykłady do biblioteki Qt5 SerialPort.
2950c847
WF
120
121%prep
122%setup -q -n %{orgname}-opensource-src-%{version}
123
124%build
125qmake-qt5
126%{__make}
c639f547 127%{__make} %{!?with_qch:html_}docs
2950c847
WF
128
129%install
130rm -rf $RPM_BUILD_ROOT
131%{__make} install \
132 INSTALL_ROOT=$RPM_BUILD_ROOT
133
c639f547 134%{__make} install_%{!?with_qch:html_}docs \
2950c847
WF
135 INSTALL_ROOT=$RPM_BUILD_ROOT
136
c639f547
JB
137# useless symlinks
138%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.?
139# actually drop *.la, follow policy of not packaging them when *.pc exist
140%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
141
2950c847
WF
142%clean
143rm -rf $RPM_BUILD_ROOT
144
c639f547
JB
145%post -n Qt5SerialPort -p /sbin/ldconfig
146%postun -n Qt5SerialPort -p /sbin/ldconfig
2950c847 147
c639f547 148%files -n Qt5SerialPort
2950c847 149%defattr(644,root,root,755)
c639f547
JB
150%attr(755,root,root) %{_libdir}/libQt5SerialPort.so.*.*.*
151%attr(755,root,root) %ghost %{_libdir}/libQt5SerialPort.so.5
152#%attr(755,root,root) %{qt5dir}/plugins
2950c847 153
c639f547 154%files -n Qt5SerialPort-devel
2950c847
WF
155%defattr(644,root,root,755)
156%attr(755,root,root) %{_libdir}/libQt5SerialPort.so
2950c847 157%{_libdir}/libQt5SerialPort.prl
2950c847 158%{_includedir}/qt5/QtSerialPort
c639f547
JB
159%{_pkgconfigdir}/Qt5SerialPort.pc
160%{_libdir}/cmake/Qt5SerialPort
161%{qt5dir}/mkspecs/modules/*.pri
2950c847
WF
162
163%files doc
164%defattr(644,root,root,755)
c639f547
JB
165%{_docdir}/qt5-doc/qtserialport
166
167%if %{with qch}
168%files doc-qch
169%defattr(644,root,root,755)
170%{_docdir}/qt5-doc/qtserialport.qch
171%endif
2950c847
WF
172
173#%files examples -f examples.files
This page took 0.10709 seconds and 4 git commands to generate.