]> git.pld-linux.org Git - packages/qt5-qtnetworkauth.git/blame - qt5-qtnetworkauth.spec
up to 5.15.12
[packages/qt5-qtnetworkauth.git] / qt5-qtnetworkauth.spec
CommitLineData
6721688c 1#
0958c88d
WF
2# Conditional build:
3%bcond_with bootstrap # disable features to able to build without installed qt5
6721688c 4%bcond_without doc # documentation
0958c88d
WF
5
6%if %{with bootstrap}
7%undefine with_doc
8%endif
9
10%define orgname qtnetworkauth
11%define qtbase_ver %{version}
12%define qtdeclarative_ver %{version}
6721688c 13%define qttools_ver 5.9
0958c88d
WF
14Summary: The Qt5 Network Auth library
15Summary(pl.UTF-8): Biblioteka Qt5 Network Auth
16Name: qt5-%{orgname}
c6f241f6 17Version: 5.15.12
980adf8e 18Release: 1
6721688c 19License: GPL v3 or commercial
0958c88d 20Group: X11/Libraries
980adf8e 21Source0: https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-opensource-src-%{version}.tar.xz
c6f241f6 22# Source0-md5: 5498cca731fc77b09e6488e14b29009c
6721688c 23URL: https://www.qt.io/
0958c88d 24BuildRequires: Qt5Core-devel >= %{qtbase_ver}
6721688c 25BuildRequires: Qt5Network-devel >= %{qtbase_ver}
0958c88d
WF
26%if %{with doc}
27BuildRequires: qt5-assistant >= %{qttools_ver}
28%endif
29BuildRequires: qt5-build >= %{qtbase_ver}
30BuildRequires: qt5-qmake >= %{qtbase_ver}
43cab9fe 31BuildRequires: rpm-build >= 4.6
b357a6de 32BuildRequires: rpmbuild(macros) >= 2.016
0958c88d
WF
33BuildRequires: tar >= 1:1.22
34BuildRequires: xz
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%define specflags -fno-strict-aliasing
38%define qt5dir %{_libdir}/qt5
39
40%description
41Qt is a cross-platform application and UI framework. Using Qt, you can
42write web-enabled applications once and deploy them across desktop,
43mobile and embedded systems without rewriting the source code.
44
45This package contains Qt5 Network Auth library.
46
47%description -l pl.UTF-8
48Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
49Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
50systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
51źródłowego.
52
53Ten pakiet zawiera bibliotekę Qt5 Network Auth.
54
55%package -n Qt5NetworkAuth
56Summary: The Qt5 Network Auth library
57Summary(pl.UTF-8): Biblioteka Qt5 Network Auth
58Group: Libraries
69e23457 59%requires_eq_to Qt5Core Qt5Core-devel
6721688c 60Requires: Qt5Network >= %{qtbase_ver}
0958c88d
WF
61
62%description -n Qt5NetworkAuth
63Qt5 Network Auth library provides classes for network authentication.
64
65%description -n Qt5NetworkAuth -l pl.UTF-8
6721688c
JB
66Biblioteka Qt5 Network Auth dostarcza klasy do uwierzytelniania w
67sieci.
0958c88d
WF
68
69%package -n Qt5NetworkAuth-devel
70Summary: Qt5 Network Auth library - development files
71Summary(pl.UTF-8): Biblioteka Qt5 Network Auth - pliki programistyczne
72Group: Development/Libraries
73Requires: Qt5Core-devel >= %{qtbase_ver}
6721688c 74Requires: Qt5Network-devel >= %{qtbase_ver}
0958c88d 75Requires: Qt5NetworkAuth = %{version}-%{release}
0958c88d
WF
76
77%description -n Qt5NetworkAuth-devel
78Qt5 Network Auth library - development files.
79
80%description -n Qt5NetworkAuth-devel -l pl.UTF-8
81Biblioteka Qt5 NetworkAuth - pliki programistyczne.
82
83%package doc
84Summary: Qt5 Network Auth documentation in HTML format
85Summary(pl.UTF-8): Dokumentacja do biblioteki Qt5 Network Auth w formacie HTML
6721688c 86License: FDL v1.3
0958c88d
WF
87Group: Documentation
88Requires: qt5-doc-common >= %{qtbase_ver}
bebac866 89BuildArch: noarch
0958c88d
WF
90
91%description doc
92Qt5 Network Auth documentation in HTML format.
93
94%description doc -l pl.UTF-8
95Dokumentacja do biblioteki Qt5 Netwok Auth w formacie HTML.
96
97%package doc-qch
98Summary: Qt5 Network Auth documentation in QCH format
99Summary(pl.UTF-8): Dokumentacja do biblioteki Qt5 Network Auth w formacie QCH
6721688c 100License: FDL v1.3
0958c88d
WF
101Group: Documentation
102Requires: qt5-doc-common >= %{qtbase_ver}
bebac866 103BuildArch: noarch
0958c88d
WF
104
105%description doc-qch
106Qt5 Network Auth documentation in QCH format.
107
108%description doc-qch -l pl.UTF-8
109Dokumentacja do biblioteki Qt5 Network Auth w formacie QCH.
110
111%package examples
112Summary: Qt5 Network Auth examples
113Summary(pl.UTF-8): Przykłady do biblioteki Qt5 Network Auth
6721688c 114License: BSD or commercial
0958c88d 115Group: X11/Development/Libraries
bebac866 116BuildArch: noarch
0958c88d
WF
117
118%description examples
119Qt5 Network Auth examples.
120
121%description examples -l pl.UTF-8
122Przykłady do biblioteki Qt5 Network Auth.
123
124%prep
125%setup -q -n %{orgname}-everywhere-src-%{version}
126
127%build
b357a6de 128%{qmake_qt5}
0958c88d 129%{__make}
43cab9fe 130
0958c88d
WF
131%{?with_doc:%{__make} docs}
132
133%install
134rm -rf $RPM_BUILD_ROOT
6721688c 135
0958c88d
WF
136%{__make} install \
137 INSTALL_ROOT=$RPM_BUILD_ROOT
138
139%if %{with doc}
140%{__make} install_docs \
141 INSTALL_ROOT=$RPM_BUILD_ROOT
142%endif
143
144# useless symlinks
145%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
146# actually drop *.la, follow policy of not packaging them when *.pc exist
147%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
148
0958c88d
WF
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%post -n Qt5NetworkAuth -p /sbin/ldconfig
153%postun -n Qt5NetworkAuth -p /sbin/ldconfig
154
155%files -n Qt5NetworkAuth
156%defattr(644,root,root,755)
157%doc LICENSE.GPL3-EXCEPT dist/changes-*
6721688c 158%attr(755,root,root) %{_libdir}/libQt5NetworkAuth.so.*.*.*
0958c88d 159%attr(755,root,root) %ghost %{_libdir}/libQt5NetworkAuth.so.5
0958c88d
WF
160
161%files -n Qt5NetworkAuth-devel
162%defattr(644,root,root,755)
6721688c
JB
163%attr(755,root,root) %{_libdir}/libQt5NetworkAuth.so
164%{_libdir}/libQt5NetworkAuth.prl
0958c88d
WF
165%{_includedir}/qt5/QtNetworkAuth
166%{_libdir}/cmake/Qt5NetworkAuth
0958c88d
WF
167%{_pkgconfigdir}/Qt5NetworkAuth.pc
168%{_libdir}/qt5/mkspecs/modules/qt_lib_networkauth.pri
169%{_libdir}/qt5/mkspecs/modules/qt_lib_networkauth_private.pri
170
171%if %{with doc}
172%files doc
173%defattr(644,root,root,755)
174%{_docdir}/qt5-doc/qtnetworkauth
175
176%files doc-qch
177%defattr(644,root,root,755)
178%{_docdir}/qt5-doc/qtnetworkauth.qch
179%endif
180
124b0f7f 181%files examples
0958c88d
WF
182%defattr(644,root,root,755)
183# XXX: dir shared with qt5-qtbase-examples
184%dir %{_examplesdir}/qt5
124b0f7f 185%{_examplesdir}/qt5/oauth
This page took 0.281481 seconds and 4 git commands to generate.