]> git.pld-linux.org Git - packages/qt5-qtnetworkauth.git/blame - qt5-qtnetworkauth.spec
- unconditional noarch subpackages
[packages/qt5-qtnetworkauth.git] / qt5-qtnetworkauth.spec
CommitLineData
6721688c 1#
0958c88d
WF
2# Conditional build:
3%bcond_with bootstrap # disable features to able to build without installed qt5
6721688c 4%bcond_without doc # documentation
0958c88d
WF
5
6%if %{with bootstrap}
7%undefine with_doc
8%endif
9
10%define orgname qtnetworkauth
11%define qtbase_ver %{version}
12%define qtdeclarative_ver %{version}
6721688c 13%define qttools_ver 5.9
0958c88d
WF
14Summary: The Qt5 Network Auth library
15Summary(pl.UTF-8): Biblioteka Qt5 Network Auth
16Name: qt5-%{orgname}
17Version: 5.12.3
6721688c
JB
18Release: 2
19License: GPL v3 or commercial
0958c88d
WF
20Group: X11/Libraries
21Source0: http://download.qt.io/official_releases/qt/5.12/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
22# Source0-md5: bc8f9a2e8e30476ba613c020f811c95c
6721688c 23URL: https://www.qt.io/
0958c88d 24BuildRequires: Qt5Core-devel >= %{qtbase_ver}
6721688c 25BuildRequires: Qt5Network-devel >= %{qtbase_ver}
0958c88d
WF
26%if %{with doc}
27BuildRequires: qt5-assistant >= %{qttools_ver}
28%endif
29BuildRequires: qt5-build >= %{qtbase_ver}
30BuildRequires: qt5-qmake >= %{qtbase_ver}
6721688c 31BuildRequires: rpmbuild(macros) >= 1.752
0958c88d
WF
32BuildRequires: tar >= 1:1.22
33BuildRequires: xz
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%define specflags -fno-strict-aliasing
37%define qt5dir %{_libdir}/qt5
38
39%description
40Qt is a cross-platform application and UI framework. Using Qt, you can
41write web-enabled applications once and deploy them across desktop,
42mobile and embedded systems without rewriting the source code.
43
44This package contains Qt5 Network Auth library.
45
46%description -l pl.UTF-8
47Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
48Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
49systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
50źródłowego.
51
52Ten pakiet zawiera bibliotekę Qt5 Network Auth.
53
54%package -n Qt5NetworkAuth
55Summary: The Qt5 Network Auth library
56Summary(pl.UTF-8): Biblioteka Qt5 Network Auth
57Group: Libraries
58Requires: Qt5Core >= %{qtbase_ver}
6721688c 59Requires: Qt5Network >= %{qtbase_ver}
0958c88d
WF
60
61%description -n Qt5NetworkAuth
62Qt5 Network Auth library provides classes for network authentication.
63
64%description -n Qt5NetworkAuth -l pl.UTF-8
6721688c
JB
65Biblioteka Qt5 Network Auth dostarcza klasy do uwierzytelniania w
66sieci.
0958c88d
WF
67
68%package -n Qt5NetworkAuth-devel
69Summary: Qt5 Network Auth library - development files
70Summary(pl.UTF-8): Biblioteka Qt5 Network Auth - pliki programistyczne
71Group: Development/Libraries
72Requires: Qt5Core-devel >= %{qtbase_ver}
6721688c 73Requires: Qt5Network-devel >= %{qtbase_ver}
0958c88d 74Requires: Qt5NetworkAuth = %{version}-%{release}
0958c88d
WF
75
76%description -n Qt5NetworkAuth-devel
77Qt5 Network Auth library - development files.
78
79%description -n Qt5NetworkAuth-devel -l pl.UTF-8
80Biblioteka Qt5 NetworkAuth - pliki programistyczne.
81
82%package doc
83Summary: Qt5 Network Auth documentation in HTML format
84Summary(pl.UTF-8): Dokumentacja do biblioteki Qt5 Network Auth w formacie HTML
6721688c 85License: FDL v1.3
0958c88d
WF
86Group: Documentation
87Requires: qt5-doc-common >= %{qtbase_ver}
bebac866 88BuildArch: noarch
0958c88d
WF
89
90%description doc
91Qt5 Network Auth documentation in HTML format.
92
93%description doc -l pl.UTF-8
94Dokumentacja do biblioteki Qt5 Netwok Auth w formacie HTML.
95
96%package doc-qch
97Summary: Qt5 Network Auth documentation in QCH format
98Summary(pl.UTF-8): Dokumentacja do biblioteki Qt5 Network Auth w formacie QCH
6721688c 99License: FDL v1.3
0958c88d
WF
100Group: Documentation
101Requires: qt5-doc-common >= %{qtbase_ver}
bebac866 102BuildArch: noarch
0958c88d
WF
103
104%description doc-qch
105Qt5 Network Auth documentation in QCH format.
106
107%description doc-qch -l pl.UTF-8
108Dokumentacja do biblioteki Qt5 Network Auth w formacie QCH.
109
110%package examples
111Summary: Qt5 Network Auth examples
112Summary(pl.UTF-8): Przykłady do biblioteki Qt5 Network Auth
6721688c 113License: BSD or commercial
0958c88d 114Group: X11/Development/Libraries
bebac866 115BuildArch: noarch
0958c88d
WF
116
117%description examples
118Qt5 Network Auth examples.
119
120%description examples -l pl.UTF-8
121Przykłady do biblioteki Qt5 Network Auth.
122
123%prep
124%setup -q -n %{orgname}-everywhere-src-%{version}
125
126%build
127qmake-qt5
128%{__make}
129%{?with_doc:%{__make} docs}
130
131%install
132rm -rf $RPM_BUILD_ROOT
6721688c 133
0958c88d
WF
134%{__make} install \
135 INSTALL_ROOT=$RPM_BUILD_ROOT
136
137%if %{with doc}
138%{__make} install_docs \
139 INSTALL_ROOT=$RPM_BUILD_ROOT
140%endif
141
142# useless symlinks
143%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
144# actually drop *.la, follow policy of not packaging them when *.pc exist
145%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
146
147# Prepare some files list
148ifecho() {
149 r="$RPM_BUILD_ROOT$2"
150 if [ -d "$r" ]; then
151 echo "%%dir $2" >> $1.files
152 elif [ -x "$r" ] ; then
153 echo "%%attr(755,root,root) $2" >> $1.files
154 elif [ -f "$r" ]; then
155 echo "$2" >> $1.files
156 else
157 echo "Error generation $1 files list!"
158 echo "$r: no such file or directory!"
159 return 1
160 fi
161}
162ifecho_tree() {
163 ifecho $1 $2
164 for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
165 ifecho $1 $2/$f
166 done
167}
168
169echo "%defattr(644,root,root,755)" > examples.files
170ifecho_tree examples %{_examplesdir}/qt5/oauth
171
172%clean
173rm -rf $RPM_BUILD_ROOT
174
175%post -n Qt5NetworkAuth -p /sbin/ldconfig
176%postun -n Qt5NetworkAuth -p /sbin/ldconfig
177
178%files -n Qt5NetworkAuth
179%defattr(644,root,root,755)
180%doc LICENSE.GPL3-EXCEPT dist/changes-*
6721688c 181%attr(755,root,root) %{_libdir}/libQt5NetworkAuth.so.*.*.*
0958c88d 182%attr(755,root,root) %ghost %{_libdir}/libQt5NetworkAuth.so.5
0958c88d
WF
183
184%files -n Qt5NetworkAuth-devel
185%defattr(644,root,root,755)
6721688c
JB
186%attr(755,root,root) %{_libdir}/libQt5NetworkAuth.so
187%{_libdir}/libQt5NetworkAuth.prl
0958c88d
WF
188%{_includedir}/qt5/QtNetworkAuth
189%{_libdir}/cmake/Qt5NetworkAuth
0958c88d
WF
190%{_pkgconfigdir}/Qt5NetworkAuth.pc
191%{_libdir}/qt5/mkspecs/modules/qt_lib_networkauth.pri
192%{_libdir}/qt5/mkspecs/modules/qt_lib_networkauth_private.pri
193
194%if %{with doc}
195%files doc
196%defattr(644,root,root,755)
197%{_docdir}/qt5-doc/qtnetworkauth
198
199%files doc-qch
200%defattr(644,root,root,755)
201%{_docdir}/qt5-doc/qtnetworkauth.qch
202%endif
203
204%files examples -f examples.files
205%defattr(644,root,root,755)
206# XXX: dir shared with qt5-qtbase-examples
207%dir %{_examplesdir}/qt5
This page took 0.142627 seconds and 4 git commands to generate.