]> git.pld-linux.org Git - packages/qscintilla2.git/blame - qscintilla2.spec
rebuild with python 3.10
[packages/qscintilla2.git] / qscintilla2.spec
CommitLineData
47f45644 1# TODO:
a9a3cc91 2# - fix building with qscintilla2(-devel) installed, remove BC
d86befc1 3# - how to successfully prepend -I../Qt4Qt5 before system qt include in qmake?
9ee0f3af 4#
d86befc1 5# Conditonal build:
7f136b4d
JR
6%bcond_without python2 # CPython 2.x module
7%bcond_without python3 # CPython 3.x module
d86befc1
JB
8%bcond_without qt4 # Qt4 library and modules
9%bcond_without qt5 # Qt5 library and modules
10
11%define scintilla_ver 3.3.6
ff1f7c20 12%define sip_ver 4.19
7f136b4d 13%define pyqt4_ver 1:4.12.1
586987ee 14%define pyqt5_ver 5.7.1
9ee0f3af 15Summary: QScintilla2 - a port to Qt of the Scintilla editing component
0bd4b1b2 16Summary(pl.UTF-8): QScintilla2 - port komponentu edytora Scintilla dla biblioteki Qt
9ee0f3af 17Name: qscintilla2
5391f258 18Version: 2.11.2
c0eee81e 19Release: 6
c333e7e3 20License: GPL v3
9ee0f3af 21Group: X11/Libraries
5391f258
JR
22Source0: https://www.riverbankcomputing.com/static/Downloads/QScintilla/%{version}/QScintilla_gpl-%{version}.tar.gz
23# Source0-md5: 2ec4833e790e44698c50ec703f274bab
9b858b8d 24Patch0: %{name}-internal_build.patch
d86befc1 25Patch3: %{name}-outoftree.patch
d7dc8e14 26Patch4: %{name}-qt5.patch
7f136b4d 27Patch5: py-config.patch
0279988b 28Patch6: python-install.patch
5391f258
JR
29Patch7: sip-check.patch
30Patch8: missing-header.patch
57b2ad6b 31Patch9: 0011-Fixed-the-Python-signatures-of-the-QsciAPIs-ctors.patch
9b858b8d 32URL: http://www.riverbankcomputing.co.uk/software/qscintilla/
d86befc1 33%if %{with python2}
d86befc1
JB
34BuildRequires: python-sip-devel >= 2:%{sip_ver}
35%endif
36%if %{with python3}
d86befc1
JB
37BuildRequires: python3-sip-devel >= 2:%{sip_ver}
38%endif
9ee0f3af 39BuildRequires: rpm-pythonprov
2b7936b6 40BuildRequires: rpmbuild(macros) >= 1.558
d86befc1
JB
41%if %{with qt4}
42BuildRequires: QtDesigner-devel >= 4.8
43BuildRequires: QtGui-devel >= 4.8
5391f258 44BuildRequires: QtNetwork-devel >= 4.8
d86befc1
JB
45BuildRequires: qt4-build >= 4.8
46BuildRequires: qt4-qmake >= 4.8
d7dc8e14
JB
47BuildRequires: sip-PyQt4 >= %{pyqt4_ver}
48%if %{with python2}
49BuildRequires: python-PyQt4 >= %{pyqt4_ver}
50%endif
51%if %{with python3}
52BuildRequires: python3-PyQt4 >= %{pyqt4_ver}
53%endif
d86befc1
JB
54%endif
55%if %{with qt5}
56BuildRequires: Qt5Designer-devel >= 5
57BuildRequires: Qt5Gui-devel >= 5
d7dc8e14 58BuildRequires: Qt5PrintSupport-devel >= 5
0279988b 59BuildRequires: Qt5UiTools-devel >= 5
d7dc8e14 60BuildRequires: Qt5Widgets-devel >= 5
d86befc1
JB
61BuildRequires: qt5-build >= 5
62BuildRequires: qt5-qmake >= 5
d7dc8e14
JB
63BuildRequires: sip-PyQt5 >= %{pyqt5_ver}
64%if %{with python2}
65BuildRequires: python-PyQt5 >= %{pyqt5_ver}
66%endif
67%if %{with python3}
68BuildRequires: python3-PyQt5 >= %{pyqt5_ver}
69%endif
d86befc1 70%endif
1dd6bff8
JB
71BuildConflicts: qscintilla2-devel < %{version}
72%{?with_qt4:BuildConflicts: qscintilla2-qt4-devel < %{version}}
73%{?with_qt5:BuildConflicts: qscintilla2-qt5-devel < %{version}}
9ee0f3af
KK
74BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76%define _sipfilesdir %{_datadir}/sip
77
78%description
79QScintilla2 is a port to Qt of the Scintilla editing component.
80This version of QScintilla is based on Scintilla v%{scintilla_ver}.
81
d2b29e31 82%description -l pl.UTF-8
23949924
JB
83QScintilla2 to port komponentu edytora Scintilla dla biblioteki Qt.
84Ta wersja QScintilli jest oparta na Scintilli %{scintilla_ver}.
85
d7dc8e14
JB
86%package apidocs
87Summary: QScintilla2 API documentation
88Summary(pl.UTF-8): Dokumentacja API biblioteki QScintilla2
89Group: Documentation
95bdea1a 90BuildArch: noarch
d7dc8e14
JB
91
92%description apidocs
93QScintilla2 API documentation.
94
95%description apidocs -l pl.UTF-8
96Dokumentacja API biblioteki QScintilla2.
97
98%package qt4
99Summary: QScintilla2 - a port to Qt 4 of the Scintilla editing component
100Summary(pl.UTF-8): QScintilla2 - port komponentu edytora Scintilla dla biblioteki Qt 4
101Group: X11/Libraries
d7dc8e14
JB
102%ifarch %{x8664} ppc64 s390x sparc64
103Provides: libqscintilla2.so.11()(64bit)
104%else
105Provides: libqscintilla2.so.11
106%endif
107Obsoletes: qscintilla2 < 2.8.4
108
109%description qt4
110QScintilla2 is a port to Qt of the Scintilla editing component.
111This version of QScintilla is based on Scintilla v%{scintilla_ver}.
112
113This package contains the Qt 4 port.
114
115%description qt4 -l pl.UTF-8
116QScintilla2 to port komponentu edytora Scintilla dla biblioteki Qt.
117Ta wersja QScintilli jest oparta na Scintilli %{scintilla_ver}.
118
119Ten pakiet zawiera port Qt 4.
120
121%package qt4-devel
122Summary: Development files for the QScintilla2 Qt 4 library
123Summary(pl.UTF-8): Pliki nagłówkowe biblioteki QScintilla2 dla Qt 4
9ee0f3af 124Group: X11/Development/Libraries
d7dc8e14
JB
125Requires: %{name}-qt4 = %{version}-%{release}
126Requires: QtGui-devel >= 4
127Obsoletes: qscintilla2-devel < 2.8.4
9ee0f3af 128
d7dc8e14 129%description qt4-devel
9ee0f3af 130This package contains the header files necessary to develop
d7dc8e14 131applications using QScintilla2 for Qt 4.
9ee0f3af 132
d7dc8e14 133%description qt4-devel -l pl.UTF-8
d2b29e31 134Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów z
d7dc8e14 135użyciem komponentu QScintilla2 dla Qt 4.
23949924 136
9ee0f3af
KK
137%package -n QtDesigner-plugin-%{name}
138Summary: QScintilla2 plugin for Qt Designer
0bd4b1b2 139Summary(pl.UTF-8): Wtyczka QScintilla2 dla Qt Designera
9ee0f3af 140Group: X11/Development/Libraries
d7dc8e14
JB
141Requires: %{name}-qt4 = %{version}-%{release}
142Requires: QtDesigner >= 4
9ee0f3af
KK
143
144%description -n QtDesigner-plugin-%{name}
145QScintilla2 plugin for Qt Designer that allows QScintilla instances
146to be included in GUI designs just like any other Qt widget.
147
d7dc8e14
JB
148This package contains the Qt 4 version.
149
d2b29e31
JR
150%description -n QtDesigner-plugin-%{name} -l pl.UTF-8
151Wtyczka WScintilla2 dla Qt Designera pozwalająca na włączanie
152instancji QScintilli w projekty GUI w ten sam sposób, co inne widgety
23949924
JB
153Qt.
154
d7dc8e14
JB
155Ten pakiet zawiera wersję dla Qt 4.
156
157%package -n sip-PyQt4-%{name}
158Summary: Python bindings for the QScintilla2 - SIP development files
159Summary(pl.UTF-8): Wiązania Pythona dla komponentu QScintilla2 - pliki programistyczne SIP
160Group: Development/Languages/Python
161Requires: sip-PyQt4 >= %{pyqt4_ver}
162Obsoletes: python-qscintilla2-devel < 2.8.4
163
164%description -n sip-PyQt4-%{name}
165Python bindings for the QScintilla2 - SIP development files.
166
167%description -n sip-PyQt4-%{name} -l pl.UTF-8
168Wiązania Pythona dla komponentu QScintilla2 - pliki programistyczne
169SIP.
170
171%package -n python-PyQt4-%{name}
172Summary: Python 2 bindings for the QScintilla2 (PyQt4 version)
173Summary(pl.UTF-8): Wiązania Pythona 2 dla komponentu QScintilla2 (wersja dla PyQt4)
9ee0f3af 174Group: Libraries/Python
d7dc8e14 175Requires: %{name}-qt4 = %{version}-%{release}
d86befc1 176%requires_ge python-PyQt4
d7dc8e14
JB
177Obsoletes: python-qscintilla2 < 2.8.4
178
179%description -n python-PyQt4-%{name}
180Python 2 bindings for the QScintilla2 (PyQt4 version).
181
182%description -n python-PyQt4-%{name} -l pl.UTF-8
183Wiązania Pythona 2 dla komponentu QScintilla2 (wersja dla PyQt4).
184
185%package -n python3-PyQt4-%{name}
186Summary: Python 3 bindings for the QScintilla2 (PyQt4 version)
187Summary(pl.UTF-8): Wiązania Pythona 3 dla komponentu QScintilla2 (wersja dla PyQt4)
188Group: Libraries/Python
189Requires: %{name}-qt4 = %{version}-%{release}
190%requires_ge python3-PyQt4
191
192%description -n python3-PyQt4-%{name}
193Python 3 bindings for the QScintilla2 (PyQt4 version).
194
195%description -n python3-PyQt4-%{name} -l pl.UTF-8
196Wiązania Pythona 3 dla komponentu QScintilla2 (wersja dla PyQt4).
197
198%package qt5
199Summary: QScintilla2 - a port to Qt 5 of the Scintilla editing component
200Summary(pl.UTF-8): QScintilla2 - port komponentu edytora Scintilla dla biblioteki Qt 5
201Group: X11/Libraries
d7dc8e14
JB
202
203%description qt5
204QScintilla2 is a port to Qt of the Scintilla editing component.
205This version of QScintilla is based on Scintilla v%{scintilla_ver}.
206
207This package contains the Qt 5 port.
208
209%description qt5 -l pl.UTF-8
210QScintilla2 to port komponentu edytora Scintilla dla biblioteki Qt.
211Ta wersja QScintilli jest oparta na Scintilli %{scintilla_ver}.
212
213Ten pakiet zawiera port Qt 5.
214
215%package qt5-devel
216Summary: Development files for the QScintilla2 Qt 5 library
217Summary(pl.UTF-8): Pliki nagłówkowe biblioteki QScintilla2 dla Qt 5
218Group: X11/Development/Libraries
219Requires: %{name}-qt5 = %{version}-%{release}
220Requires: Qt5Gui-devel >= 5
221Obsoletes: qscintilla2-devel < 2.8.4
222
223%description qt5-devel
224This package contains the header files necessary to develop
225applications using QScintilla2 for Qt 5.
226
227%description qt5-devel -l pl.UTF-8
228Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów z
229użyciem komponentu QScintilla2 dla Qt 5.
230
231%package -n Qt5Designer-plugin-%{name}
232Summary: QScintilla2 plugin for Qt Designer
233Summary(pl.UTF-8): Wtyczka QScintilla2 dla Qt Designera
234Group: X11/Development/Libraries
235Requires: %{name}-qt5 = %{version}-%{release}
236Requires: Qt5Designer >= 5
237
238%description -n Qt5Designer-plugin-%{name}
239QScintilla2 plugin for Qt Designer that allows QScintilla instances
240to be included in GUI designs just like any other Qt widget.
241
242This package contains the Qt 5 version.
9ee0f3af 243
d7dc8e14
JB
244%description -n Qt5Designer-plugin-%{name} -l pl.UTF-8
245Wtyczka WScintilla2 dla Qt Designera pozwalająca na włączanie
246instancji QScintilli w projekty GUI w ten sam sposób, co inne widgety
247Qt.
9ee0f3af 248
d7dc8e14 249Ten pakiet zawiera wersję dla Qt 5.
23949924 250
d7dc8e14
JB
251%package -n sip-PyQt5-%{name}
252Summary: Python bindings for the QScintilla2 - SIP development files
253Summary(pl.UTF-8): Wiązania Pythona dla komponentu QScintilla2 - pliki programistyczne SIP
9ee0f3af 254Group: Development/Languages/Python
d7dc8e14
JB
255Requires: sip-PyQt5 >= %{pyqt5_ver}
256
257%description -n sip-PyQt5-%{name}
258Python bindings for the QScintilla2 - SIP development files.
9ee0f3af 259
d7dc8e14
JB
260%description -n sip-PyQt5-%{name} -l pl.UTF-8
261Wiązania Pythona dla komponentu QScintilla2 - pliki programistyczne
262SIP.
9ee0f3af 263
d7dc8e14
JB
264%package -n python-PyQt5-%{name}
265Summary: Python 2 bindings for the QScintilla2 (PyQt5 version)
266Summary(pl.UTF-8): Wiązania Pythona 2 dla komponentu QScintilla2 (wersja dla PyQt5)
267Group: Libraries/Python
268Requires: %{name}-qt5 = %{version}-%{release}
269%requires_ge python-PyQt5
270
271%description -n python-PyQt5-%{name}
272Python 2 bindings for the QScintilla2 (PyQt5 version).
273
274%description -n python-PyQt5-%{name} -l pl.UTF-8
275Wiązania Pythona 2 dla komponentu QScintilla2 (wersja dla PyQt5).
276
277%package -n python3-PyQt5-%{name}
278Summary: Python 3 bindings for the QScintilla2 (PyQt5 version)
279Summary(pl.UTF-8): Wiązania Pythona 3 dla komponentu QScintilla2 (wersja dla PyQt5)
280Group: Libraries/Python
281Requires: %{name}-qt5 = %{version}-%{release}
282%requires_ge python3-PyQt5
283
284%description -n python3-PyQt5-%{name}
285Python 3 bindings for the QScintilla2 (PyQt5 version).
286
287%description -n python3-PyQt5-%{name} -l pl.UTF-8
288Wiązania Pythona 3 dla komponentu QScintilla2 (wersja dla PyQt5).
23949924 289
9ee0f3af 290%prep
5391f258 291%setup -q -n QScintilla_gpl-%{version}
9ee0f3af 292%patch0 -p1
586987ee 293%patch3 -p1
d7dc8e14 294%patch4 -p1
1dd6bff8 295%patch5 -p1
0279988b 296%patch6 -p1
5391f258
JR
297%patch7 -p1
298%patch8 -p1
57b2ad6b 299%patch9 -p1
9ee0f3af
KK
300
301%build
7f136b4d
JR
302for qt in %{?with_qt4:qt4} %{?with_qt5:qt5} ; do
303install -d build-${qt}/{Qt4Qt5,designer-Qt4Qt5,Python2,Python3}
304cd build-${qt}/Qt4Qt5
305qmake-${qt} ../../Qt4Qt5/qscintilla.pro \
306 $(test "$qt" = "qt4" || echo QMAKE_MKSPECS=%{_libdir}/$qt/mkspecs)
5391f258
JR
307%{__make}
308cd ../designer-Qt4Qt5
7f136b4d 309qmake-${qt} ../../designer-Qt4Qt5/designer.pro
5391f258
JR
310%{__make}
311cd ..
312
5391f258
JR
313%if %{with python2}
314cd Python2
315# setup PATH to get proper qmake
316# pass --apidir because configure.py default is inconsistent with sources (no /qsci subdir)
7f136b4d 317PATH=%{_libdir}/${qt}/bin:$PATH \
5391f258
JR
318%{__python} ../../Python/configure.py \
319 --verbose \
7f136b4d
JR
320 --concatenate \
321 --concatenate-split 3 \
5391f258
JR
322 -n ../../Qt4Qt5 \
323 -o ../Qt4Qt5 \
7f136b4d
JR
324 --apidir=%{_datadir}/${qt}/qsci \
325 --pyqt=PyQt${qt#qt}
5391f258
JR
326%{__make}
327cd ..
328%endif
329%if %{with python3}
330cd Python3
7f136b4d 331PATH=%{_libdir}/${qt}/bin:$PATH \
5391f258
JR
332%{__python3} ../../Python/configure.py \
333 --verbose \
7f136b4d
JR
334 --concatenate \
335 --concatenate-split 3 \
5391f258
JR
336 -n ../../Qt4Qt5 \
337 -o ../Qt4Qt5 \
7f136b4d
JR
338 --apidir=%{_datadir}/${qt}/qsci \
339 --pyqt=PyQt${qt#qt}
5391f258
JR
340%{__make}
341cd ..
342%endif
5391f258 343cd ..
7f136b4d 344done
9ee0f3af
KK
345
346%install
347rm -rf $RPM_BUILD_ROOT
348
7f136b4d
JR
349for qt in %{?with_qt4:qt4} %{?with_qt5:qt5} ; do
350%{__make} -j1 -C build-${qt}/Qt4Qt5 install \
9ee0f3af 351 INSTALL_ROOT=$RPM_BUILD_ROOT
7f136b4d 352%{__make} -j1 -C build-${qt}/designer-Qt4Qt5 install \
9ee0f3af 353 INSTALL_ROOT=$RPM_BUILD_ROOT
d86befc1 354%if %{with python3}
7f136b4d 355%{__make} -j1 -C build-${qt}/Python3 install \
47f45644 356 INSTALL_ROOT=$RPM_BUILD_ROOT
d86befc1
JB
357%endif
358%if %{with python2}
7f136b4d 359%{__make} -j1 -C build-${qt}/Python2 install \
d86befc1
JB
360 INSTALL_ROOT=$RPM_BUILD_ROOT
361%endif
7f136b4d 362done
9ee0f3af 363
d7dc8e14 364# unnecessary symlink
ed744e1c 365%{__rm} $RPM_BUILD_ROOT%{_libdir}/libqscintilla2*.so.15.0
d7dc8e14
JB
366
367%if %{with qt4}
368# move Qt4 translations to PLD-specific directory scheme
9ee0f3af
KK
369for file in $RPM_BUILD_ROOT%{_datadir}/locale/*.qm
370do
23949924
JB
371 lang=`echo $file | sed -r 's:.*/[a-zA-Z]*_(.*).qm:\1:'`
372 [ "$lang" == "pt_br" ] && lang=pt_BR
373 install -d $RPM_BUILD_ROOT%{_datadir}/locale/$lang/LC_MESSAGES
c333e7e3 374 %{__mv} $file $RPM_BUILD_ROOT%{_datadir}/locale/$lang/LC_MESSAGES/qscintilla2.qm
9ee0f3af 375done
d7dc8e14 376%endif
47f45644 377
9ee0f3af
KK
378%clean
379rm -rf $RPM_BUILD_ROOT
380
d7dc8e14
JB
381%post qt4 -p /sbin/ldconfig
382%postun qt4 -p /sbin/ldconfig
383
384%post qt5 -p /sbin/ldconfig
385%postun qt5 -p /sbin/ldconfig
9ee0f3af 386
d7dc8e14
JB
387%files apidocs
388%defattr(644,root,root,755)
389%doc doc/{Scintilla,html-Qt4Qt5}
390
391%if %{with qt4}
392%files qt4
9ee0f3af 393%defattr(644,root,root,755)
c333e7e3 394%doc NEWS README
ed744e1c
JR
395%attr(755,root,root) %{_libdir}/libqscintilla2_qt4.so.*.*.*
396%attr(755,root,root) %ghost %{_libdir}/libqscintilla2_qt4.so.15
739c851d 397%lang(cs) %{_datadir}/locale/cs/LC_MESSAGES/qscintilla2.qm
9ee0f3af 398%lang(de) %{_datadir}/locale/de/LC_MESSAGES/qscintilla2.qm
12a74d0d 399%lang(es) %{_datadir}/locale/es/LC_MESSAGES/qscintilla2.qm
9ee0f3af
KK
400%lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/qscintilla2.qm
401%lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/qscintilla2.qm
82fa3613
KK
402%dir %{_datadir}/qt4/qsci
403%dir %{_datadir}/qt4/qsci/api
d7dc8e14
JB
404%dir %{_datadir}/qt4/qsci/api/python
405%{_datadir}/qt4/qsci/api/python/Python-*.api
7f136b4d 406%{_datadir}/qt4/qsci/api/python/QScintilla2.api
9ee0f3af 407
d7dc8e14 408%files qt4-devel
9ee0f3af 409%defattr(644,root,root,755)
ed744e1c 410%attr(755,root,root) %{_libdir}/libqscintilla2_qt4.so
9ee0f3af 411%{_includedir}/qt4/Qsci
d86befc1 412%{_datadir}/qt4/mkspecs/features/qscintilla2.prf
9ee0f3af
KK
413
414%files -n QtDesigner-plugin-%{name}
9a281e92 415%defattr(644,root,root,755)
ece58d84 416%attr(755,root,root) %{_libdir}/qt4/plugins/designer/libqscintillaplugin.so
9ee0f3af 417
ed744e1c 418%if %{with python2} || %{with python3}
d7dc8e14
JB
419%files -n sip-PyQt4-%{name}
420%defattr(644,root,root,755)
421%{_sipfilesdir}/PyQt4/Qsci
ed744e1c 422%endif
d7dc8e14
JB
423
424%if %{with python2}
425%files -n python-PyQt4-%{name}
9ee0f3af 426%defattr(644,root,root,755)
ece58d84 427%attr(755,root,root) %{py_sitedir}/PyQt4/Qsci.so
7f136b4d 428%{py_sitedir}/PyQt4/Qsci.pyi
d7dc8e14 429%endif
9ee0f3af 430
d7dc8e14
JB
431%if %{with python3}
432%files -n python3-PyQt4-%{name}
9ee0f3af 433%defattr(644,root,root,755)
d7dc8e14 434%attr(755,root,root) %{py3_sitedir}/PyQt4/Qsci.so
7f136b4d 435%{py3_sitedir}/PyQt4/Qsci.pyi
d7dc8e14
JB
436%endif
437%endif
438
439%if %{with qt5}
440%files qt5
441%defattr(644,root,root,755)
c333e7e3 442%doc NEWS README
ed744e1c
JR
443%attr(755,root,root) %{_libdir}/libqscintilla2_qt5.so.*.*.*
444%attr(755,root,root) %ghost %{_libdir}/libqscintilla2_qt5.so.15
d7dc8e14
JB
445%lang(cs) %{_datadir}/qt5/translations/qscintilla_cs.qm
446%lang(de) %{_datadir}/qt5/translations/qscintilla_de.qm
447%lang(es) %{_datadir}/qt5/translations/qscintilla_es.qm
448%lang(fr) %{_datadir}/qt5/translations/qscintilla_fr.qm
449%lang(pt_BR) %{_datadir}/qt5/translations/qscintilla_pt_br.qm
450%dir %{_datadir}/qt5/qsci
451%dir %{_datadir}/qt5/qsci/api
452%dir %{_datadir}/qt5/qsci/api/python
453%{_datadir}/qt5/qsci/api/python/Python-*.api
7f136b4d 454%{_datadir}/qt5/qsci/api/python/QScintilla2.api
d7dc8e14
JB
455
456%files qt5-devel
457%defattr(644,root,root,755)
ed744e1c 458%attr(755,root,root) %{_libdir}/libqscintilla2_qt5.so
d7dc8e14 459%{_includedir}/qt5/Qsci
1dd6bff8 460%{_libdir}/qt5/mkspecs/features/qscintilla2.prf
d7dc8e14
JB
461
462%files -n Qt5Designer-plugin-%{name}
463%defattr(644,root,root,755)
464%attr(755,root,root) %{_libdir}/qt5/plugins/designer/libqscintillaplugin.so
465
ed744e1c 466%if %{with python2} || %{with python3}
d7dc8e14
JB
467%files -n sip-PyQt5-%{name}
468%defattr(644,root,root,755)
469%{_sipfilesdir}/PyQt5/Qsci
ed744e1c 470%endif
d7dc8e14
JB
471
472%if %{with python2}
473%files -n python-PyQt5-%{name}
474%defattr(644,root,root,755)
475%attr(755,root,root) %{py_sitedir}/PyQt5/Qsci.so
7f136b4d 476%{py_sitedir}/PyQt5/Qsci.pyi
d7dc8e14
JB
477%endif
478
479%if %{with python3}
480%files -n python3-PyQt5-%{name}
481%defattr(644,root,root,755)
482%attr(755,root,root) %{py3_sitedir}/PyQt5/Qsci.so
7f136b4d 483%{py3_sitedir}/PyQt5/Qsci.pyi
d7dc8e14
JB
484%endif
485%endif
This page took 0.143162 seconds and 4 git commands to generate.